Bug 1266647 - [abrt] WARNING: CPU: 0 PID: 2653 at fs/block_dev.c:57 __blkdev_put+0xc1/0x200()
[abrt] WARNING: CPU: 0 PID: 2653 at fs/block_dev.c:57 __blkdev_put+0xc1/0x200()
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
23
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:736da199a04d9d4808467faa771...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-25 23:10 EDT by Dumindu
Modified: 2016-09-23 16:11 EDT (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-09-23 16:02:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: dmesg (87.71 KB, text/plain)
2015-09-25 23:10 EDT, Dumindu
no flags Details

  None (edit)
Description Dumindu 2015-09-25 23:10:11 EDT
Additional info:
reporter:       libreport-2.6.2
WARNING: CPU: 0 PID: 2653 at fs/block_dev.c:57 __blkdev_put+0xc1/0x200()
Modules linked in: bnep bluetooth rfkill fuse xt_CHECKSUM ipt_MASQUERADE nf_nat_masquerade_ipv4 tun nf_conntrack_netbios_ns nf_conntrack_broadcast ip6t_rpfilter ip6t_REJECT nf_reject_ipv6 xt_conntrack ebtable_nat ebtable_filter ebtable_broute bridge ebtables ip6table_nat nf_conntrack_ipv6 nf_defrag_ipv6 nf_nat_ipv6 ip6table_security ip6table_mangle ip6table_raw ip6table_filter ip6_tables iptable_nat nf_conntrack_ipv4 nf_defrag_ipv4 nf_nat_ipv4 nf_nat nf_conntrack iptable_security iptable_mangle iptable_raw snd_hda_codec_realtek snd_hda_codec_generic gpio_ich iTCO_wdt iTCO_vendor_support coretemp serio_raw snd_hda_intel snd_hda_codec snd_hda_core snd_hwdep lpc_ich snd_seq snd_seq_device i2c_i801 snd_pcm mei_me mei snd_timer snd soundcore shpchp acpi_cpufreq nfsd auth_rpcgss nfs_acl lockd
 grace isofs squashfs 8021q garp stp llc mrp nouveau mxm_wmi wmi video i2c_algo_bit drm_kms_helper uas ttm usb_storage firewire_ohci drm e1000e ata_generic firewire_core pata_acpi crc_itu_t ptp pata_jmicron pps_core scsi_dh_rdac scsi_dh_emc scsi_dh_alua sunrpc loop
CPU: 0 PID: 2653 Comm: fsck.ext4 Not tainted 4.2.0-300.fc23.x86_64 #1
Hardware name:                  /DP43TF, BIOS NBG4310H.86A.0051.2008.0804.1738 08/04/2008
 0000000000000000 00000000a9cc06cc ffff8800255bfdb8 ffffffff817712aa
 0000000000000000 0000000000000000 ffff8800255bfdf8 ffffffff8109e466
 0000000000000000 ffff880074835130 ffff880074835040 ffff8800748351b8
Call Trace:
 [<ffffffff817712aa>] dump_stack+0x45/0x57
 [<ffffffff8109e466>] warn_slowpath_common+0x86/0xc0
 [<ffffffff8109e59a>] warn_slowpath_null+0x1a/0x20
 [<ffffffff812573e1>] __blkdev_put+0xc1/0x200
 [<ffffffff812579a0>] blkdev_put+0x50/0x110
 [<ffffffff81257a85>] blkdev_close+0x25/0x30
 [<ffffffff8121fb0c>] __fput+0xdc/0x1e0
 [<ffffffff8121fc5e>] ____fput+0xe/0x10
 [<ffffffff810bab25>] task_work_run+0x85/0xb0
 [<ffffffff81014a2d>] do_notify_resume+0x8d/0x90
 [<ffffffff81777e7c>] int_signal+0x12/0x17

Potential duplicate: bug 1220970
Comment 1 Dumindu 2015-09-25 23:10:21 EDT
Created attachment 1077308 [details]
File: dmesg
Comment 2 HotMusicFan 2016-01-16 16:23:28 EST
Description of problem:
I have tried to reformat an external HDD with GNOME Disks. The HDD is property of my friend and was with confused partition table which consisted of small free space, big FAT32 partition and a small NTFS one which was created by his attempt to reformat the disk with NTFS and then cancelled because of unknown error. He used Windows 7's tools to do this. GNOME Disks returned an error. The HDD is Toshiba v63700-A 500 GB with USB 3.0 port (if matters).

Version-Release number of selected component:
kernel

Additional info:
reporter:       libreport-2.6.3
cmdline:        BOOT_IMAGE=/vmlinuz-4.3.3-300.fc23.x86_64 root=/dev/mapper/fedora-root ro rd.lvm.lv=fedora/root rd.luks.uuid=luks-674f6ac1-2973-44ac-942b-617bd657aa27 rd.lvm.lv=fedora/swap rhgb quiet LANG=en_US.UTF-8
kernel:         4.3.3-300.fc23.x86_64
runlevel:       N 5
type:           Kerneloops

Truncated backtrace:
WARNING: CPU: 0 PID: 6182 at fs/block_dev.c:58 __blkdev_put+0xc1/0x200()
Modules linked in: uas usb_storage ccm ip6t_rpfilter ip6t_REJECT nf_reject_ipv6 xt_conntrack ebtable_filter ebtable_nat ebtable_broute bridge ebtables ip6table_nat nf_conntrack_ipv6 nf_defrag_ipv6 nf_nat_ipv6 ip6table_security ip6table_raw ip6table_mangle ip6table_filter ip6_tables iptable_nat nf_conntrack_ipv4 nf_defrag_ipv4 nf_nat_ipv4 nf_nat nf_conntrack iptable_security iptable_raw iptable_mangle vfat fat intel_rapl iosf_mbi x86_pkg_temp_thermal coretemp kvm snd_hda_codec_hdmi iTCO_wdt ppdev iTCO_vendor_support hp_wmi sparse_keymap snd_hda_codec_idt snd_hda_codec_generic snd_hda_intel snd_hda_codec snd_hda_core snd_hwdep arc4 snd_seq uvcvideo rt2800pci rt2800mmio rt2800lib videobuf2_vmalloc rt2x00pci videobuf2_core rt2x00mmio rt2x00lib videobuf2_memops mac80211 v4l2_common videodev
 cfg80211 eeprom_93cx6 media crc_ccitt rfkill jmb38x_ms hp_accel joydev lis3lv02d memstick snd_seq_device lpc_ich snd_pcm input_polldev hp_wireless snd_timer tpm_tis tpm snd parport_pc wmi parport mei_me mei soundcore shpchp nfsd auth_rpcgss nfs_acl lockd grace sunrpc xfs libcrc32c dm_crypt i915 crct10dif_pclmul crc32_pclmul sdhci_pci crc32c_intel i2c_algo_bit drm_kms_helper sdhci drm 8021q garp mmc_core serio_raw stp llc mrp r8169 mii video fjes
CPU: 0 PID: 6182 Comm: pool Not tainted 4.3.3-300.fc23.x86_64 #1
Hardware name: Hewlett-Packard HP ProBook 4540s/17F6, BIOS 68IRR Ver. F.32 11/06/2012
 0000000000000000 0000000093e87842 ffff8800ac7fbd90 ffffffff813a626f
 0000000000000000 ffff8800ac7fbdc8 ffffffff810a07c2 ffff8801b8c2a4b0
 ffff8801b8c2a3c0 ffff8801b8c2a538 ffff8801b8c2a3d8 ffff8801a681a800
Call Trace:
 [<ffffffff813a626f>] dump_stack+0x44/0x55
 [<ffffffff810a07c2>] warn_slowpath_common+0x82/0xc0
 [<ffffffff810a090a>] warn_slowpath_null+0x1a/0x20
 [<ffffffff8125d4f1>] __blkdev_put+0xc1/0x200
 [<ffffffff8125dadc>] blkdev_put+0x4c/0x110
 [<ffffffff8125dbc5>] blkdev_close+0x25/0x30
 [<ffffffff8122583c>] __fput+0xdc/0x1e0
 [<ffffffff8122597e>] ____fput+0xe/0x10
 [<ffffffff810bd2c3>] task_work_run+0x73/0x90
 [<ffffffff81003bab>] prepare_exit_to_usermode+0xdb/0x110
 [<ffffffff81003c35>] syscall_return_slowpath+0x55/0x150
 [<ffffffff8178178c>] int_ret_from_sys_call+0x25/0x8f
Comment 3 iamsmokingone 2016-01-22 21:57:25 EST
Description of problem:
i formatted this sd card with android terminal emulator (the dd command) and then did mke2fs on it and  the card has become un -writeable. i can't partition it and i can't format it. if i access it its blank and i cant add files. i have 2 sdcards that this has happened to. 

Version-Release number of selected component:
kernel

Additional info:
reporter:       libreport-2.6.3
cmdline:        BOOT_IMAGE=/vmlinuz-4.3.3-301.fc23.x86_64 root=/dev/mapper/fedora-root ro rd.lvm.lv=fedora/root rd.luks.uuid=luks-2c1f3c22-0287-4ab2-882d-d9ddd2e9e97f rd.lvm.lv=fedora/swap rhgb quiet LANG=en_US.UTF-8
kernel:         4.3.3-301.fc23.x86_64
runlevel:       N 5
type:           Kerneloops

Truncated backtrace:
WARNING: CPU: 1 PID: 5913 at fs/block_dev.c:58 __blkdev_put+0xc1/0x200()
Modules linked in: xfs libcrc32c btrfs xor raid6_pq bluetooth vfat fat uas usb_storage fuse ccm ip6t_rpfilter ip6t_REJECT nf_reject_ipv6 xt_conntrack ebtable_broute bridge stp llc ebtable_nat ebtable_filter ebtables ip6table_raw ip6table_nat nf_conntrack_ipv6 nf_defrag_ipv6 nf_nat_ipv6 ip6table_security ip6table_mangle ip6table_filter ip6_tables iptable_raw iptable_nat nf_conntrack_ipv4 nf_defrag_ipv4 nf_nat_ipv4 nf_nat nf_conntrack iptable_security iptable_mangle snd_hda_codec_realtek snd_hda_codec_generic arc4 ath9k hp_wmi snd_hda_intel ath9k_common sparse_keymap snd_hda_codec kvm_amd ath9k_hw kvm ath mac80211 snd_hda_core edac_mce_amd snd_hwdep edac_core k10temp cfg80211 snd_seq snd_seq_device snd_pcm rfkill joydev shpchp sp5100_tco i2c_piix4 video snd_timer wmi snd soundcore acpi_cpufreq
 nfsd auth_rpcgss nfs_acl lockd ecryptfs grace sunrpc encrypted_keys trusted tpm dm_crypt amdkfd amd_iommu_v2 radeon serio_raw i2c_algo_bit drm_kms_helper ttm drm r8169 mii fjes
CPU: 1 PID: 5913 Comm: mkfs.fat Not tainted 4.3.3-301.fc23.x86_64 #1
Hardware name: Hewlett-Packard Presario CQ62 Notebook PC/1444, BIOS F.29 04/07/2011
 0000000000000000 00000000a37106a0 ffff8800775efd40 ffffffff813a626f
 0000000000000000 ffff8800775efd78 ffffffff810a07c2 ffff8800ab75ee70
 ffff8800ab75ed80 ffff8800ab75eef8 ffff8800ab75ed98 ffff88006701e000
Call Trace:
 [<ffffffff813a626f>] dump_stack+0x44/0x55
 [<ffffffff810a07c2>] warn_slowpath_common+0x82/0xc0
 [<ffffffff810a090a>] warn_slowpath_null+0x1a/0x20
 [<ffffffff8125d4f1>] __blkdev_put+0xc1/0x200
 [<ffffffff8125dadc>] blkdev_put+0x4c/0x110
 [<ffffffff8125dbc5>] blkdev_close+0x25/0x30
 [<ffffffff8122583c>] __fput+0xdc/0x1e0
 [<ffffffff8122597e>] ____fput+0xe/0x10
 [<ffffffff810bd2c3>] task_work_run+0x73/0x90
 [<ffffffff810a34c1>] do_exit+0x391/0xae0
 [<ffffffff81065104>] ? __do_page_fault+0x1b4/0x400
 [<ffffffff810a3c97>] do_group_exit+0x47/0xb0
 [<ffffffff810a3d14>] SyS_exit_group+0x14/0x20
 [<ffffffff817815ee>] entry_SYSCALL_64_fastpath+0x12/0x71
Comment 4 Laura Abbott 2016-09-23 15:41:31 EDT
*********** MASS BUG UPDATE **************
 
We apologize for the inconvenience.  There is a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 23 kernel bugs.
 
Fedora 23 has now been rebased to 4.7.4-100.fc23.  Please test this kernel update (or newer) and let us know if you issue has been resolved or if it is still present with the newer kernel.
 
If you have moved on to Fedora 24 or 25, and are still experiencing this issue, please change the version to Fedora 24 or 25.
 
If you experience different issues, please open a new bug report for those.
Comment 5 Dumindu 2016-09-23 15:49:34 EDT
Using Fedora 25 now. Didn't noticed this type of error on it.
Comment 6 Laura Abbott 2016-09-23 16:02:59 EDT
Thanks for letting us know. Going to close this bug for now. If you find the problem again, please open another bug.
Comment 7 Dumindu 2016-09-23 16:11:29 EDT
@Laura Abbott, Just for inform. Had many issues with F23, after install win10(even it removed and reinstalled F23 on HDD). Especially when I was not using separate /boot/efi partition and when using multiple HDD get wired error, had to run fsck -d to recover bad sectors

Note You need to log in before you can comment on or make changes to this bug.