Bug 1266653 - Warnings during upgrade to next version (Cleanup phase)
Warnings during upgrade to next version (Cleanup phase)
Status: CLOSED DUPLICATE of bug 1257085
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: tog-pegasus (Show other bugs)
7.1
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Vitezslav Crhonek
qe-baseos-daemons
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-26 00:51 EDT by Alois Mahdal
Modified: 2015-10-05 04:06 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-05 04:06:30 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alois Mahdal 2015-09-26 00:51:57 EDT
Description of problem
======================

During yum upgrade to next version, Cleanup part ggenerates following
warnings:

    warning: file /var/lib/Pegasus/repository/root#interop/qualifiers/INDICATION: remove failed: No such file or directory
    warning: file /var/lib/Pegasus/repository/root#interop/qualifiers/ASSOCIATION: remove failed: No such file or directory
    warning: file /var/lib/Pegasus/repository/root#cimv2/qualifiers/INDICATION: remove failed: No such file or directory
    warning: file /var/lib/Pegasus/repository/root#cimv2/qualifiers/ASSOCIATION: remove failed: No such file or directory
    warning: file /var/lib/Pegasus/repository/root#cimv2/classes/CIM_OpticalDriveDiagnosticSettingData.CIM_DiagnosticSettingData: remove failed: No such file or directory
    warning: file /var/lib/Pegasus/repository/root#cimv2/classes/CIM_DiagnosticRecord.CIM_LogEntry: remove failed: No such file or directory
    warning: file /var/lib/Pegasus/repository/root#cimv2/classes/CIM_AccountManagementService.CIM_IdentityManagementService: remove failed: No such file or directory
    warning: file /var/lib/Pegasus/repository/root#PG_Internal/qualifiers/INDICATION: remove failed: No such file or directory
    warning: file /var/lib/Pegasus/repository/root#PG_Internal/qualifiers/ASSOCIATION: remove failed: No such file or directory

Other than that, the installation produces no more errors and the systems
seems OK (only expected versions are present, ans rpm --verify succeeds)


Version-Release number of selected component
============================================

tog-pegasus-2.12.1-16.el7


How reproducible
================

At times


Steps to Reproduce
==================

 1. install    tog-pegasus-2.12.1-16.el7
 2. upgrade to tog-pegasus-2.14.1-3.el7


Actual results
==============

Yum shows warning apparently produced by one of rpm scriptlets


Expected results
================

No warnings (or errors) during upgrade


Additional info
===============

More details (from a Beaker-prepared machine):

    [root@here tps]# yum install tog-pegasus-libs-2.14.1-3.el7.s390x.rpm tog-pegasus-2.14.1-3.el7.s390x.rpm 
    Loaded plugins: product-id, subscription-manager
    This system is not registered to Red Hat Subscription Management. You can use subscription-manager to register.
    Examining tog-pegasus-libs-2.14.1-3.el7.s390x.rpm: 2:tog-pegasus-libs-2.14.1-3.el7.s390x
    Marking tog-pegasus-libs-2.14.1-3.el7.s390x.rpm as an update to 2:tog-pegasus-libs-2.12.1-16.el7.s390x
    Examining tog-pegasus-2.14.1-3.el7.s390x.rpm: 2:tog-pegasus-2.14.1-3.el7.s390x
    Marking tog-pegasus-2.14.1-3.el7.s390x.rpm as an update to 2:tog-pegasus-2.12.1-16.el7.s390x
    Resolving Dependencies
    --> Running transaction check
    ---> Package tog-pegasus.s390x 2:2.12.1-16.el7 will be updated
    ---> Package tog-pegasus.s390x 2:2.14.1-3.el7 will be an update
    ---> Package tog-pegasus-libs.s390x 2:2.12.1-16.el7 will be updated
    ---> Package tog-pegasus-libs.s390x 2:2.14.1-3.el7 will be an update
    --> Finished Dependency Resolution

    Dependencies Resolved

    ==============================================================================================================================================================
     Package                             Arch                     Version                           Repository                                               Size
    ==============================================================================================================================================================
    Updating:
     tog-pegasus                         s390x                    2:2.14.1-3.el7                    /tog-pegasus-2.14.1-3.el7.s390x                          12 M
     tog-pegasus-libs                    s390x                    2:2.14.1-3.el7                    /tog-pegasus-libs-2.14.1-3.el7.s390x                    9.0 M

    Transaction Summary
    ==============================================================================================================================================================
    Upgrade  2 Packages

    Total size: 21 M
    Is this ok [y/d/N]: y
    Downloading packages:
    Running transaction check
    Running transaction test
    Transaction test succeeded
    Running transaction
      Updating   : 2:tog-pegasus-libs-2.14.1-3.el7.s390x                                                                                                      1/4 
      Updating   : 2:tog-pegasus-2.14.1-3.el7.s390x                                                                                                           2/4 
      Cleanup    : 2:tog-pegasus-2.12.1-16.el7.s390x                                                                                                          3/4 
    warning: file /var/lib/Pegasus/repository/root#interop/qualifiers/INDICATION: remove failed: No such file or directory
    warning: file /var/lib/Pegasus/repository/root#interop/qualifiers/ASSOCIATION: remove failed: No such file or directory
    warning: file /var/lib/Pegasus/repository/root#cimv2/qualifiers/INDICATION: remove failed: No such file or directory
    warning: file /var/lib/Pegasus/repository/root#cimv2/qualifiers/ASSOCIATION: remove failed: No such file or directory
    warning: file /var/lib/Pegasus/repository/root#cimv2/classes/CIM_OpticalDriveDiagnosticSettingData.CIM_DiagnosticSettingData: remove failed: No such file or directory
    warning: file /var/lib/Pegasus/repository/root#cimv2/classes/CIM_DiagnosticRecord.CIM_LogEntry: remove failed: No such file or directory
    warning: file /var/lib/Pegasus/repository/root#cimv2/classes/CIM_AccountManagementService.CIM_IdentityManagementService: remove failed: No such file or directory
    warning: file /var/lib/Pegasus/repository/root#PG_Internal/qualifiers/INDICATION: remove failed: No such file or directory
    warning: file /var/lib/Pegasus/repository/root#PG_Internal/qualifiers/ASSOCIATION: remove failed: No such file or directory
      Cleanup    : 2:tog-pegasus-libs-2.12.1-16.el7.s390x                                                                                                     4/4 
      Verifying  : 2:tog-pegasus-2.14.1-3.el7.s390x                                                                                                           1/4 
      Verifying  : 2:tog-pegasus-libs-2.14.1-3.el7.s390x                                                                                                      2/4 
      Verifying  : 2:tog-pegasus-2.12.1-16.el7.s390x                                                                                                          3/4 
      Verifying  : 2:tog-pegasus-libs-2.12.1-16.el7.s390x                                                                                                     4/4 

    Updated:
      tog-pegasus.s390x 2:2.14.1-3.el7                                            tog-pegasus-libs.s390x 2:2.14.1-3.el7                                           

    Complete!
    [root@here tps]# rpm -q tog-pegasus
    tog-pegasus-2.14.1-3.el7.s390x
    [root@here tps]# rpm -Va tog-pegasus\*
    [root@here tps]#
Comment 2 Vitezslav Crhonek 2015-10-05 04:06:30 EDT

*** This bug has been marked as a duplicate of bug 1257085 ***

Note You need to log in before you can comment on or make changes to this bug.