Bug 1266681 - mnemosyne fail to launch, with traceback
mnemosyne fail to launch, with traceback
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: mnemosyne (Show other bugs)
22
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Dominik 'Rathann' Mierzejewski
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-26 09:29 EDT by Michael K Johnson
Modified: 2015-10-23 13:25 EDT (History)
3 users (show)

See Also:
Fixed In Version: mnemosyne-2.3.4-1.fc23 mnemosyne-2.3.4-1.fc22
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-12 20:06:07 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael K Johnson 2015-09-26 09:29:47 EDT
Description of problem:

# dnf install mnemosyne
...
Installed:
  mnemosyne.noarch 2.3.3-1.fc22      python-matplotlib-qt4.x86_64 1.4.3-3.fc22  
  python-webob.noarch 1.4.1-1.fc22 

Selected Education → Mnemosyne from menu. Got traceback:

Traceback (innermost last):
  File "/usr/bin/mnemosyne", line 191, in <module>
    debug_file=options.debug_file)
  File "/usr/lib/python2.7/site-packages/mnemosyne/libmnemosyne/__init__.py", line 174, in initialise
    self.register_components()
  File "/usr/lib/python2.7/site-packages/mnemosyne/libmnemosyne/__init__.py", line 244, in register_components
    exec("from %s import %s" % (module_name, class_name))
  File "<string>", line 1, in <module>
  File "/usr/lib/python2.7/site-packages/mnemosyne/pyqt_ui/statistics_wdgts_plotting.py", line 12, in <module>
    from matplotlib.backends.backend_qt4agg import FigureCanvasQTAgg as FigureCanvas
  File "/usr/lib64/python2.7/site-packages/matplotlib/backends/backend_qt4agg.py", line 17, in <module>
    from .backend_qt5agg import NavigationToolbar2QTAgg
 ImportError: No module named backend_qt5agg
Comment 1 Jiri Popelka 2015-09-26 10:30:25 EDT

*** This bug has been marked as a duplicate of bug 1219556 ***
Comment 2 Fedora Update System 2015-09-30 12:12:17 EDT
mnemosyne-2.3.3-2.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2015-c7dc663d01
Comment 3 Fedora Update System 2015-10-01 19:53:26 EDT
mnemosyne-2.3.3-4.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update mnemosyne'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-808e9a62af
Comment 4 Fedora Update System 2015-10-01 21:49:17 EDT
mnemosyne-2.3.3-4.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update mnemosyne'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-808e9a62af
Comment 5 Fedora Update System 2015-10-03 21:37:41 EDT
mnemosyne-2.3.3-2.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update mnemosyne'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-c7dc663d01
Comment 6 Fedora Update System 2015-10-06 04:25:18 EDT
mnemosyne-2.3.4-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-808e9a62af
Comment 7 Fedora Update System 2015-10-06 04:25:46 EDT
mnemosyne-2.3.4-1.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2015-c7dc663d01
Comment 8 Fedora Update System 2015-10-07 12:26:54 EDT
mnemosyne-2.3.4-1.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update mnemosyne'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-c7dc663d01
Comment 9 Fedora Update System 2015-10-07 12:28:47 EDT
mnemosyne-2.3.4-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update mnemosyne'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-808e9a62af
Comment 10 Fedora Update System 2015-10-12 20:06:05 EDT
mnemosyne-2.3.4-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 11 Fedora Update System 2015-10-23 13:25:54 EDT
mnemosyne-2.3.4-1.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.