Bug 1266701 - [abrt] dnf: miscutils.py:62:checkSig:OSError: [Errno 2] No such file or directory: '/var/cache/dnf/fedora-d174f3c3f2691dd5/packages/libXScrnSaver-1.2.2-8.fc22.x86_64.rpm'
[abrt] dnf: miscutils.py:62:checkSig:OSError: [Errno 2] No such file or direc...
Status: CLOSED DUPLICATE of bug 1264834
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
22
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:5d5b1d93b01af1df847a5fb3116...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-26 12:41 EDT by Xavier Ortiz
Modified: 2015-09-30 04:38 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-30 04:38:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (1.58 KB, text/plain)
2015-09-26 12:41 EDT, Xavier Ortiz
no flags Details
File: environ (280 bytes, text/plain)
2015-09-26 12:41 EDT, Xavier Ortiz
no flags Details

  None (edit)
Description Xavier Ortiz 2015-09-26 12:41:19 EDT
Version-Release number of selected component:
dnf-1.1.1-2.fc22

Additional info:
reporter:       libreport-2.6.2
cmdline:        /usr/bin/python -OO /usr/bin/dnf install -y --disableplugin=refresh-packagekit k9copy devede brasero
dso_list:       python-dnf-1.1.1-2.fc22.noarch
executable:     /usr/bin/dnf
kernel:         4.1.7-200.fc22.x86_64
runlevel:       N 5
type:           Python
uid:            0

Truncated backtrace:
miscutils.py:62:checkSig:OSError: [Errno 2] No such file or directory: '/var/cache/dnf/fedora-d174f3c3f2691dd5/packages/libXScrnSaver-1.2.2-8.fc22.x86_64.rpm'

Traceback (most recent call last):
  File "/usr/bin/dnf", line 36, in <module>
    main.user_main(sys.argv[1:], exit_code=True)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 198, in user_main
    errcode = main(args)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 84, in main
    return _main(base, args)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 144, in _main
    ret = resolving(cli, base)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 173, in resolving
    base.do_transaction(display=displays)
  File "/usr/lib/python2.7/site-packages/dnf/cli/cli.py", line 219, in do_transaction
    self.gpgsigcheck(downloadpkgs)
  File "/usr/lib/python2.7/site-packages/dnf/cli/cli.py", line 239, in gpgsigcheck
    result, errmsg = self.sigCheckPkg(po)
  File "/usr/lib/python2.7/site-packages/dnf/base.py", line 948, in sigCheckPkg
    sigresult = dnf.rpm.miscutils.checkSig(ts, po.localPkg())
  File "/usr/lib/python2.7/site-packages/dnf/rpm/miscutils.py", line 62, in checkSig
    fdno = os.open(package, os.O_RDONLY)
OSError: [Errno 2] No such file or directory: '/var/cache/dnf/fedora-d174f3c3f2691dd5/packages/libXScrnSaver-1.2.2-8.fc22.x86_64.rpm'

Local variables in innermost frame:
currentflags: 986880
ts: <dnf.rpm.transaction.TransactionWrapper object at 0x7f7b617c1590>
value: 0
package: u'/var/cache/dnf/fedora-d174f3c3f2691dd5/packages/libXScrnSaver-1.2.2-8.fc22.x86_64.rpm'
Comment 1 Xavier Ortiz 2015-09-26 12:41:26 EDT
Created attachment 1077519 [details]
File: backtrace
Comment 2 Xavier Ortiz 2015-09-26 12:41:27 EDT
Created attachment 1077520 [details]
File: environ
Comment 3 Michal Luscon 2015-09-30 04:38:54 EDT

*** This bug has been marked as a duplicate of bug 1264834 ***

Note You need to log in before you can comment on or make changes to this bug.