This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1266783 - [abrt] qt-creator: data(): qtcreator killed by SIGSEGV
[abrt] qt-creator: data(): qtcreator killed by SIGSEGV
Status: CLOSED DUPLICATE of bug 1247967
Product: Fedora
Classification: Fedora
Component: qt-creator (Show other bugs)
22
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Itamar Reis Peixoto
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:5c21ebf5f8834ae48055e688800...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-27 16:24 EDT by Dan Mossor [danofsatx]
Modified: 2015-09-27 16:25 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-27 16:25:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (74.88 KB, text/plain)
2015-09-27 16:24 EDT, Dan Mossor [danofsatx]
no flags Details
File: cgroup (190 bytes, text/plain)
2015-09-27 16:24 EDT, Dan Mossor [danofsatx]
no flags Details
File: core_backtrace (27.72 KB, text/plain)
2015-09-27 16:24 EDT, Dan Mossor [danofsatx]
no flags Details
File: dso_list (33.35 KB, text/plain)
2015-09-27 16:24 EDT, Dan Mossor [danofsatx]
no flags Details
File: environ (1.78 KB, text/plain)
2015-09-27 16:24 EDT, Dan Mossor [danofsatx]
no flags Details
File: limits (1.29 KB, text/plain)
2015-09-27 16:24 EDT, Dan Mossor [danofsatx]
no flags Details
File: maps (136.55 KB, text/plain)
2015-09-27 16:24 EDT, Dan Mossor [danofsatx]
no flags Details
File: mountinfo (3.01 KB, text/plain)
2015-09-27 16:24 EDT, Dan Mossor [danofsatx]
no flags Details
File: namespaces (85 bytes, text/plain)
2015-09-27 16:24 EDT, Dan Mossor [danofsatx]
no flags Details
File: open_fds (1.21 KB, text/plain)
2015-09-27 16:24 EDT, Dan Mossor [danofsatx]
no flags Details
File: proc_pid_status (1021 bytes, text/plain)
2015-09-27 16:24 EDT, Dan Mossor [danofsatx]
no flags Details
File: var_log_messages (300 bytes, text/plain)
2015-09-27 16:24 EDT, Dan Mossor [danofsatx]
no flags Details

  None (edit)
Description Dan Mossor [danofsatx] 2015-09-27 16:24:09 EDT
Description of problem:
Set the editor font to "Source Code Pro", and hit "Apply". Program crashed after I hit "Apply".

This was the initial run of qt-creator and I was configuring it for first use. No code had been opened, no other settings other than color scheme and font had been altered to this point.

Version-Release number of selected component:
qt-creator-3.5.0-1.fc22

Additional info:
reporter:       libreport-2.6.2
backtrace_rating: 4
cmdline:        /bin/qtcreator
crash_function: data
executable:     /usr/bin/qtcreator
global_pid:     8096
kernel:         4.1.7-200.fc22.x86_64
runlevel:       N 5
type:           CCpp
uid:            1000

Truncated backtrace:
Thread no. 1 (10 frames)
 #0 data at ../../src/corelib/tools/qscopedpointer.h:135
 #1 QBrush::QBrush at painting/qbrush.cpp:534
 #2 KStatefulBrush::brush at ../../src/kcolorscheme.cpp:697
 #4 hoverColor at ../../kstyle/breezehelper.h:78
 #5 Breeze::Helper::frameOutlineColor at ../../kstyle/breezehelper.cpp:92
 #6 Breeze::FrameShadow::paintEvent at ../../kstyle/breezeframeshadow.cpp:340
 #7 QWidget::event at kernel/qwidget.cpp:9034
 #8 QApplicationPrivate::notify_helper at kernel/qapplication.cpp:3717
 #9 QApplication::notify at kernel/qapplication.cpp:3500
 #10 QCoreApplication::notifyInternal at kernel/qcoreapplication.cpp:965
Comment 1 Dan Mossor [danofsatx] 2015-09-27 16:24:13 EDT
Created attachment 1077776 [details]
File: backtrace
Comment 2 Dan Mossor [danofsatx] 2015-09-27 16:24:15 EDT
Created attachment 1077777 [details]
File: cgroup
Comment 3 Dan Mossor [danofsatx] 2015-09-27 16:24:16 EDT
Created attachment 1077778 [details]
File: core_backtrace
Comment 4 Dan Mossor [danofsatx] 2015-09-27 16:24:18 EDT
Created attachment 1077779 [details]
File: dso_list
Comment 5 Dan Mossor [danofsatx] 2015-09-27 16:24:19 EDT
Created attachment 1077780 [details]
File: environ
Comment 6 Dan Mossor [danofsatx] 2015-09-27 16:24:20 EDT
Created attachment 1077781 [details]
File: limits
Comment 7 Dan Mossor [danofsatx] 2015-09-27 16:24:22 EDT
Created attachment 1077782 [details]
File: maps
Comment 8 Dan Mossor [danofsatx] 2015-09-27 16:24:23 EDT
Created attachment 1077783 [details]
File: mountinfo
Comment 9 Dan Mossor [danofsatx] 2015-09-27 16:24:24 EDT
Created attachment 1077784 [details]
File: namespaces
Comment 10 Dan Mossor [danofsatx] 2015-09-27 16:24:25 EDT
Created attachment 1077785 [details]
File: open_fds
Comment 11 Dan Mossor [danofsatx] 2015-09-27 16:24:27 EDT
Created attachment 1077786 [details]
File: proc_pid_status
Comment 12 Dan Mossor [danofsatx] 2015-09-27 16:24:28 EDT
Created attachment 1077787 [details]
File: var_log_messages
Comment 13 Sandro Mani 2015-09-27 16:25:42 EDT

*** This bug has been marked as a duplicate of bug 1247967 ***

Note You need to log in before you can comment on or make changes to this bug.