Bug 126681 - Package javamail needs katana, this is not available (but it is..)
Package javamail needs katana, this is not available (but it is..)
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-24 13:36 EDT by Bob Gustafson
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-04 13:12:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Bob Gustafson 2004-06-24 13:36:26 EDT
Description of problem:

  Various packages (including javamail) seem to have a dependency on
katana

Version-Release number of selected component (if applicable):

  [root@hoho2 user1]# rpm -q katana
  katana-1.0.4-3
  [root@hoho2 user1]#

How reproducible:

 Just noticed it awhile ago.

Steps to Reproduce:
1. yum install \*
2. see below
3.
  
Actual results:

yum install \*
...
...
Resolving dependencies
.Package katana-build needs katana = 1.0.4-3, this is not available.
Package xerces-j needs katana, this is not available.
Package xalan-j needs katana, this is not available.
Package jakarta-regexp needs katana, this is not available.
Package bcel needs katana, this is not available.
Package jaf needs katana, this is not available.
Package javamail needs katana, this is not available.
Package ecj needs katana, this is not available.
Package junit needs katana, this is not available.
Package cup needs katana, this is not available.
Package xalan-j-xsltc needs katana, this is not available.
Package ant-core needs katana, this is not available.
Package commons-logging needs katana, this is not available.
Package ant-optional needs katana, this is not available.

[root@hoho2 user1]# yum install katana
Gathering header information file(s) from server(s)
Server: Fedora Core 2 - Development Tree
Finding updated packages
Downloading needed headers
katana is installed and is the latest version.
No actions to take
[root@hoho2 user1]#
Comment 1 Bob Gustafson 2004-06-25 11:42:24 EDT
Katana was updated, but somehow it did not fix the dependencies

yum install \*
...
...
Resolving dependencies
.Package xerces-j needs katana, this is not available.
Package xalan-j needs katana, this is not available.
Package jakarta-regexp needs katana, this is not available.
Package bcel needs katana, this is not available.
Package jaf needs katana, this is not available.
Package javamail needs katana, this is not available.
Package ecj needs katana, this is not available.
Package junit needs katana, this is not available.
Package cup needs katana, this is not available.
Package xalan-j-xsltc needs katana, this is not available.
Package ant-core needs katana, this is not available.
Package commons-logging needs katana, this is not available.
Package ant-optional needs katana, this is not available.
Package katana-build needs katana = 1.0.4-4, this is not available.
[root@hoho2 tmp]#

[root@hoho2 tmp]# rpm -q katana
katana-1.0.4-4
[root@hoho2 tmp]#
Comment 2 Bob Gustafson 2004-07-08 10:55:08 EDT
Still a problem

[root@hoho2 root]# date
Thu Jul  8 09:54:40 CDT 2004

[root@hoho2 root]# yum install \*
Gathering header information file(s) from server(s)
Server: Fedora Core 2 - Development Tree
Finding updated packages
Downloading needed headers
kernel-smp is installed and is the latest version.
openssl is installed and is the latest version.
glibc is installed and is the latest version.
kernel is installed and is the latest version.
Resolving dependencies
.Package xerces-j needs katana, this is not available.
Package jakarta-regexp needs katana, this is not available.
Package bcel needs katana, this is not available.
Package jaf needs katana, this is not available.
Package javamail needs katana, this is not available.
Package junit needs katana, this is not available.
Package cup needs katana, this is not available.
Package ant-core needs katana, this is not available.
Package commons-logging needs katana, this is not available.
Package ant-optional needs katana, this is not available.
Package katana-build needs katana = 1.0.4-4, this is not available.
Package jlex needs katana, this is not available.
Package xalan-j needs katana, this is not available.
Package xalan-j-xsltc needs katana, this is not available.
Package ecj needs katana, this is not available.
[root@hoho2 root]#

Comment 3 Gary Benson 2004-07-08 11:19:13 EDT
Sounds like you might have a corrupted rpm database.  If 'rpm -q
--whatprovides katana' returns nothing then that's definitely it.
Comment 4 Bob Gustafson 2004-07-11 12:32:25 EDT
[user1@hoho2 user1]$ rpm -q --whatprovides katana
katana-1.0.4-4
[user1@hoho2 user1]$

Doing rpmdb-fedora
Resolving dependencies
Dependencies resolved
I will do the following:
[update: rpmdb-fedora 1:2-0.20040711.i386]
Getting rpmdb-fedora-2-0.20040711.i386.rpm
rpmdb-fedora-2-0.20040711 100% |=========================|  30 MB    03:17
Running test transaction:
Test transaction complete, Success!
rpmdb-fedora 100 % done 1/2
Completing update for rpmdb-fedora  - 2/2
Updated:  rpmdb-fedora 1:2-0.20040711.i386
Transaction(s) Complete

[root@hoho2 root]# rpm -q --whatprovides katana
katana-1.0.4-4
     
[root@hoho2 root]# rpm -q redhat-java-rpm-scripts
package redhat-java-rpm-scripts is not installed

[root@hoho2 root]# yum install redhat-java-rpm-scripts
Gathering header information file(s) from server(s)
Server: Fedora Core 2 - Development Tree
Finding updated packages
Downloading needed headers
Resolving dependencies
.Package xerces-j needs katana, this is not available.
Package jakarta-regexp needs katana, this is not available.
Package bcel needs katana, this is not available.
Package jaf needs katana, this is not available.
Package javamail needs katana, this is not available.
Package junit needs katana, this is not available.
Package cup needs katana, this is not available.
Package ant-core needs katana, this is not available.
Package commons-logging needs katana, this is not available.
Package ant-optional needs katana, this is not available.
Package katana-build needs katana = 1.0.4-4, this is not available.
Package jlex needs katana, this is not available.
Package xalan-j needs katana, this is not available.
Package xalan-j-xsltc needs katana, this is not available.
Package ecj needs katana, this is not available.
[root@hoho2 root]#
Comment 5 Gary Benson 2004-07-12 08:54:30 EDT
I didn't mean that.  Try running 'rpm --rebuilddb' and see if that helps.
Comment 6 Bob Gustafson 2004-07-12 15:00:38 EDT
Nope - not yet 

[root@hoho2 user1]# date
Mon Jul 12 13:45:16 CDT 2004

[root@hoho2 user1]# rpm --rebuilddb
date
[root@hoho2 user1]# date
Mon Jul 12 13:55:01 CDT 2004

[root@hoho2 user1]# yum install redhat-java-rpm-scripts
Gathering header information file(s) from server(s)
Server: Fedora Core 2 - Development Tree
Finding updated packages
Downloading needed headers
rpmdb-fedora-1-2-0.200407 100% |=========================| 1.9 kB    00:00
Resolving dependencies
.Package katana-build needs katana = 1.0.4-4, this is not available.
Package xalan-j-xsltc needs katana, this is not available.
Package xerces-j needs katana, this is not available.
Package commons-logging needs katana, this is not available.
Package javamail needs katana, this is not available.
Package ant-core needs katana, this is not available.
Package ant-optional needs katana, this is not available.
Package xalan-j needs katana, this is not available.
Package ecj needs katana, this is not available.
Package jakarta-regexp needs katana, this is not available.
Package bcel needs katana, this is not available.
Package junit needs katana, this is not available.
Package jaf needs katana, this is not available.
Package cup needs katana, this is not available.
Package jlex needs katana, this is not available.
[root@hoho2 user1]#

Additional Info
  I have not done an 'update' since my last comment.
Comment 7 Bob Gustafson 2004-07-15 23:41:10 EDT
Still a problem

[root@hoho2 root]# cat /proc/version
Linux version 2.6.7-1.488smp (bhcompile@daffy.perf.redhat.com) (gcc
version 3.4.1 20040702 (Red Hat Linux 3.4.1-2)) #1 SMP Wed Jul 14
10:02:03 EDT 2004

[root@hoho2 root]# date
Thu Jul 15 22:40:48 CDT 2004

[root@hoho2 root]# yum install redhat-java-rpm-scripts
Gathering header information file(s) from server(s)
Server: Fedora Core 2 - Development Tree
Finding updated packages
Downloading needed headers
Resolving dependencies
.Package katana-build needs katana = 1.0.4-4, this is not available.
Package xalan-j-xsltc needs katana, this is not available.
Package xerces-j needs katana, this is not available.
Package commons-logging needs katana, this is not available.
Package javamail needs katana, this is not available.
Package ant-core needs katana, this is not available.
Package ant-optional needs katana, this is not available.
Package xalan-j needs katana, this is not available.
Package ecj needs katana, this is not available.
Package jakarta-regexp needs katana, this is not available.
Package bcel needs katana, this is not available.
Package junit needs katana, this is not available.
Package jaf needs katana, this is not available.
Package cup needs katana, this is not available.
Package jlex needs katana, this is not available.
[root@hoho2 root]#


Comment 8 Bob Gustafson 2004-07-22 15:25:19 EDT
Still a problem - see below

[root@hoho2 root]# date
Thu Jul 22 14:23:26 CDT 2004

[root@hoho2 root]# yum --exclude=\*debuginfo\* install \*
Gathering header information file(s) from server(s)
Server: Fedora Core 2 - Development Tree
Finding updated packages
Downloading needed headers
kernel-smp is installed and is the latest version.
openssl is installed and is the latest version.
glibc is installed and is the latest version.
kernel is installed and is the latest version.
Resolving dependencies
.Package katana-build needs katana = 1.0.4-4, this is not available.
Package xalan-j-xsltc needs katana, this is not available.
Package xerces-j needs katana, this is not available.
Package commons-logging needs katana, this is not available.
Package javamail needs katana, this is not available.
Package ant-core needs katana, this is not available.
Package ant-optional needs katana, this is not available.
Package xalan-j needs katana, this is not available.
Package ecj needs katana, this is not available.
Package jakarta-regexp needs katana, this is not available.
Package bcel needs katana, this is not available.
Package junit needs katana, this is not available.
Package jaf needs katana, this is not available.
Package cup needs katana, this is not available.
Package jlex needs katana, this is not available.
Package gnome-bluetooth needs libsdp.so.2, this is not available.
Package libbtctl needs libsdp.so.2, this is not available.
[root@hoho2 root]#

Comment 9 Bob Gustafson 2004-08-04 23:53:13 EDT
This is still a problem

[root@hoho2 ~]# yum -y --exclude=]*debuginfo\* install \*
Gathering header information file(s) from server(s)
Server: Fedora Core 2 - Development Tree
Finding updated packages
Downloading needed headers
kernel-smp is installed and is the latest version.
openssl is installed and is the latest version.
glibc is installed and is the latest version.
kernel is installed and is the latest version.
Resolving dependencies
.Package katana-build needs katana = 1.0.4-4, this is not available.
Package xalan-j-xsltc needs katana, this is not available.
Package xerces-j needs katana, this is not available.
Package commons-logging needs katana, this is not available.
Package javamail needs katana, this is not available.
Package ant-core needs katana, this is not available.
Package ant-optional needs katana, this is not available.
Package xalan-j needs katana, this is not available.
Package jakarta-regexp needs katana, this is not available.
Package bcel needs katana, this is not available.
Package junit needs katana, this is not available.
Package jaf needs katana, this is not available.
Package cup needs katana, this is not available.
Package jlex needs katana, this is not available.
Package ecj needs katana, this is not available.
Package php needs libcurl.so.2, this is not available.
[root@hoho2 ~]#

Comment 10 Bob Gustafson 2004-08-18 10:14:04 EDT
Still a problem

[root@hoho2 ~]# date
Wed Aug 18 09:13:36 CDT 2004
[root@hoho2 ~]# yum -y --exclude=\*debuginfo\* --exclude=iii\* install \*
Gathering header information file(s) from server(s)
Server: Fedora Core 2 - Development Tree
Finding updated packages
Downloading needed headers
kernel-smp is installed and is the latest version.
openssl is installed and is the latest version.
glibc is installed and is the latest version.
kernel is installed and is the latest version.
Resolving dependencies
.Package katana-build needs katana = 1.0.4-4, this is not available.
Package xalan-j-xsltc needs katana, this is not available.
Package xerces-j needs katana, this is not available.
Package commons-logging needs katana, this is not available.
Package javamail needs katana, this is not available.
Package ant-core needs katana, this is not available.
Package ant-optional needs katana, this is not available.
Package xalan-j needs katana, this is not available.
Package jakarta-regexp needs katana, this is not available.
Package bcel needs katana, this is not available.
Package junit needs katana, this is not available.
Package jaf needs katana, this is not available.
Package cup needs katana, this is not available.
Package jlex needs katana, this is not available.
Package ecj needs katana, this is not available.
[root@hoho2 ~]# date
Wed Aug 18 09:14:28 CDT 2004
[root@hoho2 ~]#

Comment 11 Bob Gustafson 2004-08-20 15:42:31 EDT
There were a lot of updates available a few minutes ago, but when all
was done and installed and rebooted, the problem remains. 

[root@hoho2 ~]# yum -y --exclude=\*debuginfo\* --exclude=iii\* install \*
Gathering header information file(s) from server(s)
Server: Fedora Core 2 - Development Tree
Finding updated packages
Downloading needed headers
kernel-smp is installed and is the latest version.
openssl is installed and is the latest version.
glibc is installed and is the latest version.
kernel is installed and is the latest version.
Resolving dependencies
.Package katana-build needs katana = 1.0.4-4, this is not available.
Package xalan-j-xsltc needs katana, this is not available.
Package xerces-j needs katana, this is not available.
Package commons-logging needs katana, this is not available.
Package javamail needs katana, this is not available.
Package ant-core needs katana, this is not available.
Package ant-optional needs katana, this is not available.
Package xalan-j needs katana, this is not available.
Package jakarta-regexp needs katana, this is not available.
Package bcel needs katana, this is not available.
Package junit needs katana, this is not available.
Package jaf needs katana, this is not available.
Package cup needs katana, this is not available.
Package jlex needs katana, this is not available.
Package ecj needs katana, this is not available.
[root@hoho2 ~]#

[root@hoho2 ~]# date
Fri Aug 20 14:41:39 CDT 2004

[root@hoho2 ~]# cat /proc/version
Linux version 2.6.8-1.524smp (bhcompile@tweety.build.redhat.com) (gcc
version 3.4.1 20040815 (Red Hat 3.4.1-8)) #1 SMP Wed Aug 18 12:12:51
EDT 2004
[root@hoho2 ~]#

Comment 12 Gary Benson 2004-08-23 03:42:24 EDT
Since nobody else has this problem I'm guessing you have a corrupted
rpm database. 
Comment 13 Bob Gustafson 2004-09-04 13:12:08 EDT
The rpm database has been updated a number of times since this bug was
reported.

Also, 'rpm --rebuilddb' was run (see earlier in this bug report) with
no change in output.

Perhaps this problem is an artifact of doing 'yum install \*'.

Yum has been modified so the wildcard at the end does not work, so I
have not seen the katana complaint for a week or so.

Since no one else has reported this problem (probably no-one using
'yum install \*'), and I don't see it any more.

Works for me.

Note You need to log in before you can comment on or make changes to this bug.