Bug 1266943 - A test bug (please ignore me)
A test bug (please ignore me)
Status: CLOSED NOTABUG
Product: Red Hat OpenStack
Classification: Red Hat
Component: distribution (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 8.0 (Liberty)
Assigned To: Lars Kellogg-Stedman
Lars Kellogg-Stedman
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-28 11:34 EDT by Lars Kellogg-Stedman
Modified: 2016-04-26 21:31 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-15 16:00:05 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
lars: needinfo-


Attachments (Terms of Use)
[1/357] Initial setup of the repo (533 bytes, patch)
2015-09-28 11:50 EDT, Lars Kellogg-Stedman
no flags Details | Diff
[2/357] Initial Import (51.73 KB, patch)
2015-09-28 11:50 EDT, Lars Kellogg-Stedman
no flags Details | Diff
[3/357] Switch from SysV init scripts to systemd units (35.07 KB, patch)
2015-09-28 11:50 EDT, Lars Kellogg-Stedman
no flags Details | Diff
[4/357] Add the one man page (2.37 KB, patch)
2015-09-28 11:51 EDT, Lars Kellogg-Stedman
no flags Details | Diff
[5/357] Start services with --flagfile rather than --flag-file (#735070) (6.47 KB, patch)
2015-09-28 11:51 EDT, Lars Kellogg-Stedman
no flags Details | Diff
[6/357] Add iptables rules to allow requests to dnsmasq (#734347) (3.89 KB, patch)
2015-09-28 11:51 EDT, Lars Kellogg-Stedman
no flags Details | Diff
[7/357] Add iptables rule to allow EC2 metadata requests (#734347) (3.55 KB, patch)
2015-09-28 11:51 EDT, Lars Kellogg-Stedman
no flags Details | Diff
[8/357] Remove python-libguestfs dependency (#738187) (1.25 KB, patch)
2015-09-28 11:51 EDT, Lars Kellogg-Stedman
no flags Details | Diff
[9/357] Use tgtadm instead of ietadm (#737046) (19.89 KB, patch)
2015-09-28 11:51 EDT, Lars Kellogg-Stedman
no flags Details | Diff
[10/357] Update to Diablo final (30.59 KB, patch)
2015-09-28 11:51 EDT, Lars Kellogg-Stedman
no flags Details | Diff
[11/357] Manage the package's patches in git; no functional changes. (84.61 KB, patch)
2015-09-28 11:51 EDT, Lars Kellogg-Stedman
no flags Details | Diff
[12/357] Backport some diablo fixes from upstream (126.53 KB, patch)
2015-09-28 11:51 EDT, Lars Kellogg-Stedman
no flags Details | Diff
[13/357] Add dependency on python-amqplib (1.25 KB, patch)
2015-09-28 11:52 EDT, Lars Kellogg-Stedman
no flags Details | Diff
[14/357] Fix block migration (#741690) (7.40 KB, patch)
2015-09-28 11:52 EDT, Lars Kellogg-Stedman
no flags Details | Diff
[15/357] Fix password leak in EC2 API (#749385, CVE 2011-4076) (4.81 KB, patch)
2015-09-28 11:52 EDT, Lars Kellogg-Stedman
no flags Details | Diff
[16/357] Add ~20 significant fixes from upstream stable branch (295.38 KB, patch)
2015-09-28 11:52 EDT, Lars Kellogg-Stedman
no flags Details | Diff
[17/357] Switch default db config from sqlite to mysql. (7.15 KB, patch)
2015-09-28 11:52 EDT, Lars Kellogg-Stedman
no flags Details | Diff
[18/357] Switch default db config from sqlite to mysql. (7.78 KB, patch)
2015-09-28 11:52 EDT, Lars Kellogg-Stedman
no flags Details | Diff
[1/1] test (974 bytes, patch)
2015-09-28 11:53 EDT, Lars Kellogg-Stedman
no flags Details | Diff

  None (edit)
Description Lars Kellogg-Stedman 2015-09-28 11:34:51 EDT
Nothing to see here, move along.
Comment 2 Lars Kellogg-Stedman 2015-09-28 11:50 EDT
Created attachment 1077968 [details]
[1/357] Initial setup of the repo
Comment 3 Lars Kellogg-Stedman 2015-09-28 11:50 EDT
Created attachment 1077969 [details]
[2/357] Initial Import

 .gitignore                                         |   1 +
 ...uire-bridge_interface-for-flatdhcpmanager.patch |  28 ++
 nova-fix-flavorid-migration-failure.patch          |  51 +++
 nova-fix-quotas-migration-failure.patch            |  84 +++++
 nova-ifc-template                                  |  15 +
 nova-polkit.pkla                                   |   6 +
 nova-sudoers                                       |  44 +++
 nova.conf                                          |  10 +
 nova.logrotate                                     |   9 +
 openstack-nova-ajax-console-proxy.init             | 102 ++++++
 openstack-nova-api.init                            | 110 ++++++
 openstack-nova-compute.init                        | 118 +++++++
 openstack-nova-direct-api.init                     | 110 ++++++
 openstack-nova-network.init                        | 116 +++++++
 openstack-nova-objectstore.init                    | 102 ++++++
 openstack-nova-scheduler.init                      | 102 ++++++
 openstack-nova-vncproxy.init                       | 102 ++++++
 openstack-nova-volume.init                         | 110 ++++++
 openstack-nova.spec                                | 376 +++++++++++++++++++++
 sources                                            |   1 +
 20 files changed, 1597 insertions(+)
Comment 4 Lars Kellogg-Stedman 2015-09-28 11:50 EDT
Created attachment 1077970 [details]
[3/357] Switch from SysV init scripts to systemd units


Signed-off-by: Angus Salkeld <asalkeld@redhat.com>
---
 openstack-nova-ajax-console-proxy.init    | 102 --------------------------
 openstack-nova-ajax-console-proxy.service |  12 +++
 openstack-nova-api.init                   | 110 ----------------------------
 openstack-nova-api.service                |  12 +++
 openstack-nova-compute.init               | 118 ------------------------------
 openstack-nova-compute.service            |  12 +++
 openstack-nova-direct-api.init            | 110 ----------------------------
 openstack-nova-direct-api.service         |  12 +++
 openstack-nova-network.init               | 116 -----------------------------
 openstack-nova-network.service            |  12 +++
 openstack-nova-objectstore.init           | 102 --------------------------
 openstack-nova-objectstore.service        |  12 +++
 openstack-nova-scheduler.init             | 102 --------------------------
 openstack-nova-scheduler.service          |  12 +++
 openstack-nova-vncproxy.init              | 102 --------------------------
 openstack-nova-vncproxy.service           |  12 +++
 openstack-nova-volume.init                | 110 ----------------------------
 openstack-nova-volume.service             |  12 +++
 openstack-nova.spec                       |  68 +++++++++--------
 19 files changed, 145 insertions(+), 1003 deletions(-)
Comment 5 Lars Kellogg-Stedman 2015-09-28 11:51 EDT
Created attachment 1077971 [details]
[4/357] Add the one man page


Signed-off-by: Angus Salkeld <asalkeld@redhat.com>
---
 openstack-nova.spec | 17 +++++++++++++----
 1 file changed, 13 insertions(+), 4 deletions(-)
Comment 6 Lars Kellogg-Stedman 2015-09-28 11:51 EDT
Created attachment 1077972 [details]
[5/357] Start services with --flagfile rather than --flag-file (#735070)


Since the switch to systemd, logs have been written to nova-$service.log
even though the commands we use to launch them are e.g.

  /usr/bin/nova-compute --flag-file /etc/nova/nova.conf --logfile /var/log/nova/compute.log

It turns out the issue is that it should be --flagfile instead of
--flag-file and the difference is causing --logfile to be ignored
---
 openstack-nova-ajax-console-proxy.service | 2 +-
 openstack-nova-api.service                | 2 +-
 openstack-nova-compute.service            | 2 +-
 openstack-nova-direct-api.service         | 2 +-
 openstack-nova-network.service            | 2 +-
 openstack-nova-objectstore.service        | 2 +-
 openstack-nova-scheduler.service          | 2 +-
 openstack-nova-vncproxy.service           | 2 +-
 openstack-nova-volume.service             | 2 +-
 openstack-nova.spec                       | 7 ++++---
 10 files changed, 13 insertions(+), 12 deletions(-)
Comment 7 Lars Kellogg-Stedman 2015-09-28 11:51 EDT
Created attachment 1077973 [details]
[6/357] Add iptables rules to allow requests to dnsmasq (#734347)

 nova-add-filter-rules-for-dnsmasq-dhcp.patch | 51 ++++++++++++++++++++++++++++
 openstack-nova.spec                          |  7 +++-
 2 files changed, 57 insertions(+), 1 deletion(-)
Comment 8 Lars Kellogg-Stedman 2015-09-28 11:51 EDT
Created attachment 1077974 [details]
[7/357] Add iptables rule to allow EC2 metadata requests (#734347)

 ...nput-chain-rule-for-ec2-metadata-requests.patch | 38 ++++++++++++++++++++++
 openstack-nova.spec                                |  7 +++-
 2 files changed, 44 insertions(+), 1 deletion(-)
Comment 9 Lars Kellogg-Stedman 2015-09-28 11:51 EDT
Created attachment 1077975 [details]
[8/357] Remove python-libguestfs dependency (#738187)

 openstack-nova.spec | 6 ++++--
 1 file changed, 4 insertions(+), 2 deletions(-)
Comment 10 Lars Kellogg-Stedman 2015-09-28 11:51 EDT
Created attachment 1077976 [details]
[9/357] Use tgtadm instead of ietadm (#737046)

 nova-iscsi-choice.patch | 459 ++++++++++++++++++++++++++++++++++++++++++++++++
 nova.conf               |   1 +
 openstack-nova.spec     |   7 +-
 3 files changed, 466 insertions(+), 1 deletion(-)
Comment 11 Lars Kellogg-Stedman 2015-09-28 11:51 EDT
Created attachment 1077977 [details]
[10/357] Update to Diablo final


Also, drop some upstreamed patches and update the metadata-accept patch
to what's proposed for essex.

Finally, switch rpc impl from carrot to kombu.
---
 .gitignore                                         |   1 +
 nova-add-filter-rules-for-dnsmasq-dhcp.patch       |  51 ------
 ...nput-chain-rule-for-ec2-metadata-requests.patch |  38 ----
 ...uire-bridge_interface-for-flatdhcpmanager.patch |  28 ---
 nova-fix-flavorid-migration-failure.patch          |  51 ------
 nova-fix-quotas-migration-failure.patch            |  84 ---------
 nova-iscsi-choice.patch                            |  36 ++--
 nova-metadata-accept.patch                         | 202 +++++++++++++++++++++
 openstack-nova.spec                                |  24 ++-
 sources                                            |   2 +-
 10 files changed, 233 insertions(+), 284 deletions(-)
Comment 12 Lars Kellogg-Stedman 2015-09-28 11:51 EDT
Created attachment 1077978 [details]
[11/357] Manage the package's patches in git; no functional changes.

 ...hain-rule-for-EC2-metadata-requests-lp-85.patch |  40 ++
 ...pi-add-the-INPUT-rule-for-EC2-metadata-lp.patch | 188 +++++++
 ...ser-to-choose-either-ietadm-or-tgtadm-lp-.patch | 236 +++++++++
 ...e-VolumeDriver.sync_exec-method-lp-819997.patch | 236 +++++++++
 ...tadm-tgtadm-calls-out-into-helper-classes.patch | 561 +++++++++++++++++++++
 nova-iscsi-choice.patch                            | 459 -----------------
 nova-metadata-accept.patch                         | 202 --------
 openstack-nova.spec                                |  18 +-
 8 files changed, 1276 insertions(+), 664 deletions(-)
Comment 13 Lars Kellogg-Stedman 2015-09-28 11:51 EDT
Created attachment 1077979 [details]
[12/357] Backport some diablo fixes from upstream


Fix lazy load exception with security groups (#741307)
Fix issue with nova-network deleting the default route (#741686)
Fix errors caused by MySQL connection pooling (#741312)
---
 ...hain-rule-for-EC2-metadata-requests-lp-85.patch |  40 --
 ...pool-complexities-from-nova.db.sqlalchemy.patch |  94 ++++
 ...pi-add-the-INPUT-rule-for-EC2-metadata-lp.patch | 188 -------
 ...kes-sure-to-recreate-gateway-for-moved-ip.patch | 119 +++++
 ...ser-to-choose-either-ietadm-or-tgtadm-lp-.patch | 236 ---------
 ...e-grantee-group-loading-for-source-groups.patch |  36 ++
 ...hain-rule-for-EC2-metadata-requests-lp-85.patch |  40 ++
 ...e-VolumeDriver.sync_exec-method-lp-819997.patch | 236 ---------
 ...pi-add-the-INPUT-rule-for-EC2-metadata-lp.patch | 188 +++++++
 ...tadm-tgtadm-calls-out-into-helper-classes.patch | 561 ---------------------
 ...ser-to-choose-either-ietadm-or-tgtadm-lp-.patch | 236 +++++++++
 ...e-VolumeDriver.sync_exec-method-lp-819997.patch | 236 +++++++++
 ...tadm-tgtadm-calls-out-into-helper-classes.patch | 561 +++++++++++++++++++++
 openstack-nova.spec                                |  23 +-
 14 files changed, 1527 insertions(+), 1267 deletions(-)
Comment 14 Lars Kellogg-Stedman 2015-09-28 11:52 EDT
Created attachment 1077980 [details]
[13/357] Add dependency on python-amqplib

 openstack-nova.spec | 6 +++++-
 1 file changed, 5 insertions(+), 1 deletion(-)
Comment 15 Lars Kellogg-Stedman 2015-09-28 11:52 EDT
Created attachment 1077981 [details]
[14/357] Fix block migration (#741690)

 0009-Fixed-bug-lp850602.patch | 119 ++++++++++++++++++++++++++++++++++++++++++
 openstack-nova.spec           |   9 ++--
 2 files changed, 125 insertions(+), 3 deletions(-)
Comment 16 Lars Kellogg-Stedman 2015-09-28 11:52 EDT
Created attachment 1077982 [details]
[15/357] Fix password leak in EC2 API (#749385, CVE 2011-4076)

 ...p-returning-correct-password-on-api-calls.patch | 77 ++++++++++++++++++++++
 openstack-nova.spec                                |  7 +-
 2 files changed, 83 insertions(+), 1 deletion(-)
Comment 17 Lars Kellogg-Stedman 2015-09-28 11:52 EDT
Created attachment 1077983 [details]
[16/357] Add ~20 significant fixes from upstream stable branch

 0001-Add-tools-rfc.sh-from-master.patch            | 175 ++++++
 ...pool-complexities-from-nova.db.sqlalchemy.patch |  94 ---
 0002-Don-t-use-GitPython-for-authors-check.patch   |  81 +++
 ...kes-sure-to-recreate-gateway-for-moved-ip.patch | 119 ----
 ...e-grantee-group-loading-for-source-groups.patch |  36 --
 ...Made-jenkins-email-pruning-more-resilient.patch |  28 +
 ...hain-rule-for-EC2-metadata-requests-lp-85.patch |  40 --
 0004-Removing-old-code-that-snuck-back-in.patch    |  77 +++
 ...outstanding-pep8-errors-for-a-clean-trunk.patch | 675 +++++++++++++++++++++
 ...pi-add-the-INPUT-rule-for-EC2-metadata-lp.patch | 188 ------
 ...ser-to-choose-either-ietadm-or-tgtadm-lp-.patch | 236 -------
 0006-Point-tools-rfc.sh-at-the-right-branch.patch  |  26 +
 ...kes-sure-to-recreate-gateway-for-moved-ip.patch | 120 ++++
 ...e-VolumeDriver.sync_exec-method-lp-819997.patch | 236 -------
 ...tadm-tgtadm-calls-out-into-helper-classes.patch | 561 -----------------
 ...y-qualified-domain-name-in-local-hostname.patch | 103 ++++
 ...e-grantee-group-loading-for-source-groups.patch |  38 ++
 0009-Fixed-bug-lp850602.patch                      | 119 ----
 ...ders-when-auth_token-is-None.-Fixes-bug-8.patch |  29 +
 ...p-returning-correct-password-on-api-calls.patch |  77 ---
 ...pool-complexities-from-nova.db.sqlalchemy.patch |  95 +++
 0012-Raise-InsufficientFreeMemory.patch            |  69 +++
 0013-Don-t-leak-exceptions-out-to-users.patch      |  36 ++
 ...snapshots-work-for-amis.-Fixes-bug-873156.patch | 166 +++++
 0015-Add-missing-author.patch                      |  25 +
 0016-Make-snapshots-private-by-default.patch       |  30 +
 ...ackups-can-no-longer-happen-simultaneousl.patch | 196 ++++++
 0018-Fixed-bug-lp850602.patch                      | 119 ++++
 0019-bug-861310.patch                              |  31 +
 0020-Enforce-snapshot-cleanup.patch                |  90 +++
 0021-bug-lp845714.patch                            | 100 +++
 ...-version-specifier-to-kombu-in-pip-requir.patch |  31 +
 ...nant-id-to-the-create-images-response-Loc.patch |  55 ++
 ...-bug-862633-OS-api-consoles-create-broken.patch | 270 +++++++++
 0025-Deallocate-ip-if-build-fails.patch            | 159 +++++
 ...p-returning-correct-password-on-api-calls.patch |  76 +++
 0027-Handle-pidfile-exception-for-dnsmasq.patch    |  51 ++
 0028-Make-sure-unknown-extensions-return-404.patch |  58 ++
 ...ginal-exception-in-ClassNotFound-exceptio.patch |  93 +++
 ...default-FLAGS.logfile_mode-is-properly-co.patch |  49 ++
 ...t-errors-on-confirm-revertResize-failures.patch |  88 +++
 ...ds-ext4-and-reiserfs-to-_mount_filesystem.patch |  30 +
 0033-Improve-access-check-on-images.patch          |  82 +++
 ...es-bug-834633-Auto-assigning-floating-IPs.patch |  62 ++
 0035-fixes-bug-883233.patch                        |  44 ++
 ...hain-rule-for-EC2-metadata-requests-lp-85.patch |  41 ++
 ...pi-add-the-INPUT-rule-for-EC2-metadata-lp.patch | 188 ++++++
 ...ser-to-choose-either-ietadm-or-tgtadm-lp-.patch | 237 ++++++++
 ...e-VolumeDriver.sync_exec-method-lp-819997.patch | 236 +++++++
 ...tadm-tgtadm-calls-out-into-helper-classes.patch | 561 +++++++++++++++++
 openstack-nova.spec                                | 111 +++-
 51 files changed, 4811 insertions(+), 1726 deletions(-)
Comment 18 Lars Kellogg-Stedman 2015-09-28 11:52 EDT
Created attachment 1077984 [details]
[17/357] Switch default db config from sqlite to mysql.

 nova.conf               |   1 +
 openstack-nova-db-setup | 154 ++++++++++++++++++++++++++++++++++++++++++++++++
 openstack-nova.spec     |  19 +++---
 3 files changed, 164 insertions(+), 10 deletions(-)
Comment 19 Lars Kellogg-Stedman 2015-09-28 11:52 EDT
Created attachment 1077985 [details]
[18/357] Switch default db config from sqlite to mysql.

 nova.conf               |   1 +
 openstack-nova-db-setup | 170 ++++++++++++++++++++++++++++++++++++++++++++++++
 openstack-nova.spec     |  19 +++---
 3 files changed, 180 insertions(+), 10 deletions(-)
Comment 20 Lars Kellogg-Stedman 2015-09-28 11:53 EDT
Created attachment 1077986 [details]
[1/1] test

 openstack-nova.spec | 8 ++++++++
 1 file changed, 8 insertions(+)

Note You need to log in before you can comment on or make changes to this bug.