Bug 126697 - (capiplugin.so) version mismatch pppd and capiplugin.so
version mismatch pppd and capiplugin.so
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: isdn4k-utils (Show other bugs)
2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-24 17:29 EDT by Benedikt Weyer
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-27 10:23:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Benedikt Weyer 2004-06-24 17:29:50 EDT
Description of problem:
pppd is packaged in version 2.4.2, capiplugin.so is of version 2.4.1. that does not 
work.

Version-Release number of selected component (if applicable):
ppp 2.4.2
isdn4k-utils 3.2

How reproducible:
just start a pppd with an option of "plugins capiplugin.so"

Steps to Reproduce:
evident
  
Actual results:
no capi-based ppp-service (disappointing)

Expected results:
working capi-based ppp-service

Additional info:
volunteer(rhce) wanted? please contact me.
Comment 1 Ngo Than 2004-06-28 05:26:26 EDT
it's now fixed in isdn4k-utils-3.2-16.p1.1, which should be available
in rawhide. Thanks for your report

Does the capi-based ppp-service work for you with this version?
Comment 2 Benedikt Weyer 2004-06-29 15:43:26 EDT
hi,

no, it does not work ;-(

first: /usr/lib/libcapi20.so is missing but a simple ln -s
libcapi20.so.2 libcapi20.so seems to be a workaround

next: starting a pppd with capiplugin.so results in this messages:

Jun 29 21:39:34 zabelthau pppd[2485]: Plugin capiplugin.so loaded.
Jun 29 21:39:34 zabelthau pppd[2485]: capiplugin: $Revision: 1.32 $
Jun 29 21:39:34 zabelthau pppd[2485]: capiconn:  1.7 
Jun 29 21:39:34 zabelthau kernel: CSLIP: code copyright 1989 Regents
of the University of California
Jun 29 21:39:34 zabelthau kernel: PPP generic driver version 2.4.2
Jun 29 21:39:34 zabelthau pppd[2493]: pppd 2.4.2 started by root, uid 0
Jun 29 21:39:34 zabelthau pppd[2493]: capiplugin: phase serialconn.
Jun 29 21:39:34 zabelthau pppd[2493]: capiplugin: dialing 00191011 (hdlc)
Jun 29 21:39:36 zabelthau pppd[2493]: capiplugin: connected: "29" ->
"00191011" outgoing (pcli=0x301/ncci=0x10301)
Jun 29 21:39:36 zabelthau pppd[2493]: capiplugin: tty /dev/capi/0
doesn't exist - CAPI Filesystem Support not enabled in kernel or not
mounted ?
Jun 29 21:39:37 zabelthau pppd[2493]: capiplugin: disconnect(local):
"29" -> "00191011" outgoing (pcli=0x301/ncci=0x10301) 0x349f (0x0000)
- Normal, unspecified
Jun 29 21:39:37 zabelthau pppd[2493]: capiplugin: exit
Jun 29 21:39:37 zabelthau pppd[2493]: Exit.


the layer-2-hdlc-connection seems to be stablished (right?) but then
capiplugin looks for a device /dev/capi/0 i don' see it, there are
just a lot of /dev/capi20.##

Comment 3 Ngo Than 2004-07-04 05:16:38 EDT
it looks like the kernel does not support CAPI! in this case you have
to enable CAPI Support in kernel and rebuild again. Could you try it
please?
Comment 4 Benedikt Weyer 2004-07-05 15:54:24 EDT
hi,

no, the kernel supports capi.  the problem was, that the module capifs was loaded but 
the capi-filesystem was not mounted, which is usually done unter /dev/capi. I will 
attach a gpl'ed patch for isdn4k-utils-3.2-16.p1.1 to this bug-report next weekend if 
that is usefull for you. please reassign the bug-report as NEEDINFO to me if you want 
it.
Comment 5 Ngo Than 2004-07-28 09:04:49 EDT
Benedikt, it would be great if you could send the patch please. Thanks
Comment 6 Ngo Than 2006-04-27 10:23:47 EDT
the new isdn4k-utils in the rawhide included the fix for this problem. Thanks for
your report

Note You need to log in before you can comment on or make changes to this bug.