Bug 1267124 - error on installation without httpd preinstalled / missing %requires httpd
error on installation without httpd preinstalled / missing %requires httpd
Status: CLOSED NOTABUG
Product: Red Hat Certification Program
Classification: Red Hat
Component: redhat-certification (Show other bugs)
1.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Greg Nichols
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-29 00:06 EDT by Brian Brock
Modified: 2015-10-13 12:59 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-13 12:59:45 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brian Brock 2015-09-29 00:06:38 EDT
If redhat-certification-backend is installed on a rhel 6 system which does not have the user apache, several hundred lines of complaints about that user are printed at install time.

redhat-certification-2.0-20150928.el6

reliably reproducible

Steps to Reproduce:
1. install a rhel 6 system without httpd
2. attempt install of redhat-certification-backend (or redhat-certification)
3. watch stderr

Actual results:
Running Transaction
  Installing : redhat-certification-backend-2.0-20150928.el6.noarch                                                                                                                                                                      1/1 
warning: user apache does not exist - using root
warning: group apache does not exist - using root
warning: user apache does not exist - using root
warning: group apache does not exist - using root

(the last two lines are repeated ~200 times)

Expected results:
httpd %require'd and installed when redhat-certification installed
no error message about missing user or group
Comment 1 Brian Brock 2015-09-29 00:09:22 EDT
redhat-certification-backend installs successfully without installing httpd:

# rpm -q redhat-certification-backend httpd
redhat-certification-backend-2.0-20150928.el6.noarch
package httpd is not installed
Comment 2 Greg Nichols 2015-10-13 12:59:45 EDT
The intended use of redhat-certification-backend on el6 is for the rhcert client, so it doesn't need the %requires.  However, if the user would like to install apache they can and will have access to the webUI.

Note You need to log in before you can comment on or make changes to this bug.