Bug 1267135 - [RFE] virt-who should support "--proxy" when run it with command-line
[RFE] virt-who should support "--proxy" when run it with command-line
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: virt-who (Show other bugs)
7.2
x86_64 Linux
unspecified Severity medium
: rc
: ---
Assigned To: Radek Novacek
xingge
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-29 02:05 EDT by Liushihui
Modified: 2016-11-30 19:35 EST (History)
3 users (show)

See Also:
Fixed In Version: sgao@redhat.com; hsun@redhat.com
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-20 21:48:45 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Liushihui 2015-09-29 02:05:10 EDT
Description of problem:
When virt-who run at command-line, it can't support connect hyperv/rhevm/vcenter through proxy, it should add --proxy option in command line.

Version-Release number of selected component (if applicable):
virt-who-0.14-9.el7.noarch
subscription-manager-1.15.9-11.el7.x86_64
python-rhsm-1.15.4-5.el7.x86_64

How reproducible:
Always

Precondition:
virt-who can't connect rhevm directly.

Steps to Reproduce:
1. Register system to SAM
2. Run virt-who at command line and monitor rhevm through proxy
[root@hp-z220-06 virt-who.d]# virt-who --rhevm --rhevm-owner=ACME_Corporation --rhevm-env=Library --rhevm-server=https://10.66.79.83:443 --rhevm-username=admin@internal --rhevm-password=redhat --proxy -o -d
Usage: virt-who [-d] [-i INTERVAL] [-o] [--sam|--satellite5|--satellite6] [--libvirt|--vdsm|--esx|--rhevm|--hyperv]

virtwho.py: error: no such option: --proxy
3. [root@hp-z220-06 virt-who.d]# virt-who --help | grep proxy

Actual results:
Virt-who can't support proxy when it run at command line. it also hasn't included any proxy's information in virt-who's help info.

Expected results:
Virt-who should support proxy when it run at command line. it also should include --proxy option in virt-who's help info.

Additional info:
Comment 1 Radek Novacek 2015-09-29 02:17:08 EDT
You can use the environment variable even on command line:

HTTPS_PROXY=https://some.proxy:1234 virt-who --rhevm ...

This is standard way to define proxy for many linux command line applications. Most of them doesn't have extra --proxy parameter.
Comment 2 Radek Novacek 2015-12-15 09:29:29 EST
I don't think adding the --proxy option is not worth the efford. Setting the environment variable seems to be sufficient. Do you agree to close this bug?
Comment 3 Liushihui 2015-12-20 21:48:45 EST
(In reply to Radek Novacek from comment #2)
> I don't think adding the --proxy option is not worth the efford. Setting the
> environment variable seems to be sufficient. Do you agree to close this bug?

Yes, It is acceptable that "HTTPS_PROXY/HTTP_PROXY" replace of "proxy". Therefore, close it. Thanks.

Note You need to log in before you can comment on or make changes to this bug.