Bug 1267192 - Guest on nfs storage fails to start after power off
Guest on nfs storage fails to start after power off
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.6.0
x86_64 Unspecified
high Severity high
: ovirt-3.6.0-rc3
: 3.6.0
Assigned To: Ala Hino
Aharon Canan
storage
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-29 05:43 EDT by Pei Zhang
Modified: 2016-02-10 13:52 EST (History)
18 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-08 05:44:43 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
guest xml and log (7.62 KB, text/plain)
2015-09-29 21:36 EDT, Pei Zhang
no flags Details

  None (edit)
Description Pei Zhang 2015-09-29 05:43:43 EDT
Description of problem:
Guest on nfs storage fail to start after power off 

version:
libvirt-1.2.17-11.el7.x86_64
vdsm-4.17.8-1.el7ev.noarch
qemu-kvm-rhev-2.3.0-26.el7.x86_64
kernel-3.10.0-319.el7.x86_64

How reproduce :
100%

Steps:
1.on rhevm3.6 evn create a healthy guest which disk on NFS storage.
2.power off the guest 
3.start the guest.

Actual resutl :
Guest fail to start 

Expected result:
Guest start successfully.
Comment 1 Oved Ourfali 2015-09-29 09:05:23 EDT
Hard to say who should take a look without any exception/logs. Can you attach the logs? Currently putting on storage team.
Comment 2 Pei Zhang 2015-09-29 21:36 EDT
Created attachment 1078510 [details]
guest xml and log

Sorry for the delay.
The attachment is part of log where I thought the problem is. But I am not sure. 
Thanks.
Comment 4 Tal Nisan 2015-09-30 08:09:00 EDT
Pei, does this occur on every VM in this setup or just this one?
If you create a new VM with a disk on that NFS domain, start it and shut it down will it reproduce?
Comment 5 Allon Mureinik 2015-10-06 05:21:59 EDT
Ala, as this week's contact, please take a look.
Comment 6 Pei Zhang 2015-10-08 05:44:43 EDT
Testing this scenario with the latest tree, this issue CANNOT be reproduced :

OS Tree : 
http://download.englab.nay.redhat.com/pub/rhel/rel-eng/RHEL-7.2-20151001.0/compose/Server/x86_64/os/

Version :
libvirt-1.2.17-12.el7
qemu-kvm-rhev-2.3.0-28.el7
kernel-3.10.0-322.el7
vdsm-4.17.8-1.el7ev

I will close this bug because it works well in current release.
thanks.

Note You need to log in before you can comment on or make changes to this bug.