Bug 1267300 - Errors raised when refreshing the powerstate of a Hyper-V provider
Errors raised when refreshing the powerstate of a Hyper-V provider
Status: CLOSED NOTABUG
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Providers (Show other bugs)
5.4.0
Unspecified Unspecified
medium Severity unspecified
: GA
: 5.6.0
Assigned To: Bronagh Sorota
Jeff Teehan
scvmm:retest
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-29 11:01 EDT by Felix Dewaleyne
Modified: 2016-10-03 12:20 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-12 10:30:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: Unknown


Attachments (Terms of Use)
scvmm.patch (1.71 KB, patch)
2015-09-29 11:01 EDT, Felix Dewaleyne
no flags Details | Diff
error1.log (3.24 KB, text/plain)
2015-09-29 11:06 EDT, Felix Dewaleyne
no flags Details
error2.log (3.24 KB, text/plain)
2015-09-29 11:07 EDT, Felix Dewaleyne
no flags Details
error3.log (3.32 KB, text/plain)
2015-09-29 11:08 EDT, Felix Dewaleyne
no flags Details

  None (edit)
Description Felix Dewaleyne 2015-09-29 11:01:54 EDT
Created attachment 1078408 [details]
scvmm.patch

Description of problem:
Errors raised when refreshing the powerstate of a Hyper-V provider:

Error #1 (While processing hypervisors)

[----] E, [2015-09-25T14:48:26.001425 #21767:1285e8c] ERROR -- : MIQ(EmsRefresh::Refreshers::ScvmmRefresher.refresh) EMS: [SCVMM], id: [1000000000009] Refresh failed
[----] E, [2015-09-25T14:48:26.001556 #21767:1285e8c] ERROR -- : [NoMethodError]: undefined method `collect' for nil:NilClass  Method:[rescue in block in refresh]
[----] E, [2015-09-25T14:48:26.001650 #21767:1285e8c] ERROR -- : /var/www/miq/vmdb/app/models/ems_refresh/parsers/scvmm.rb:251:in `process_host_storages'

Error #2 (While processing hypervisors)

[----] E, [2015-09-25T16:15:41.788747 #42789:985e90] ERROR -- : MIQ(EmsRefresh::Refreshers::ScvmmRefresher.refresh) EMS: [SCVMM], id: [1000000000009] Refresh failed
[----] E, [2015-09-25T16:15:41.788904 #42789:985e90] ERROR -- : [NoMethodError]: undefined method `each' for nil:NilClass  Method:[rescue in block in refresh]
[----] E, [2015-09-25T16:15:41.788988 #42789:985e90] ERROR -- : /var/www/miq/vmdb/app/models/ems_refresh/parsers/scvmm.rb:259:in `map_mount_point_to_datastore'

Error #3 (While processing VMs/Templates – not sure which yet)

[----] E, [2015-09-28T10:49:35.983952 #32401:89de88] ERROR -- : MIQ(EmsRefresh::Refreshers::ScvmmRefresher.refresh) EMS: [SCVMM], id: [1000000000009] Refresh failed
[----] E, [2015-09-28T10:49:35.984142 #32401:89de88] ERROR -- : [NoMethodError]: undefined method `empty?' for nil:NilClass  Method:[rescue in block in refresh]
[----] E, [2015-09-28T10:49:35.984231 #32401:89de88] ERROR -- : /var/www/miq/vmdb/app/models/ems_refresh/parsers/scvmm.rb:397:in `process_vm_guest_devices’


Version-Release number of selected component (if applicable):
cfme 5.4.2.0.1

How reproducible:
all the time on customer setup

Steps to Reproduce:
1. initiate a refresh of the provider
2.
3.

Actual results:
traces in scvmm.rb

Expected results:
refresh goes through

Additional info:
- hyper-V SP1
Comment 3 Felix Dewaleyne 2015-09-29 11:06 EDT
Created attachment 1078409 [details]
error1.log
Comment 4 Felix Dewaleyne 2015-09-29 11:07 EDT
Created attachment 1078410 [details]
error2.log
Comment 5 Felix Dewaleyne 2015-09-29 11:08 EDT
Created attachment 1078411 [details]
error3.log
Comment 6 Dave Johnson 2015-10-05 10:49:26 EDT
Jeff, can you reproduce this in our qe environment?
Comment 7 Jeff Teehan 2015-10-05 13:57:05 EDT
I'm not seeing the issue.  I checked 5.4.2 and 5.4.3, SCVMM SP1 and SCVMM R2 on both appliances.  It all seems to be working fine.

Perhaps there is some other step.  Was the provider working and then just stopped, or has it never worked?
Comment 8 Greg Blomquist 2015-10-12 14:09:27 EDT
Bronagh,

check with Jeff/Dajo to see if there's anything to do here yet.  You may have to wait for more information on this one.
Comment 9 Jeff Teehan 2015-10-12 14:47:18 EDT
Tried again on SCVMM R2 and SCVMM SP1 and I don't see anything.  jt
Comment 10 Bronagh Sorota 2016-07-08 13:24:49 EDT
Nick,
Looks like this issue has been closed on the Red Hat Customer Portal, can we close this BZ? 

thanks
Bronagh

Note You need to log in before you can comment on or make changes to this bug.