Bug 1267378 - Need extra dependencies for texmaker
Need extra dependencies for texmaker
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: texmaker (Show other bugs)
22
All Linux
unspecified Severity medium
: ---
: ---
Assigned To: Mukundan Ragavan
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-29 16:50 EDT by Ivan Krukov
Modified: 2016-04-11 11:41 EDT (History)
3 users (show)

See Also:
Fixed In Version: texmaker-4.5-1.fc23 texmaker-4.5-1.fc22
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-09 16:52:51 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
texmaker installation (40.07 KB, text/plain)
2015-10-01 17:58 EDT, Mukundan Ragavan
no flags Details

  None (edit)
Description Ivan Krukov 2015-09-29 16:50:04 EDT
Description of problem:

Not all the dependencies are specified in the package description. Upon fresh install, application crashes after failure of dynamic library load.

Need to add `qt5-qtwebkit`, `qt5-qtsensors`, and `qt5-qtlocation`.

Version-Release number of selected component (if applicable):

Fedora 22

How reproducible:

Always

Steps to Reproduce:
1. `sudo dnf install texmaker`
2. `texmaker`

Actual results:

`texmaker: error while loading shared libraries: libQt5Positioning.so.5: cannot open shared object file: No such file or directory`

Expected results:

Application starting

Additional info:
Comment 1 Mukundan Ragavan 2015-09-29 20:20:35 EDT
Thanks for the report.

That's strange. I do not remember seeing this. Let me take a look and submit an update as necessary.
Comment 2 Mukundan Ragavan 2015-10-01 17:58 EDT
Created attachment 1079283 [details]
texmaker installation

I cannot reproduce this at all. For example, texmaker pulls in all the dependencies correctly.

Are you sure these deps were not mistakenly erased?
Comment 3 Mukundan Ragavan 2015-10-01 17:58:48 EDT
The attachment shows on F23 but I did not see this F22 either ...

Can you try dnf install texmaker and post the output for me please?
Comment 4 Fedora Update System 2015-10-31 21:50:56 EDT
texmaker-4.5-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-f30e04fb98
Comment 5 Fedora Update System 2015-10-31 21:51:27 EDT
texmaker-4.5-1.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2015-014aa7cb6d
Comment 6 Fedora Update System 2015-11-01 19:24:52 EST
texmaker-4.5-1.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update texmaker'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-014aa7cb6d
Comment 7 Fedora Update System 2015-11-01 19:49:18 EST
texmaker-4.5-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update texmaker'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-f30e04fb98
Comment 8 Fedora Update System 2015-11-09 16:52:49 EST
texmaker-4.5-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 9 Fedora Update System 2015-11-09 19:21:44 EST
texmaker-4.5-1.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.