Bug 1267397 - report_uReport fails with "pos() takes 2 positional arguments but 4 were given"
report_uReport fails with "pos() takes 2 positional arguments but 4 were given"
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: libreport (Show other bugs)
22
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: abrt
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-29 19:09 EDT by Christian Stadelmann
Modified: 2016-05-11 17:22 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-11 17:22:14 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
A compressed archive of the problem directory below /var/spool/abrt as requested in comment #1 (1.31 KB, application/octet-stream)
2015-09-30 12:48 EDT, Christian Stadelmann
no flags Details

  None (edit)
Description Christian Stadelmann 2015-09-29 19:09:15 EDT
Description of problem:
Quite often when trying to report problems, abrt fails to do so.

Version-Release number of selected component (if applicable):
abrt-2.6.1-5.fc22.x86_64
libreport-2.6.2-4.fc22.x86_64
gnome-abrt-1.2.0-4.fc22.x86_64

How reproducible:
don't know exactly, just that it happens often.

Steps to Reproduce:
1. Wait for a crash to happen. 
2. open gnome-abrt
3. try to report the crash

Actual results:
Error reporting fails. In gnome-abrt the header bar changes its title to "pos() takes 2 positional arguments but 4 were given" and the log shows this content:

--- Running report_uReport ---
Line 3, column 59: Traceback header not found.
reporter-ureport failed with exit code 1
(»report_uReport« abgebrochen durch 1)

With this the whole report will be aborted. Backtrace won't be generated and no bug on bugzilla will be opened.

Expected results:
Crash reporter should not fail.

Additional info:
This seems to affect crashes in python packages only. But it doesn't affect all python packages.
Comment 1 Matej Habrnal 2015-09-30 10:42:28 EDT
Thank you for the bug report!

I cannot reproduce the issue on my system. Could you please share the problem data of the crash, which causes the issue, with us? The data are stored in a directory placed in /var/spool/abrt/. To get the path/content of the crash directory just press the right mouse button on the crash in gnome-abrt and choose either "Copy problem's ID to Clipboard" (Ctrl+C) or "Open problem's data directory" (Ctrl+O).

Please create an archive of that directory and upload it somewhere or attach it to this bug report.
Comment 2 Christian Stadelmann 2015-09-30 12:48 EDT
Created attachment 1078744 [details]
A compressed archive of the problem directory below /var/spool/abrt as requested in comment #1

(In reply to Matej Habrnal from comment #1)
> "Copy problem's ID to Clipboard" (Ctrl+C)
won't work since I don't have permissions to list /var/spool/abrt. But the other method works.

See attached archive. I removed the files containing just my uid, my username, my hostname and the environ file. If you need those, please provide a PGP key to encrypt to.

I guess the "pos() takes 2 positional arguments but 4 were given" message is the error of yumex-dnf, the package that crashed.
Comment 3 Christian Stadelmann 2016-05-11 17:22:14 EDT
This issue is gone now.

Note You need to log in before you can comment on or make changes to this bug.