Bug 1267481 - [DOCS] [3.1] [Feature] Document the new Jenkins Image
[DOCS] [3.1] [Feature] Document the new Jenkins Image
Status: CLOSED CURRENTRELEASE
Product: OpenShift Container Platform
Classification: Red Hat
Component: Documentation (Show other bugs)
3.0.0
Unspecified Unspecified
high Severity medium
: ---
: ---
Assigned To: Thien-Thi Nguyen
Vikram Goyal
Vikram Goyal
:
: 1282611 (view as bug list)
Depends On:
Blocks: 1248001
  Show dependency treegraph
 
Reported: 2015-09-30 03:22 EDT by Vikram Goyal
Modified: 2017-03-08 13 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-19 19:36:37 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vikram Goyal 2015-09-30 03:22:42 EDT
Document the Jenkins Image for OpenShift.

The corresponding Developer Trello Card:
https://trello.com/c/pPfn0hTH/650-5-productize-jenkins-image
Comment 2 Thien-Thi Nguyen 2015-10-04 09:15:10 EDT
It looks like the basics are there.  The plan is:

- Remove eof section "Usage" entirely -- it's redundant.
- Find and link / write "Troubleshooting" section (i.e., "How to look at the log files").
- General style cleanup.
Comment 3 Thien-Thi Nguyen 2015-10-21 08:24:12 EDT
Are we still providing version 1.609 of Jenkins?  Would it be correct to track this by looking at the Dockerfile:

 https://github.com/openshift/jenkins/blob/master/1/Dockerfile#L20

I'd like to confirm that this is valid for OSE v3.1.
Comment 4 Ben Parees 2015-10-21 08:49:55 EDT
yes still 1.609.  For OSE you should look at the rhel7 dockerfile:
https://github.com/openshift/jenkins/blob/master/1/Dockerfile.rhel7#L27
Comment 5 Thien-Thi Nguyen 2015-10-26 08:56:25 EDT
PR: https://github.com/openshift/openshift-docs/pull/1108
Comment 6 openshift-github-bot 2015-11-03 08:37:57 EST
Commit pushed to master at https://github.com/openshift/openshift-docs

https://github.com/openshift/openshift-docs/commit/581066eff542b8a6810699f04301524afdd2fb9d
document Jenkins images (bug 1267481)
Comment 7 Vikram Goyal 2015-11-17 01:45:57 EST
*** Bug 1282611 has been marked as a duplicate of this bug. ***
Comment 8 Thien-Thi Nguyen 2015-11-19 19:36:37 EST
ok: https://access.redhat.com/documentation/en/openshift-enterprise/3.1/using-images/chapter-5-other-images
Moving to CLOSED CURRENTRELEASE.

Note You need to log in before you can comment on or make changes to this bug.