Bug 126750 - ccsd doesn't handle close from cman_tool leave properly
Summary: ccsd doesn't handle close from cman_tool leave properly
Status: CLOSED DUPLICATE of bug 126958
Alias: None
Product: Red Hat Cluster Suite
Classification: Retired
Component: gfs   
(Show other bugs)
Version: 4
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jonathan Earl Brassow
QA Contact: Derek Anderson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-06-25 18:44 UTC by Derek Anderson
Modified: 2010-01-12 02:53 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 19:04:13 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Derek Anderson 2004-06-25 18:44:55 UTC
Description of problem:

After quorum was achieved in a three node cluster I started removing
nodes with 'cman_tool leave'.  Then noticed around 2 million of these
message per minute in the /var/log/messages file:

Jun 25 19:17:34 link-10 ccsd[5329]: Received bad communication type on
cluster socket.

Added some debug to cluster/ccs/daemon/cman_mgr.c:
Index: cman_mgr.c
===================================================================
RCS file: /cvs/cluster/cluster/ccs/daemon/cman_mgr.c,v
retrieving revision 1.1
diff -r1.1 cman_mgr.c
116a117
>       log_err("recvmsg returned %d\n", len);
118,119c119,121
<       log_dbg("Msg looks like:\n");
<       log_dbg("%s\n", (char *)&ch);
---
>       log_err("Msg looks like:\n");
>       log_err("Type is %d\n", ch.comm_type);
>       log_err("%s\n", (char *)&ch);

Error output then looks like:
Jun 25 19:17:34 link-10 ccsd[5329]: recvmsg returned 0
Jun 25 19:17:34 link-10 ccsd[5329]: Received bad communication type on
cluster socket.
Jun 25 19:17:34 link-10 ccsd[5329]: Msg looks like:
Jun 25 19:17:34 link-10 ccsd[5329]: Type is 0

So it seems ccsd is not handling a client close properly.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Jonathan Earl Brassow 2004-06-29 21:26:22 UTC

*** This bug has been marked as a duplicate of 126958 ***

Comment 2 Kiersten (Kerri) Anderson 2004-11-16 19:13:04 UTC
Updating version to the right level in the defects.  Sorry for the storm.

Comment 3 Red Hat Bugzilla 2006-02-21 19:04:13 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.