Bug 1267535 - "katello-service restart" does not restart goferd on Capsule
"katello-service restart" does not restart goferd on Capsule
Status: CLOSED NEXTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Capsule (Show other bugs)
6.1.1
x86_64 Linux
medium Severity medium (vote)
: GA
: 6.X
Assigned To: Chris Roberts
Katello QA List
http://projects.theforeman.org/issues...
: Triaged
: 1454938 (view as bug list)
Depends On:
Blocks: 260381
  Show dependency treegraph
 
Reported: 2015-09-30 06:55 EDT by Pavel Moravec
Modified: 2017-08-01 16:02 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-01 16:02:48 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Foreman Issue Tracker 16586 None None None 2016-09-20 14:01 EDT

  None (edit)
Description Pavel Moravec 2015-09-30 06:55:49 EDT
Description of problem:
"katello-service restart" should restart all Satellite/Capsule-related processes. But it does not restart goferd that is critical e.g. for capsule sync.

(same applies to katello-service [start|stop|..])


Version-Release number of selected component (if applicable):
katello-service-2.2.0.15-1.el7sat.noarch


How reproducible:
100%


Steps to Reproduce:
1. On a capsule, run:
ps aux | grep gofer | grep -v grep
katello-service restart
ps aux | grep gofer | grep -v grep


Actual results:
Both "ps" outputs provide same PID of goferd service/process.


Expected results:
goferd should be restarted and running under a new PID.


Additional info:
Comment 2 Bryan Kearney 2016-07-08 16:39:33 EDT
Per 6.3 planning, moving out non acked bugs to the backlog
Comment 4 Mike McCune 2017-07-18 16:46:53 EDT
*** Bug 1454938 has been marked as a duplicate of this bug. ***
Comment 5 Bryan Kearney 2017-08-01 16:02:48 EDT
The fix to this bug will be delivered with release 6.3 of Satellite.

Note You need to log in before you can comment on or make changes to this bug.