Bug 1267590 - RHEL 7 kernel-rt debuginfo packages are not handled properly
RHEL 7 kernel-rt debuginfo packages are not handled properly
Status: CLOSED CURRENTRELEASE
Product: Fedora EPEL
Classification: Fedora
Component: retrace-server (Show other bugs)
epel7
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Michal Toman
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-30 09:37 EDT by Kyle Walker
Modified: 2016-06-03 03:07 EDT (History)
5 users (show)

See Also:
Fixed In Version: retrace-server-1.13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-03 03:07:58 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to fix this bug from Kyle Walker (865 bytes, application/octet-stream)
2015-10-03 17:37 EDT, Dave Wysochanski
no flags Details

  None (edit)
Description Kyle Walker 2015-09-30 09:37:15 EDT
Description of problem:
 retrace-server-1.12-3.el6.noarch does not properly extract debuginfo packages. This seems to be due to a minor change in naming convention.

Version-Release number of selected component (if applicable):
 retrace-server-1.12-3.el6.noarch

How reproducible:
 Easily

Steps to Reproduce:
1. Capture a vmcore on a system using the kernel-rt kernel
2. Queue the vmcore via the retrace-server interface
3. Verify that the vmcore has queued correctly

Actual results:
As is seen in the debug log:
DEBUG:root:   2015-09-30 08:16:56 Parsing kernel version '3.10.0-229.14.1.rt56.141.13.el7_1.x86_64'
DEBUG:root:   2015-09-30 08:16:56 Version: '3.10.0'; Release: '229.14.1.rt56.141.13.el7_1'; Arch: 'x86_64'; Flavour: 'None'; Realtime: False
DEBUG:root:   2015-09-30 08:16:56 Parsing kernel version '3.10.0-229.14.1.rt56.141.13.el7_1.x86_64'
DEBUG:root:   2015-09-30 08:16:56 Version: '3.10.0'; Release: '229.14.1.rt56.141.13.el7_1'; Arch: 'x86_64'; Flavour: 'None'; Realtime: False
DEBUG:root:   2015-09-30 08:16:56 Trying debuginfo file: /cores/retrace/repos/kernel/Packages/kernel-debuginfo-3.10.0-229.14.1.rt56.141.13.el7_1.x86_64.rpm
DEBUG:root:   2015-09-30 08:16:56 Trying debuginfo file: /cores/retrace/repos/kernel/kernel-debuginfo-3.10.0-229.14.1.rt56.141.13.el7_1.x86_64.rpm
DEBUG:root:   2015-09-30 08:16:56 Trying debuginfo file: /cores/retrace/repos/download/Packages/kernel-debuginfo-3.10.0-229.14.1.rt56.141.13.el7_1.x86_64.rpm
DEBUG:root:   2015-09-30 08:16:56 Trying debuginfo file: /cores/retrace/repos/download/kernel-debuginfo-3.10.0-229.14.1.rt56.141.13.el7_1.x86_64.rpm
DEBUG:root:   2015-09-30 08:16:56 Trying debuginfo file: /mnt/brewroot/packages/kernel/3.10.0/229.14.1.rt56.141.13.el7_1/x86_64/kernel-debuginfo-3.10.0-229.14.1.rt56.141.13.el7_1.x86_64.rpm
DEBUG:root:   2015-09-30 08:16:56 Trying debuginfo URL: http://download.devel.redhat.com/brewroot/packages/kernel/3.10.0/229.14.1.rt56.141.13.el7_1/x86_64/kernel-debuginfo-3.10.0-229.14.1.rt56.141.13.el7_1.x86_64.rpm
ERROR:root:   2015-09-30 08:16:56 prepare_debuginfo failed: Unable to find debuginfo package


Expected results:
 vmcore queues successfully

Additional info:
 This seems to be primarily due to the "Realtime" flag being evaluated as "False".
Comment 3 Dave Wysochanski 2015-10-03 17:37:37 EDT
Created attachment 1079674 [details]
Patch to fix this bug from Kyle Walker
Comment 4 Dave Wysochanski 2015-10-03 17:48:40 EDT
Kyle - I built your one-liner and indeed it seems to fix the problem.
Are you happy with the 1-liner or do you think it needs more investigation?
Comment 6 Kyle Walker 2015-10-05 08:15:10 EDT
Dave,

I think that should be good. I can't think of any circumstances where we would hit false positives.

ACK.

Kyle Walker
Comment 7 Dave Wysochanski 2015-10-06 11:14:23 EDT
Submitted to mtoman against upstream
commit 76ef38e9132f1a1284b71e4095013388b8742e47
Merge: 1742972 4eeea83
Author: Michal Toman <michal.toman@gmail.com>
Date:   Tue Sep 15 10:40:33 2015 +0200

    Merge pull request #88 from abrt/add_hooks
    
    Script hooks
Comment 8 Dave Wysochanski 2015-10-06 12:02:49 EDT
Looks like mtoman recently merged another fix.

commit 09dd8e0e15e73fea2eb6ff6a5273d6c37d682ca0
Author: Michal Toman <mtoman@fedoraproject.org>
Date:   Mon Oct 5 23:51:59 2015 +0200

    update handling of RT kernels
    
    fixes RHBZ#1267590
    
    Signed-off-by: Michal Toman <mtoman@fedoraproject.org>

diff --git a/src/lib/retrace.py b/src/lib/retrace.py
index c8be849..9074786 100644
--- a/src/lib/retrace.py
+++ b/src/lib/retrace.py
@@ -1399,7 +1399,7 @@ class KernelVer(object):
                     self.release = self.release[:-len(kf)]
                     break
 
-        self.rt = self.release.endswith("rt")
+        self.rt = "rt" in self.release
Comment 9 Mike McCune 2016-03-28 19:06:24 EDT
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions

Note You need to log in before you can comment on or make changes to this bug.