Bug 1267675 - rome fails to build from source
rome fails to build from source
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: rome (Show other bugs)
6.8
Unspecified Unspecified
unspecified Severity unspecified
: rc
: 6.9
Assigned To: Mat Booth
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-30 11:52 EDT by Omair Majid
Modified: 2017-05-25 11:50 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-05-25 11:50:10 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to use the current system jdom jar (390 bytes, patch)
2015-09-30 11:55 EDT, Omair Majid
no flags Details | Diff

  None (edit)
Description Omair Majid 2015-09-30 11:52:53 EDT
Description of problem:

I was trying to build rome to test OpenJDK7 on RHEL 6, but rome fails to build.

Version-Release number of selected component (if applicable):


How reproducible:
Every time

Steps to Reproduce:
1. rhpkg clone -a rome
2. cd rome
3. rhpkg switch-branch rhel-6.8
4. rhpkg scratch-build

Or

1. rhpkg clone -a rome
2. cd rome
3. rhpkg switch-branch rhel-6.8
4. # yum-builddep ./rome.spec
5. rhpkg local


Actual results:
Build fails

Expected results:
Build succeeds
Comment 2 Omair Majid 2015-09-30 11:55 EDT
Created attachment 1078714 [details]
patch to use the current system jdom jar

It looks like rome is looking for a version of jdom no longer included with RHEL. The patch makes rome use the current version in RHEL to build.

Note You need to log in before you can comment on or make changes to this bug.