Bug 1267711 - It is not possible to reselect the same icon in Chrome and IE
It is not possible to reselect the same icon in Chrome and IE
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: Frontend.Core (Show other bugs)
4.0.0
Unspecified Unspecified
unspecified Severity medium (vote)
: ovirt-3.6.3
: 3.6.3
Assigned To: jniederm
Lukas Svaty
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-30 14:32 EDT by jniederm
Modified: 2016-02-18 06:03 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-18 06:03:38 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Virt
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑3.6.z+
mgoldboi: planning_ack+
michal.skrivanek: devel_ack+
mavital: testing_ack+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 46895 master MERGED webadmin: Re-selection of the same icon works in IE and Chrome Never
oVirt gerrit 46905 ovirt-engine-3.6 MERGED webadmin: Re-selection of the same icon works in IE and Chrome Never
oVirt gerrit 49533 master MERGED core: Fix of repetitive setting same custom icon 2015-12-17 02:33 EST
oVirt gerrit 50463 ovirt-engine-3.6 MERGED core: Fix of repetitive setting same custom icon 2015-12-17 04:38 EST

  None (edit)
Description jniederm 2015-09-30 14:32:16 EDT
Description of problem:
It is not possible to upload a custom icon, then select OS default icons and then upload the same custom icon again in IE and Chrome based browsers. It works ok in Firefox.

Version-Release number of selected component (if applicable):
4.0 master, commit 0c71398

How reproducible:
100%

Steps to Reproduce:
1. Open edit vm dialog
2. Select Icon tab
3. Upload custom icon
4. Click 'Use default'
5. Upload the same custom icon again

Actual results:
nothing

Expected results:
Icon preview is updated by selected icon

Additional info:
The cause is that <input type="file"> in IE and Chrome doesn't fire 'change' event if the same file is selected again.
Comment 1 Red Hat Bugzilla Rules Engine 2015-10-18 04:22:02 EDT
Fixed bug tickets must have version flags set prior to fixing them. Please set the correct version flags and move the bugs back to the previous status after this is corrected.
Comment 2 Red Hat Bugzilla Rules Engine 2015-10-19 06:52:48 EDT
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.
Comment 3 Yaniv Lavi 2015-10-29 08:36:28 EDT
In oVirt testing is done on single release by default. Therefore I'm removing the 4.0 flag. If you think this bug must be tested in 4.0 as well, please re-add the flag. Please note we might not have testing resources to handle the 4.0 clone.
Comment 4 Lukas Svaty 2015-11-26 07:07:22 EST
Failed QA in firefox/chrome:

rhevm-3.6.1-0.2.el6.noarch


Scenario:
1. Edit VM -> Upload new icon -> Save VM
2. Edit VM -> Use default icon -> Save VM
3. Edit VM -> Use upload same icon from step 1. -> Save VM

Actual result:
Action blocked by engine: "Large icon of provided id does not exist."

Expected result:
Should succeed again.
Comment 5 Red Hat Bugzilla Rules Engine 2015-11-27 00:45:55 EST
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.
Comment 6 Red Hat Bugzilla Rules Engine 2016-01-28 07:15:33 EST
Bug tickets that are moved to testing must have target release set to make sure tester knows what to test. Please set the correct target release before moving to ON_QA.
Comment 7 Red Hat Bugzilla Rules Engine 2016-01-28 07:24:47 EST
Bug tickets that are moved to testing must have target release set to make sure tester knows what to test. Please set the correct target release before moving to ON_QA.
Comment 8 Red Hat Bugzilla Rules Engine 2016-01-28 07:28:37 EST
Bug tickets that are moved to testing must have target release set to make sure tester knows what to test. Please set the correct target release before moving to ON_QA.
Comment 9 Lukas Svaty 2016-02-04 06:49:51 EST
verified in rhevm-3.6.3-0.1.el6.noarch

Note You need to log in before you can comment on or make changes to this bug.