Bug 1267713 - [abrt] evolution: strlen(): evolution killed by SIGSEGV
[abrt] evolution: strlen(): evolution killed by SIGSEGV
Status: CLOSED DUPLICATE of bug 1192773
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
22
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Milan Crha
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:4780aad7948fe3a55e01b322654...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-30 14:37 EDT by Brian J. Murrell
Modified: 2015-10-02 10:59 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-02 10:59:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (171.92 KB, text/plain)
2015-09-30 14:37 EDT, Brian J. Murrell
no flags Details
File: cgroup (284 bytes, text/plain)
2015-09-30 14:37 EDT, Brian J. Murrell
no flags Details
File: core_backtrace (18.88 KB, text/plain)
2015-09-30 14:37 EDT, Brian J. Murrell
no flags Details
File: dso_list (30.24 KB, text/plain)
2015-09-30 14:37 EDT, Brian J. Murrell
no flags Details
File: environ (2.35 KB, text/plain)
2015-09-30 14:37 EDT, Brian J. Murrell
no flags Details
File: limits (1.29 KB, text/plain)
2015-09-30 14:37 EDT, Brian J. Murrell
no flags Details
File: maps (153.58 KB, text/plain)
2015-09-30 14:37 EDT, Brian J. Murrell
no flags Details
File: mountinfo (7.59 KB, text/plain)
2015-09-30 14:37 EDT, Brian J. Murrell
no flags Details
File: namespaces (85 bytes, text/plain)
2015-09-30 14:37 EDT, Brian J. Murrell
no flags Details
File: open_fds (7.75 KB, text/plain)
2015-09-30 14:37 EDT, Brian J. Murrell
no flags Details
File: proc_pid_status (1.02 KB, text/plain)
2015-09-30 14:37 EDT, Brian J. Murrell
no flags Details
File: var_log_messages (346 bytes, text/plain)
2015-09-30 14:38 EDT, Brian J. Murrell
no flags Details

  None (edit)
Description Brian J. Murrell 2015-09-30 14:37:44 EDT
Description of problem:
Switching to a new message

Version-Release number of selected component:
evolution-3.16.5-3.fc22

Additional info:
reporter:       libreport-2.6.2
backtrace_rating: 4
cmdline:        evolution
crash_function: strlen
executable:     /usr/bin/evolution
global_pid:     18503
kernel:         4.1.7-200.fc22.x86_64
runlevel:       N 5
type:           CCpp
uid:            1001

Truncated backtrace:
Thread no. 1 (6 frames)
 #0 strlen at ../sysdeps/x86_64/strlen.S:106
 #1 g_strdup at gstrfuncs.c:355
 #2 ml_getselected_cb at message-list.c:5050
 #3 e_tree_selection_model_foreach at e-tree-selection-model.c:761
 #4 message_list_get_selected at message-list.c:5071
 #5 on_selection_changed_cmd at message-list.c:4905
Comment 1 Brian J. Murrell 2015-09-30 14:37:47 EDT
Created attachment 1078764 [details]
File: backtrace
Comment 2 Brian J. Murrell 2015-09-30 14:37:48 EDT
Created attachment 1078765 [details]
File: cgroup
Comment 3 Brian J. Murrell 2015-09-30 14:37:49 EDT
Created attachment 1078766 [details]
File: core_backtrace
Comment 4 Brian J. Murrell 2015-09-30 14:37:51 EDT
Created attachment 1078767 [details]
File: dso_list
Comment 5 Brian J. Murrell 2015-09-30 14:37:52 EDT
Created attachment 1078768 [details]
File: environ
Comment 6 Brian J. Murrell 2015-09-30 14:37:53 EDT
Created attachment 1078769 [details]
File: limits
Comment 7 Brian J. Murrell 2015-09-30 14:37:55 EDT
Created attachment 1078770 [details]
File: maps
Comment 8 Brian J. Murrell 2015-09-30 14:37:56 EDT
Created attachment 1078771 [details]
File: mountinfo
Comment 9 Brian J. Murrell 2015-09-30 14:37:57 EDT
Created attachment 1078772 [details]
File: namespaces
Comment 10 Brian J. Murrell 2015-09-30 14:37:58 EDT
Created attachment 1078773 [details]
File: open_fds
Comment 11 Brian J. Murrell 2015-09-30 14:37:59 EDT
Created attachment 1078774 [details]
File: proc_pid_status
Comment 12 Brian J. Murrell 2015-09-30 14:38:00 EDT
Created attachment 1078775 [details]
File: var_log_messages
Comment 13 Milan Crha 2015-10-02 10:59:47 EDT
Thanks for a bug report. I see in the backtrace that Thread 25 calls gtk+ functions in a non-UI thread, namely inside imapx_parser_thread(), which it surely shouldn't happen. The current stable version (3.18.0), which is part of Fedora 23, has this imapx_parser_thread() removed completely, which obsoletes this issue there.

A similar issue had been already reported, thus I mark this as a duplicate of it.

*** This bug has been marked as a duplicate of bug 1192773 ***

Note You need to log in before you can comment on or make changes to this bug.