Bug 1267733 - ectd cluster install fails when hosts have different names network interfaces
ectd cluster install fails when hosts have different names network interfaces
Status: CLOSED CURRENTRELEASE
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer (Show other bugs)
3.0.0
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Scott Dodson
Gaoyun Pei
:
: 1267740 (view as bug list)
Depends On:
Blocks: 1272201
  Show dependency treegraph
 
Reported: 2015-09-30 15:54 EDT by Ryan Howe
Modified: 2015-12-02 03:57 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-20 10:42:49 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ryan Howe 2015-09-30 15:54:28 EDT
Description of problem:
ectd cluster install fails when differently named network interfaces are used

Version-Release number of selected component (if applicable):
Latest

How reproducible:
Customer 

Steps to Reproduce:
Set up to install etcd clusterd on a host with interface "ens192" and another host wiht  "eth02"


Actual results:
fatal: [uslv-dpas-etc04.amgen.com] => {'msg': "AnsibleUndefinedVariable: One or more undefined variables: 'dict object' has no attribute u'ansible_ens192'", 'failed': True}
fatal: [uslv-dpas-etc04.amgen.com] => {'msg': "AnsibleUndefinedVariable: One or more undefined variables: 'dict object' has no attribute u'ansible_ens192'", 'failed': True}
fatal: [aws-dpas-etc06.amgen.com] => {'msg': "AnsibleUndefinedVariable: One or more undefined variables: 'dict object' has no attribute u'ansible_eth0'", 'failed': True}
fatal: [aws-dpas-etc06.amgen.com] => {'msg': "AnsibleUndefinedVariable: One or more undefined variables: 'dict object' has no attribute u'ansible_eth0'", 'failed': True}


Expected results:

Pass

Additional info:
https://github.com/openshift/openshift-ansible/blob/0ded8248eedf3ad1ceac44eac486e83a53960bb5/roles/etcd/templates/etcd.conf.j2#L4-L6
Comment 2 Brenton Leanhardt 2015-10-09 08:46:58 EDT
*** Bug 1267740 has been marked as a duplicate of this bug. ***
Comment 3 Brenton Leanhardt 2015-10-09 08:48:55 EDT
See Bug #1267740 for more detail.  This should be ready for testing and it looks like Gao Yun has been working on it too.

https://github.com/openshift/openshift-ansible/pull/437
Comment 7 Jason DeTiberus 2015-10-27 11:03:39 EDT
Added a fix to https://github.com/openshift/openshift-ansible/pull/702 to correct the original issue of trying to reference the wrong interface on different hosts.
Comment 8 Gaoyun Pei 2015-10-28 01:51:24 EDT
The same error as https://bugzilla.redhat.com/show_bug.cgi?id=1272201#c10

Move this to Assigned
Comment 9 Jason DeTiberus 2015-10-28 15:38:39 EDT
I updated https://github.com/openshift/openshift-ansible/pull/702 to address some edge cases. We now test to make sure that we can read the variables we expect from the interface specified by etcd_interface for the specified host.

If you are still seeing issues, please update with the inventory file you are using as well as the output of `ip addr` on the hosts.
Comment 10 Gaoyun Pei 2015-10-29 02:34:15 EDT
This issue is actually a sub-issue in BZ#1272201, so will track the progress in BZ#1272201.
Once BZ#1272201 is verified, this bug could be moved to verified too.
Comment 11 Gaoyun Pei 2015-10-30 03:10:56 EDT
Move this bug to VERIFIED as BZ#1272201 is verified.

Note You need to log in before you can comment on or make changes to this bug.