Bug 126777 - Package gnome-utils needs /usr/bin/gtk-query-immodules-2.0, this is not available.
Summary: Package gnome-utils needs /usr/bin/gtk-query-immodules-2.0, this is not avail...
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-utils   
(Show other bugs)
Version: 2
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Matthias Clasen
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-06-26 13:57 UTC by Bob Gustafson
Modified: 2007-11-30 22:10 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-18 03:36:04 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Bob Gustafson 2004-06-26 13:57:28 UTC
Description of problem:

 .Package gnome-utils needs /usr/bin/gtk-query-immodules-2.0
  this is not available.

  (but it is there..)

Version-Release number of selected component (if applicable):

 Operation is attempted update of gnome-utils-2.6.0-3

How reproducible:

  Just showed up this morning.

Steps to Reproduce:
1.  yum update
2.  (see below)
3.
  
Actual results:

  yum update
  ...
  ...
  Resolving dependencies
  .Package gnome-utils needs /usr/bin/gtk-query-immodules-2.0, this is  
  not available.

Now, trying to exclude it (yum problem?)

[root@hoho2 root]# yum --exclude gnome-utils update
Gathering header information file(s) from server(s)
Server: Fedora Core 2 - Development Tree
Finding updated packages
Downloading needed headers
Resolving dependencies
.Package gnome-utils needs /usr/bin/gtk-query-immodules-2.0, this is
not available.

[root@hoho2 root]# rpm -q gnome-utils
gnome-utils-2.6.0-3

[root@hoho2 root]# ls -l /usr/bin/gtk-query-immodules*
-rwxr-xr-x  1 root root 9748 Jun 15 19:13 /usr/bin/gtk-query-immodules-2.0
[root@hoho2 root]#


Expected results:


Additional info:

Comment 1 Bob Gustafson 2004-07-06 18:34:24 UTC
Seems to be ok now

[root@hoho2 init.d]# yum install gnome-utils
Gathering header information file(s) from server(s)
Server: Fedora Core 2 - Development Tree
Finding updated packages
Downloading needed headers
gnome-utils is installed and is the latest version.
No actions to take

[root@hoho2 init.d]# rpm -q gnome-utils
gnome-utils-2.6.2-1
[root@hoho2 init.d]#

Works for me


Comment 2 Matthew Miller 2004-09-15 17:59:10 UTC
This is suddenly a problem again, not with the development tree, but
with the FC2 release, due to this update:
<http://www.redhat.com/archives/fedora-announce-list/2004-September/msg00021.html>

Since removing gnome-utils causes printing to break (and all sorts of
other things), this seems pretty urgent.

Comment 3 Brian May 2004-09-15 18:17:42 UTC
I'll have to add the "me too" post to the list.  Got the message
Fedora Update Notification for the gtk2 an gdk-pixbuf updates and when
I run yum update I get this:

Gathering header information file(s) from server(s)
Server: Fedora Core 2 - i386 - Base
Server: Dag Wieers RPM Repository for Fedora Core 2
Server: Fedora Core 2 - i386 - Released Updates
Finding updated packages
Downloading needed headers
Resolving dependencies
.Package gnome-utils needs /usr/bin/gtk-query-immodules-2.0, this is
not available.

but the file is there:
[root@router01 root]# ls /usr/bin/gtk-query-immodules-2.0 -l
-rwxr-xr-x  1 root root 9728 Mar 17 01:18 /usr/bin/gtk-query-immodules-2.0

[root@router01 root]# rpm -q gnome-utils
gnome-utils-2.6.0-2

as of yesterday I was up to date with all the releases..

Comment 4 Matthew Miller 2004-09-15 18:20:43 UTC
This is also a problem with iiimf-gtk (src package iiimf-sdk). Should
I file a separate bug for that?

Comment 5 Matthew Miller 2004-09-15 18:33:34 UTC
(er -- src package im-sdk, I mean. sorry)

Comment 6 Daniel Rogers 2004-09-15 18:50:46 UTC
Yeah, I just started getting this today with gnome-utils too.  I also
have the needed file in place.


Comment 7 Matthew Miller 2004-09-15 18:53:07 UTC
The problem is that the new file in the new gtk2 package has a "-32"
appended to the end.

Comment 8 Matthias Clasen 2004-09-15 19:26:31 UTC
The update inadvertedly contains biarch changes from FC3. 
I'm working on a fix.

Comment 9 Craig Sherwood 2004-09-15 22:26:09 UTC
Glad the problem is found. I'll add my voice to others who are
suffering this quandry. (That is having the needed file: "-rwxr-xr-x 
1 root root 9728 Mar 17 04:18 /usr/bin/gtk-query-immodules-2.0" and
having a dependency failure)

Comment 10 Christopher Aillon 2004-09-16 05:41:44 UTC
Looks like matthias is on the case here.  Re-assigning.

Comment 11 Philip Van Hoof 2004-09-16 07:33:39 UTC
Please update the mirrors asap. This is breaking the update of every
FC2 user!

Comment 12 Brian May 2004-09-16 21:07:18 UTC
Seems to be fixed.

yum update finished properly.

Updated:  gtk2 2.4.7-2.5.i386 gtk2-devel 2.4.7-2.5.i386 gdk-pixbuf
1:0.22.0-11.3.5.i386
Transaction(s) Complete

Comment 13 Daniel Rogers 2004-09-16 22:07:28 UTC
Yup, works for me now too.


Comment 14 Scrimson J Pickens 2004-09-16 22:14:53 UTC
It's not working for me yet, I'm confused here.  Is it just a mirror
update lag or something perhaps?

Comment 15 Scrimson J Pickens 2004-09-16 22:54:21 UTC
must have been, I'm all good now

Comment 16 Bob Gustafson 2004-09-17 19:04:08 UTC
I'm good on gnome-utils. Have another yum problem, but not gnome-utils.


Comment 17 Keith Jaska 2004-09-25 01:07:03 UTC
I'm still having the problem, what channel is everyone using??

Comment 18 Matthias Clasen 2004-09-25 13:07:39 UTC
Do you have gtk2-2.4.7-2.6 ?

Comment 19 Keith Jaska 2004-09-25 15:27:39 UTC
RE: Comment# 17

I do now :)

Turns out that when I first discovered the dependency problem, I
attempted to fix it by upgrading to the "cutting edge" version of
gnome-utils (gnome-utils-2.6.0-2 --> gnome-utils-2.7.91-1.i386.rpm).
In any case, it wasn't until after I uninstalled gnome-utils-2.7.91-1
that I was able to successfully install gtk2-2.4.7-2.6.
Once gtk2-2.4.7-2.6 was correctly install, I was able to re-install
gnome-utils-2.6.0-2 without issue.

Thanks All!


Note You need to log in before you can comment on or make changes to this bug.