Bug 126778 - Directories 'msgs' and 'pxelinux.cfg' are missing
Directories 'msgs' and 'pxelinux.cfg' are missing
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: system-config-netboot (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-26 10:52 EDT by Olivier Baudron
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-07-21 14:37:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Olivier Baudron 2004-06-26 10:52:49 EDT
From a clean /tftpboot/ directory, system-config-netboot creates:
    /tftpboot/linux-install/
    /tftpboot/linux-install/Fedora/   (for example)
and then crashes because the following directories are missing:
    /tftpboot/linux-install/msgs/
    /tftpboot/linux-install/pxelinux.cfg/

One error message is:

--------------------------------------------------------------------
~# Traceback (most recent call last):
  File "/usr/sbin/system-config-netboot", line 428, in ?
    rc=gui.on_firsttime_druid_activate(None)
  File "/usr/sbin/system-config-netboot", line 304, in
on_firsttime_druid_activate
    pxeos.pxeOSList().append(OS)
  File "/usr/share/system-config-netboot/pxeos.py", line 84, in append
    self.saveOSList(osList)
  File "/usr/share/system-config-netboot/pxeos.py", line 91, in saveOSList
    bootFD=open("%s/msgs/boot.msg" % PXEBOOTDIR,"w")sony:/# Traceback
(most recent call last):
  File "/usr/sbin/system-config-netboot", line 428, in ?
    rc=gui.on_firsttime_druid_activate(None)
  File "/usr/sbin/system-config-netboot", line 304, in
on_firsttime_druid_activate
    pxeos.pxeOSList().append(OS)
  File "/usr/share/system-config-netboot/pxeos.py", line 84, in append
    self.saveOSList(osList)
  File "/usr/share/system-config-netboot/pxeos.py", line 91, in saveOSList
    bootFD=open("%s/msgs/boot.msg" % PXEBOOTDIR,"w")
IOError: [Errno 2] No such file or directory:
'/tftpboot/linux-install//msgs/boot.msg'

IOError: [Errno 2] No such file or directory:
'/tftpboot/linux-install//msgs/boot.msg'
--------------------------------------------------------------------
Comment 1 Daniel Walsh 2004-07-20 11:09:34 EDT
The post install of the RPM should have created those directories.

Dan
Comment 2 Olivier Baudron 2004-07-21 04:35:37 EDT
Yes, this is indeed a mistake from me.

The problem is that: /tftpboot/linux-install/ (and its sons) are not
owned by the package although they are created by it in the
post-install process.

So, I may have deleted the directory inadvertently.

Note You need to log in before you can comment on or make changes to this bug.