Bug 126780 - modprobe of ide-scsi module causes a segmentation fault
modprobe of ide-scsi module causes a segmentation fault
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-26 11:51 EDT by Sergio
Modified: 2015-01-04 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-14 00:21:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sergio 2004-06-26 11:51:31 EDT
Description of problem: When the command /sbin/modprobe ide-scsi is
issued, a segmentation fault message is displayed.


Version-Release number of selected component (if applicable): 2.6.6-1.245


How reproducible: Always

Steps to Reproduce:
1. Compile kernel with CONFIG_BLK_DEV_IDESCSI=m
2. Install the Kernel
3. Issue the command /sbin/modprobe ide-scsi
  
Actual results:

Segmentation Fault


Expected results:

Successful module load

Additional info:

Jun 26 11:43:24 master kernel: Unable to handle kernel NULL pointer
dereference at virtual address 00000000
Jun 26 11:43:24 master kernel:  printing eip:
Jun 26 11:43:24 master kernel: 00000000
Jun 26 11:43:24 master kernel: *pde = 00000000
Jun 26 11:43:24 master kernel: Oops: 0000 [#1]
Jun 26 11:43:24 master kernel: Modules linked in: ide_scsi udf
nls_utf8 ppp_deflate zlib_deflate ppp_async ppp_generic slhc
snd_pcm_oss floppy snd_mixer_oss snd_intel8x0 snd_ac97_codec snd_pcm
snd_timer snd_page_alloc gameport snd_mpu401_uart snd_rawmidi
snd_seq_device snd soundcore r128 ipt_REJECT iptable_filter ip_tables
parport_pc lp parport ipv6 autofs4 sunrpc tulip sundance mii sg
scsi_mod microcode dm_mod uhci_hcd button battery asus_acpi ac ext3 jbd
Jun 26 11:43:24 master kernel: CPU:    0
Jun 26 11:43:24 master kernel: EIP:    0060:[<00000000>]    Not tainted
Jun 26 11:43:24 master kernel: EFLAGS: 00210202   (2.6.6-1.435)
Jun 26 11:43:24 master kernel: EIP is at 0x0
Jun 26 11:43:24 master kernel: eax: 00000000   ebx: 022cc9b8   ecx:
022cc9b8   edx: 00000000
Jun 26 11:43:24 master kernel: esi: 12f83180   edi: 022cc9a0   ebp:
04f0f000   esp: 04f0ffb0
Jun 26 11:43:24 master kernel: ds: 007b   es: 007b   ss: 0068
Jun 26 11:43:24 master kernel: Process modprobe (pid: 27086,
threadinfo=04f0f000 task=0a7c98b0)
Jun 26 11:43:24 master kernel: Stack: 021280e8 04f0ffc4 08645a38
08057260 ffff3200 f6fab008 00036af9 08645a38
Jun 26 11:43:24 master kernel:        08645a38 08057260 fee4a048
00000080 0000007b 0000007b 00000080 00a1d402
Jun 26 11:43:24 master kernel:        00000073 00200246 fee49fec 0000007b
Jun 26 11:43:24 master kernel: Call Trace:
Jun 26 11:43:24 master kernel:  [<021280e8>] sys_init_module+0xe7/0x1c0
Jun 26 11:43:24 master kernel:
Jun 26 11:43:24 master kernel: Code:  Bad EIP value.
Comment 1 Dave Jones 2005-01-14 00:21:43 EST
this should be fixed since quite some time ago.
reopen if its still occuring.

Note You need to log in before you can comment on or make changes to this bug.