Bug 1267886 - STOP rename python-dnf to python2-dnf and back all the time
STOP rename python-dnf to python2-dnf and back all the time
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
22
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-01 05:56 EDT by Harald Reindl
Modified: 2015-10-13 09:37 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-13 09:37:02 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Harald Reindl 2015-10-01 05:56:56 EDT
first it was "python-dnf", then it was "python2-dnf", now it's "python-dnf" and you maintainers obviously never heard about Obsoletes/Provides in SPEC files to avoid spit early testers in their face by for them to deal with "rpm --nodpes"

python-dnf-1.1.2-4.fc22.noarch.rpm
python2-dnf-1.1.2-2.fc22.noarch
Comment 1 Harald Reindl 2015-10-01 06:01:07 EDT
WTF

Package python-dnf-plugins-core-0.1.12-2.fc22.noarch has missing requires of python2-dnf >= ('0', '1.1.2', None)
Package python-dnf-plugins-core-0.1.12-2.fc22.noarch has missing requires of python2-dnf < ('0', '2.0', None)
Comment 2 Parag Nemade 2015-10-01 07:25:56 EDT
I really think f22 branch updates of dnf* packages should be updated separately, I see always merge happens from master and then struggle for having successful f22 koji build due to python-dnf/python2-dnf package names.
Comment 3 Harald Reindl 2015-10-01 07:30:50 EDT
it would be enough *one* time make a decision how it is named and the just use Provides/Obsoletes and just rebuild one the plugins to keep it in sync, not break upgrades and don't force users to deal with --noeps

to be honest it scares me terrible that a group maintaining a package manager don't use Provides/Obsoletes in a sane way

1.1.2-2 was completly broken in F22 and did not show any updates
1.1.2-4 works at least for basic operations
python-dnf-plugins-core with 1.1.2-4 has a broken dep
Comment 4 Jaroslav Mracek 2015-10-13 09:37:02 EDT
It has been released for Fedora 22 by a mistake and package was removed from repository. Sorry for it.

Note You need to log in before you can comment on or make changes to this bug.