Bug 1267931 - [RGW]: Ubuntu rgw documentation doesn't talk about stopping apache after moving rgw to port 80 civetweb
[RGW]: Ubuntu rgw documentation doesn't talk about stopping apache after movi...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: Documentation (Show other bugs)
1.3.0
x86_64 Linux
unspecified Severity low
: rc
: 1.3.0
Assigned To: Nilamdyuti
ceph-qe-bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-01 08:14 EDT by shylesh
Modified: 2015-10-07 12:13 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-07 12:13:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description shylesh 2015-10-01 08:14:42 EDT
Description of problem:

https://gitlab.cee.redhat.com/ngoswami/red-hat-ceph-storage-object-gateway-ubuntu/blob/v1.3/installation.adoc doesn't talk about  stopping apache which will be running at port 80. Due to this when rgw which will be running on 7480 moved to civetweb on port 80 will fail to aquire the port.

@yehuda,

Is stopping apache daemon required or rgw should take over the port without restarting the apache?
 

Purpose of this bug is to get clarity on whether we need doc for this issue.
Comment 2 Yehuda Sadeh 2015-10-05 12:20:10 EDT
apache needs to be stopped so that rgw can take over that port.
Comment 3 Harish NV Rao 2015-10-05 12:54:02 EDT
Thanks Yehuda!

Changing component to Documentation to add the required information into the doc.
Comment 4 John Wilkins 2015-10-05 14:15:37 EDT
This is covered under the Migrating section. In fact, it explicitly says, "Migrating to use Civetweb basically involves removing your Apache installation. Then, you must remove Apache and FastCGI settings from your Ceph configuration file and reset `rgw_frontends` to Civetweb."

Are you asking for stepwise instructions? Removing the Apache installation implies stopping it, but we can detail it out for you.
Comment 5 shylesh 2015-10-06 02:53:28 EDT
Hi John,

What I followed is 1.3.0 install doc where in we will be directly on civetweb. When we start the gateway civetweb will be listening on 7480, then only port configuration will be changed in ceph.conf and nothing else related to apache.

So I followed https://gitlab.cee.redhat.com/ngoswami/red-hat-ceph-storage-object-gateway-ubuntu/blob/v1.3/installation.adoc , after making the port change if user restarts the civetweb It will fail since apache is running and we haven't touched any of the apache configs because we were directly on civetweb.

Correct me If I am missing something.

if user follows above document, silently radosgw restart will not work because of port issues hence I requested for one step in the doc which says "apache needs to be stopped before restarting the radosgw after a port change in the conf file".

Your thoughts are welcome..
Comment 6 shylesh 2015-10-06 02:56:26 EDT
(In reply to shylesh from comment #5)
> Hi John,
> 
> What I followed is 1.3.0 install doc where in we will be directly on
> civetweb. When we start the gateway civetweb will be listening on 7480, then
> only port configuration will be changed in ceph.conf and nothing else
> related to apache.
> 
> So I followed
> https://gitlab.cee.redhat.com/ngoswami/red-hat-ceph-storage-object-gateway-
> ubuntu/blob/v1.3/installation.adoc , after making the port change if user
> restarts the civetweb It will fail since apache is running and we haven't
> touched any of the apache configs because we were directly on civetweb.
> 
> Correct me If I am missing something.
> 
> if user follows above document, silently radosgw restart will not work
> because of port issues hence I requested for one step in the doc which says
> "apache needs to be stopped before restarting the radosgw after a port
> change in the conf file".
> 
> Your thoughts are welcome..

@John,

Please note that I am talking about fresh installation, hence user might not even look into "Migrating from Apache to Civetweb" part.
Comment 8 shylesh 2015-10-07 05:13:38 EDT
Doc added to stop apache before restarting the radosgw.


"Stop Apache so that Ceph Object Gateway can run on port 80.

sudo service apache2 stop "
hence marking this as verified.

Note You need to log in before you can comment on or make changes to this bug.