Bug 1268035 - Show how to edit or modify the scheduler configuration.
Show how to edit or modify the scheduler configuration.
Status: CLOSED DUPLICATE of bug 1337217
Product: OpenShift Container Platform
Classification: Red Hat
Component: Documentation (Show other bugs)
3.0.0
Unspecified Unspecified
high Severity medium
: ---
: ---
Assigned To: Thien-Thi Nguyen
Vikram Goyal
Vikram Goyal
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-01 11:55 EDT by Eric Rich
Modified: 2016-08-04 21:27 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-27 08:33:56 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eric Rich 2015-10-01 11:55:19 EDT
Document URL: https://docs.openshift.com/enterprise/3.0/admin_guide/scheduler.html

Describe the issue: 

Its not clear where or how, to modify the scheduling behavior of openshift. 

    /etc/openshift/master/scheduler.json

And the file can be configured in the master configuration:

    # grep schedulerConfigFile /etc/openshift/master/master-config.yaml
    schedulerConfigFile: /etc/openshift/master/scheduler.json

Suggestions for improvement: 

Show where / how to modify the scheduler configuration and reload it. 

Additional information:
Comment 3 Thien-Thi Nguyen 2016-04-01 13:16:01 EDT
The plan is to add two initial sections to the Scheduler chapter:
- Getting Status
- Changing Configuration
and mention them explicitly in the Overview.  The current chapter contents are to be called "reference material" in the Overview, but otherwise to remain unchanged.

WIP (on fork):
https://github.com/tnguyen-rh/openshift-docs/tree/bz1268035
Comment 4 Thien-Thi Nguyen 2016-05-27 08:33:56 EDT
I've deleted the WIP.  Marking as duplicate of 1337217.

*** This bug has been marked as a duplicate of bug 1337217 ***

Note You need to log in before you can comment on or make changes to this bug.