Bug 126806 - latex2html fails because of unknown image format
latex2html fails because of unknown image format
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: tetex (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-27 09:25 EDT by Patrice Dumas
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version: 2.0.2-15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-28 05:23:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Patrice Dumas 2004-06-27 09:25:33 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040510

Description of problem:
Here is what happens when I run latex2html -h:

[pat@localhost pat]$ latex2html -h
 [japanese]Error: No such image type ''.
       This installation supports (first is default):

And the program exits. 

If I call it with a filename it exits with the same error message:

[pat@localhost pat]$ latex2html truc.tex
 [japanese]Error: No such image type ''.
       This installation supports (first is default):

I had a quick look at the code and there are those lines:

unless(grep(/^\Q$IMAGE_TYPE\E$/o, @IMAGE_TYPES)) {
    die <<"EOF";
Error: No such image type '$IMAGE_TYPE'.
       This installation supports (first is default): @IMAGE_TYPES
EOF
}

I didn't found any other occurence of @IMAGE_TYPES. And from the 
error message it seems that $IMAGE_TYPE should have been initialized
with $IMAGE_TYPES[0]. 

I tried to look at the use and require I found that 
/usr/share/latex2html/l2hconf.pm
is used but @IMAGE_TYPES = ()
L2hos/Unix.pm also seems to be used but there is nothing relevant in
that file.

There might be something wrong in my setup, but I doubt it as from 
the code it seems that files required are printed on the screen. 

Version-Release number of selected component (if applicable):
tetex-latex-2.0.2-14

How reproducible:
Always

Steps to Reproduce:
1. latex2html -h 
2. latex2html file.tex
3. See error message
    

Actual Results:  An error message

[japanese]Error: No such image type ''.
       This installation supports (first is default):

Expected Results:  An help message/processinfg of the file

Additional info:
Comment 1 Tim Waugh 2004-06-28 05:23:59 EDT
Fixed in tetex-2.0.2-15.
Comment 2 Patrice Dumas 2004-07-13 17:17:55 EDT
Agreed. The rawhide version works for me.

Note You need to log in before you can comment on or make changes to this bug.