Bug 1268180 - [DOCS] [3.1] [Feature] Document Jobs Controller
[DOCS] [3.1] [Feature] Document Jobs Controller
Status: CLOSED CURRENTRELEASE
Product: OpenShift Container Platform
Classification: Red Hat
Component: Documentation (Show other bugs)
3.0.0
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: brice
zhou ying
Vikram Goyal
:
: 1255706 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-01 22:51 EDT by Vikram Goyal
Modified: 2017-03-08 13 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-19 19:47:40 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vikram Goyal 2015-10-01 22:51:45 EDT
Document this new feature to enable the execution of finite duration jobs on the cluster

Developer Trello Card:
https://trello.com/c/HAsDbe3H/460-13-implement-jobs-controller

Possible Guide:

* Developer Guide
Comment 2 brice 2015-11-04 23:13:33 EST
Here's a PR from the dev:

https://github.com/openshift/openshift-docs/pull/1130

This'll need a follow-up with the answers to the questions addressed on the PR.
Comment 3 brice 2015-11-08 20:27:59 EST
Follow up edits PR submitted:

https://github.com/openshift/openshift-docs/pull/1165
Comment 4 brice 2015-11-12 01:23:07 EST
Peer reviewed. Putting this onto QA.

This above link outlines the changes.
Comment 5 zhou ying 2015-11-12 04:43:52 EST
Checked , and found:

1)The title should not be:Builds.

2)It's better to illustrat the option of  .spec.template.spec.restartPolicy
Comment 6 brice 2015-11-12 20:56:17 EST
Zhou,

1. This is fixed. Link in the PR in comment 3.

2. This might be out of scope for this BZ. This parameter is featured in a number of templates in the Enterprise docs. I have created this BZ for this, and this will be worked on post 3.1:

https://bugzilla.redhat.com/show_bug.cgi?id=1281654

I'll put this back onto QA. Please let me know if there's is anything else for this BZ.

Thank you very much for the QA!
Comment 7 openshift-github-bot 2015-11-14 11:42:05 EST
Commit pushed to master at https://github.com/openshift/openshift-docs

https://github.com/openshift/openshift-docs/commit/9a000e01b360896e4e734e03668e07716a2641de
Bug 1268180 : added to architecture section and edits to job info then edits after tech review
Comment 8 Thien-Thi Nguyen 2015-11-14 11:49:31 EST
*** Bug 1255706 has been marked as a duplicate of this bug. ***
Comment 9 zhou ying 2016-07-25 21:43:39 EDT
please refer to comment 7

Note You need to log in before you can comment on or make changes to this bug.