Bug 126823 - iiimf causing kernel segfault.
Summary: iiimf causing kernel segfault.
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel   
(Show other bugs)
Version: 2
Hardware: x86_64 Linux
medium
medium
Target Milestone: ---
Assignee: Dave Jones
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-06-28 01:28 UTC by Sam Varshavchik
Modified: 2015-01-04 22:07 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-15 04:06:09 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Sam Varshavchik 2004-06-28 01:28:41 UTC
Description of problem:

Trying to test IIimf (http://apac.redhat.com/iiimftest/) results in a
kernel segfault.

Version-Release number of selected component (if applicable):

kernel-smp-2.6.6-1.435.x86_64.rpm

How reproducible:

Always.

Steps to Reproduce:
1. Update FC2 to kernel build 435
2. Install IIImf as per http://apac.redhat.com/iiimftest/

Installed RPMs:

iiimf-client-lib-11.4-43
iiimf-client-lib-devel-11.4-43
iiimf-csconv-11.4-43
iiimf-docs-11.4-43
iiimf-gtk-11.4-43
iiimf-le-canna-11.4-43
iiimf-le-hangul-11.4-43
iiimf-le-inpinyin-0.3-2
iiimf-le-unit-11.4-43
iiimf-le-xcin-0.1.5-1
iiimf-protocol-lib-11.4-43
iiimf-protocol-lib-devel-11.4-43
iiimf-server-11.4-43
iiimf-x-11.4-43

3. Run the following command from a gnome-terminal window:

LANG=ja_JP.UTF-8 GTK_IM_MODULE=iiim gedit

  
Actual results:

Some error dialogs pop up, and the following gets dumped into syslog:

Jun 27 21:24:20 commodore htt_server[14726]: Client shut down the
connection owned by im_id(1).
Jun 27 21:24:28 commodore kernel: htt_server[14738] general protection
rip:2a957bb5e4 rsp:409ff420 error:0
Jun 27 21:24:28 commodore cannaserver[2425]: [htt] Receive request failed
Jun 27 21:24:28 commodore kernel: gedit[14737]: segfault at
00000000000000f8 rip 00000000000000f8 rsp 0000007fbfffefb8 error 14
Jun 27 21:24:28 commodore htt_server[14739]: started.
Jun 27 21:24:31 commodore kernel: htt_server[14743] general protection
rip:2a957bb5e4 rsp:409ff420 error:0
Jun 27 21:24:31 commodore cannaserver[2425]: [htt] Receive request failed
Jun 27 21:24:31 commodore htt_server[14744]: started.
Jun 27 21:24:31 commodore kernel: gedit[14742]: segfault at
00000000000000f8 rip 00000000000000f8 rsp 0000007fbfffefb8 error 14


Expected results:


Additional info:

Comment 1 Dave Jones 2005-01-14 05:22:55 UTC
is this fixed in the latest updates ?


Comment 2 Sam Varshavchik 2005-01-15 01:23:10 UTC
I cannot reproduce this error in the current kernel.



Note You need to log in before you can comment on or make changes to this bug.