Bug 1268284 - autopoint 0.19.4 thinks to be older than 0.18.0
autopoint 0.19.4 thinks to be older than 0.18.0
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: gettext (Show other bugs)
22
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Daiki Ueno
Fedora Extras Quality Assurance
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-02 08:25 EDT by Sandro Bonazzola
Modified: 2015-10-04 20:59 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-04 20:59:55 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sandro Bonazzola 2015-10-02 08:25:01 EDT
Description of problem:

Using gettext-0.19.4-4.fc22.x86_64 autopoint fails if an older gettext version is specified in congure.ac

Version-Release number of selected component (if applicable):
gettext-0.19.4-4.fc22.x86_64

How reproducible: 100%


Steps to Reproduce:
1. create a configure.ac like:

AC_PREREQ([2.69])
AC_INIT([test], [1], [sbonazzo@redhat.com])
AM_GNU_GETTEXT_VERSION([0.18.0])
AC_OUTPUT

2. run autopoint

Actual results:
$ autopoint 
autopoint: *** The AM_GNU_GETTEXT_VERSION declaration in your configure.ac
               file requires the infrastructure from gettext-0.18.0 but this version
               is older. Please upgrade to gettext-0.18.0 or newer.
autopoint: *** Stop.

$ autopoint --version
/usr/bin/autopoint (GNU gettext-tools) 0.19.4
Uses a versions archive in dirxz format.
Copyright (C) 2002-2013 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.
Written by Bruno Haible


Expected results:
0.19.4 must be detected as newer than 0.18.0

Additional info:
Comment 1 Sandro Bonazzola 2015-10-02 08:26:16 EDT
Additional info:

AC_PREREQ([2.69])
AC_INIT([test], [1], [sbonazzo@redhat.com])
AM_GNU_GETTEXT_VERSION([0.18.2])
AC_OUTPUT

works fine.
Comment 2 Daiki Ueno 2015-10-04 20:59:55 EDT
AM_GNU_GETTEXT_VERSION instructs autopoint to copy the gettext infrastructure files of given version, not the best possible version.  In this case, since there has never been a 0.18.0 release, autopoint cannot copy the files from archive:

  $ tar tf /usr/share/gettext/archive.dir.tar.xz | grep 0.18.0

For your purpose, we added AM_GNU_GETTEXT_REQUIRE_VERSION in 0.19.6:

https://lists.gnu.org/archive/html/bug-gettext/2015-08/msg00026.html

Note You need to log in before you can comment on or make changes to this bug.