Bug 1268446 - zbarcam shows no image / does not recognize codes
zbarcam shows no image / does not recognize codes
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: zbar (Show other bugs)
22
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Douglas Schilling Landgraf
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-02 16:15 EDT by Stefan Neufeind
Modified: 2016-04-27 10:04 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-04 14:43:05 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stefan Neufeind 2015-10-02 16:15:04 EDT
Description of problem:
I can start zbarcam just fine and get no errors, not even when I enable verbose-output. But it doesn't show the webcam-image or recognize codes.

The light of my webcam goes on, so the device can be opened fine. And if I enlarge the zbarcam-window I get to see a (corretly showing) live-video part from the webcam. So it seems to fetch video somehow - but can't preview or process it?
Comment 1 Douglas Schilling Landgraf 2015-10-10 19:46:37 EDT
Hi Mauro, 

Have you seen this before? 

Thanks!
Comment 2 Douglas Schilling Landgraf 2015-11-02 08:39:59 EST
(In reply to Stefan Neufeind from comment #0)
> Description of problem:
> I can start zbarcam just fine and get no errors, not even when I enable
> verbose-output. But it doesn't show the webcam-image or recognize codes.
> 
> The light of my webcam goes on, so the device can be opened fine. And if I
> enlarge the zbarcam-window I get to see a (corretly showing) live-video part
> from the webcam. So it seems to fetch video somehow - but can't preview or
> process it?

What's the zbar/kernel version? 

Thanks
Comment 3 Stefan Neufeind 2015-11-02 09:03:44 EST
kernel-4.2.3-200.fc22.x86_64
zbar-0.10-22.fc22.x86_64

verbose says:

_zbar_video_open: opened camera device /dev/video0 (fd=5)
_zbar_v4l2_probe: Integrated Camera on usb-0000:00:14.0-8 driver uvcvideo (version 4.2.3)
_zbar_v4l2_probe:     capabilities: CAPTURE READWRITE STREAMING
v4l2_reset_crop: crop bounds: 640 x 480 @ (0, 0)
v4l2_reset_crop: current crop win: 640 x 480 @ (0, 0) aspect 1 / 1
ERROR: zbar video in v4l2_reset_crop():
    system error: setting default crop window (VIDIOC_S_CROP): Inappropriate ioctl for device (25)
v4l2_probe_formats: current format: YUYV(56595559) 640 x 480 (line=0x500 size=0x96000)
WARNING: zbar video in v4l2_probe_iomode():                                                                                                                                                                    
    system error: USERPTR failed. Falling back to mmap: Invalid argument (22)                                                                                                                                  
_zbar_v4l2_probe: using I/O mode: MMAP                                                                                                                                                                         
_zbar_window_probe_xv: XVideo extension version 2.2                                                                                                                                                            
xv_probe_port: probing port 79 with 1 encodings:                                                                                                                                                               
xv_probe_port: max XV_IMAGE size 16384x16384                                                                                                                                                                   
xv_probe_port: 5 image formats                                                                                                                                                                                 
xv_probe_port: probing port 143 with 1 encodings:                                                                                                                                                              
xv_probe_port: max XV_IMAGE size 8192x8192                                                                                                                                                                     
xv_probe_port: 3 image formats                                                                                                                                                                                 
v4l2_set_format: set new format: YUYV(56595559) 640 x 480 (0x96000)                                                                                                                                            
v4l2_init: using 4 buffers (of 4 requested)
Comment 4 Stefan Neufeind 2015-11-03 14:56:17 EST
same for:
kernel-4.2.5-300.fc23.x86_64
zbar-0.10-24.fc23.x86_64
Comment 5 Douglas Schilling Landgraf 2015-11-04 12:19:48 EST
Hi Stefan,

Looks like it's the XV driver. Unfortunately, I cannot help with that
at this moment. You might want to contact zbar developers at
http://sourceforge.net/p/zbar/discussion/?source=navbar

Note You need to log in before you can comment on or make changes to this bug.