This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 126852 - redhat-config-users hangs with no input
redhat-config-users hangs with no input
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: redhat-config-users (Show other bugs)
2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-28 09:42 EDT by Suresh Jayaram
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-30 14:04:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Suresh Jayaram 2004-06-28 09:42:18 EDT
Description of problem:

When using redhat-config-users, the application hangs while clicking 
Ok button without any input.

Version-Release number of selected component (if applicable):


How reproducible:

Often

Steps to Reproduce:
1. Select redhat-config-users
2. Click Ok without entering any input
3. The application hangs with following error message 

Traceback (most recent call last):
  File "/usr/share/redhat-config-users/userWindow.py", line 146, in 
on_userWin_ok_button_clicked
    if not asciiCheck.isUsernameOk(userName, self.userWinUserName):
  File "/usr/share/redhat-config-users/asciiCheck.py", line 39, in 
isUsernameOk
    if str[0] in string.digits:
IndexError: string index out of range


  
Actual results:
The application hangs

Expected results:
Error message

Additional info:
Comment 1 Brent Fox 2004-06-28 11:21:21 EDT
What version of redhat-config-users are you running?  I'm pretty sure
you're not using Fedora Core 2 since the name of redhat-config-users
was changed to system-config-users between FC1 and FC2.
Comment 2 Suresh Jayaram 2004-06-29 00:45:40 EDT
I don't know the the version of redhat-config-users, but I checked 
again, it is not in FC2, but in Redhat 9.0. I have both. The problem 
is not with FC2.
Comment 3 Brent Fox 2004-06-30 14:04:56 EDT
Argh, Bugzilla won't let me choose "Red Hat Linux" in the Product
field anymore.  Since you say that the problem no longer appears in
FC2, I'm going to close this report as "currentrelease".  I don't have
time to do an updated version for RHL 9.0.  Thanks for your report.

Note You need to log in before you can comment on or make changes to this bug.