Bug 1268553 - aqemu uses out-of-date -spice arguments
aqemu uses out-of-date -spice arguments
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: aqemu (Show other bugs)
22
x86_64 Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Stephen Gordon
Fedora Extras Quality Assurance
:
: 1093967 1244055 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-03 00:31 EDT by Richard Jasmin
Modified: 2016-03-26 13:57 EDT (History)
3 users (show)

See Also:
Fixed In Version: aqemu-0.8.2-18.fc24
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-26 13:57:21 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Richard Jasmin 2015-10-03 00:31:32 EDT
Description of problem:
aqemu as updated recently is no longer useable. It boils down to requiring options that are not available to set that darn spice port.Most people using this app havent even heard of what spice is, let alone what to put there.

But with the latest version, you cant change the options.Everything is greyed out.

Thereby the app is unusable.Either default port needs to be specified during install or we need to do away with the application until this is fixed.

Version-Release number of selected component (if applicable):
22

How reproducible:
post install

Steps to Reproduce:
1.install aqemu
2.launch it
Comment 1 Richard Jasmin 2015-10-03 00:31:58 EDT
this is version .8.2-13 for reference.
Comment 2 Stephen Gordon 2015-10-14 15:01:23 EDT
(In reply to Richard Jasmin from comment #0)
> Description of problem:
> aqemu as updated recently is no longer useable. It boils down to requiring
> options that are not available to set that darn spice port.Most people using
> this app havent even heard of what spice is, let alone what to put there.
> 
> But with the latest version, you cant change the options.Everything is
> greyed out.
> 
> Thereby the app is unusable.Either default port needs to be specified during
> install or we need to do away with the application until this is fixed.
> 
> Version-Release number of selected component (if applicable):
> 22
> 
> How reproducible:
> post install
> 
> Steps to Reproduce:
> 1.install aqemu
> 2.launch it

Can you clarify what you mean by as recently updated? The only changes to the package between 0.8.2-6 (Mon Feb 27 2012) and 0.8.2-15 (Wed Jun 17 2015) other than the mass rebuilds were for:

* Fri Jul 04 2014 Stephen Gordon <sgordon@redhat.com> - 0.8.2-12 - Apply changes for "-Werror=format-security" (bz#1036992) 

* Mon Mar 05 2012 Stephen Gordon <sgordon@redhat.com> - 0.8.2-7 - Added BuildRequires on hicolor-icon-theme (bz#734275).

The aqemu project is pretty much dead upstream so not a lot changes though it's possible a dependency did, there is an upstream issue with a workaround here:

    http://sourceforge.net/p/aqemu/support-requests/1/
Comment 3 Stephen Gordon 2015-10-14 15:03:37 EDT
*** Bug 1244055 has been marked as a duplicate of this bug. ***
Comment 4 Richard Jasmin 2015-10-16 12:26:31 EDT
dropped a similar bug myself in fedora.

I dont know. somewhere between 21 and 22 the app changed and then the area is greyed out.

You cant invoke qemu/kvm directly(well I had a repo issue that not going away) until libusb conflict is fixed and gnome-boxes is tricky to get working, which is why I was using aqemu.

I would fix the repo and libusb issue if I could spin.I cant seem to do that either.Since you cant en mass add packages with DNF, reinstalling is out until I can spin.
Comment 5 Stephen Gordon 2016-03-19 23:53:33 EDT
(In reply to Richard Jasmin from comment #4)

This didn't really help. After fixing the F24 FTBFS error the actual error text appears to be:

Error #1
qemu-system-x86_64:

Error #2
-spice port=6000,sport=1,hostname=localhost,sv=off,playback-compression=off,disable-ticketing: Invalid parameter 'sport' 

Investigation of the qemu man page indicates that the supported -spice arguments changed at some point, though it is not immediately obvious what new parameter replaces sport (or hostname for that matter). The related upstream bug is https://sourceforge.net/p/aqemu/support-requests/2/ but there is no fix posted at this time.
Comment 6 Stephen Gordon 2016-03-20 00:00:04 EDT
sv maps to streaming-video
hostname maps to addr
sport is still unclear
Comment 7 Stephen Gordon 2016-03-20 00:06:12 EDT
(In reply to Stephen Gordon from comment #6)

> sport is still unclear

As a stab in the dark I suspect it is tls-port. Additonally ic needs to be mapped to image-compression.
Comment 8 Stephen Gordon 2016-03-20 00:34:10 EDT
Initial testing of a scratch build with these changes http://koji.fedoraproject.org/koji/taskinfo?taskID=13394924 seems promising but need further confirmation.
Comment 9 Stephen Gordon 2016-03-20 11:26:31 EDT
(In reply to Stephen Gordon from comment #8)
> Initial testing of a scratch build with these changes
> http://koji.fedoraproject.org/koji/taskinfo?taskID=13394924 seems promising
> but need further confirmation.

This is a little further along:

http://koji.fedoraproject.org/koji/taskinfo?taskID=13398831
Comment 10 Stephen Gordon 2016-03-20 11:33:01 EDT
Alright, confirmed with that latest scratch build I can start a VM and attach to the SPICE console. Will push the fixes into git shortly.
Comment 11 Fedora Update System 2016-03-20 12:54:57 EDT
aqemu-0.8.2-18.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-1a2a5a72f7
Comment 12 Stephen Gordon 2016-03-20 13:41:29 EDT
*** Bug 1093967 has been marked as a duplicate of this bug. ***
Comment 13 Fedora Update System 2016-03-21 18:32:14 EDT
aqemu-0.8.2-18.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-1a2a5a72f7
Comment 14 Fedora Update System 2016-03-26 13:57:16 EDT
aqemu-0.8.2-18.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.