Bug 1268595 - on filesystems with numerous files, tracker can fill up the space assigned to ~/
on filesystems with numerous files, tracker can fill up the space assigned to ~/
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: tracker (Show other bugs)
7.3
Unspecified Unspecified
unspecified Severity medium
: rc
: ---
Assigned To: Debarshi Ray
Desktop QE
:
Depends On:
Blocks: 1298243 1420851
  Show dependency treegraph
 
Reported: 2015-10-03 06:32 EDT by Felix Dewaleyne
Modified: 2017-06-30 09:08 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-06-30 09:08:19 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 660137 None None None Never

  None (edit)
Description Felix Dewaleyne 2015-10-03 06:32:52 EDT
Description of problem:
on filesystems with numerous files, tracker can fill up the space assigned to ~/

Version-Release number of selected component (if applicable):
tracker-0.16.2-8.el7.x86_64

How reproducible:
hard - very specific to filesystem usage

Steps to Reproduce:
1.install tracker
2.run a graphical session as root user
3.

Actual results:
[root@localhost ~]# du -sh ./.cache/tracker/meta.db-wal
89G     ./.cache/tracker/meta.db-wal
[root@localhost ~]# cd ./.cache/tracker/
[root@localhost tracker]# ls -ltr
total 93317156
-rw-r--r--. 1 root root           2 Mar 14  2015 db-version.txt
-rw-r--r--. 1 root root          11 Mar 14  2015 db-locale.txt
-rw-r--r--. 1 root root      352020 Mar 14  2015 ontologies.gvdb
-rw-r--r--. 1 root root          11 Mar 14  2015 miner-applications-locale.txt
-rw-r--r--. 1 root root          10 Mar 14  2015 last-crawl.txt
-rw-r--r--. 1 root root           6 Mar 14  2015 first-index.txt
-rw-r--r--. 1 root root     4365312 Jun 22 11:12 meta.db
-rw-r--r--. 1 root root 94828065192 Oct  3 12:58 meta.db-wal
-rw-r--r--. 1 root root   723910656 Oct  3 12:58 meta.db-shm

Expected results:
indexes reaching a large size should no longer continue to be used

Additional info:
- past a certain size, it is highly likely that using the index will become slower than looking at the filesystem directly, negating any benefit
- upstream seems already looking into changes around tracker that would put the index's size under control : https://bugzilla.gnome.org/show_bug.cgi?id=660137
- previously reportd against fedora but closed ( bz#741007 )
Comment 5 Matěj Cepl 2017-04-12 12:38:23 EDT
(In reply to Felix Dewaleyne from comment #0)
> on filesystems with numerous files, tracker can fill up the space assigned
> to ~/

Could you elaborate on that word “numerous” here, please? On my system (with 1,620,716 files on /home partition) I have only 2.9G meta.db file (and other meta* files are under 10M)
Comment 6 Felix Dewaleyne 2017-06-29 10:37:50 EDT
(In reply to Matěj Cepl from comment #5)
> (In reply to Felix Dewaleyne from comment #0)
> > on filesystems with numerous files, tracker can fill up the space assigned
> > to ~/
> 
> Could you elaborate on that word “numerous” here, please? On my system (with
> 1,620,716 files on /home partition) I have only 2.9G meta.db file (and other
> meta* files are under 10M)

this is a case from 2 years ago. I since moved to a different area and the customer never provided any numbers. The space allocated in his partitions was pretty tightly managed however. the home space affected at the time was the /root - I can't say that I'd encourage users to ever graphically log in as root but that's what they did...
Comment 8 Red Hat Bugzilla Rules Engine 2017-06-30 09:08:19 EDT
Development Management has reviewed and declined this request. You may appeal this decision by reopening this request.

Note You need to log in before you can comment on or make changes to this bug.