Bug 1268602 - http error when ssharing needs password
http error when ssharing needs password
Status: CLOSED DUPLICATE of bug 1274924
Product: Fedora
Classification: Fedora
Component: gvfs (Show other bugs)
22
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ondrej Holy
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-03 08:48 EDT by antonio montagnani
Modified: 2015-11-04 12:21 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-04 12:21:40 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
info request reply (47.71 KB, image/png)
2015-10-05 18:40 EDT, antonio montagnani
no flags Details
as per needinfo (26.26 KB, text/plain)
2015-10-07 14:33 EDT, antonio montagnani
no flags Details
another log per needinfo (8.36 KB, text/plain)
2015-10-07 14:56 EDT, antonio montagnani
no flags Details

  None (edit)
Description antonio montagnani 2015-10-03 08:48:24 EDT
Description of problem:
when personal file sharing is enabled, I get an hhtp error when sharing has password enabled

Version-Release number of selected component (if applicable):
3.14.2-1

How reproducible:
always

Steps to Reproduce:
1.enable Personal  file sharing
2.sharing password on
3.

Actual results:
hhtp server error

Expected results:
it should connect fine

Additional info:
pretty standard F22 installation, with Selinux and Firewall working
Comment 1 Bastien Nocera 2015-10-05 07:11:03 EDT
(In reply to antonio montagnani from comment #0)
> Description of problem:
> when personal file sharing is enabled, I get an hhtp error when sharing has
> password enabled

What error?
Comment 2 antonio montagnani 2015-10-05 18:40 EDT
Created attachment 1080085 [details]
info  request reply

this is what I see when password is enabled in files sharing
Comment 3 Ondrej Holy 2015-10-07 05:39:13 EDT
It works correctly for me. Could you provide log using following steps please?

1/ Run following command:
pkill gvfs -u $(id -u); GVFS_DEBUG=1 GVFS_HTTP_DEBUG=all /usr/libexec/gvfsd &> ~/gvfsd.log 
2/ Then reproduce the bug.
3/ Finally attach gvfsd.log from your home folder to this bug report.
Comment 4 antonio montagnani 2015-10-07 14:33 EDT
Created attachment 1080772 [details]
as per needinfo

please note that behavoiur is quite erratic, at the end I could reproduce bug, therefore I suppose that final lines of log file are connected to this bug.

please note that same bug can be reproduced also by user lellamura@tiscali.it
Comment 5 antonio montagnani 2015-10-07 14:56 EDT
Created attachment 1080773 [details]
another log per needinfo

this time I restarted the machine and I could reproduce the bug immediately
Comment 6 Ondrej Holy 2015-10-12 04:20:29 EDT
Thanks for the logs. Just a quick update. Both logs show that there were spawned two dav backends at the same time from some reason and then both mount operations were cancelled (might be caused by multiple click). I have to investigate this further to find what's wrong there...

In the meantime you might want to check, whether your mouse generates press and release events only once per one click. You can use following utility (click in a window and check what is printed on commandline):
xev -event button
Comment 7 antonio montagnani 2015-10-12 06:19:29 EDT
(In reply to Ondrej Holy from comment #6)
> Thanks for the logs. Just a quick update. Both logs show that there were
> spawned two dav backends at the same time from some reason and then both
> mount operations were cancelled (might be caused by multiple click). I have
> to investigate this further to find what's wrong there...
> 
> In the meantime you might want to check, whether your mouse generates press
> and release events only once per one click. You can use following utility
> (click in a window and check what is printed on commandline):
> xev -event button

xev -event button
Outer window is 0x2800001, inner window is 0x2800002

ButtonPress event, serial 25, synthetic NO, window 0x2800001,
    root 0xd5, subw 0x2800002, time 18578182, (53,40), root:(180,231),
    state 0x0, button 1, same_screen YES

ButtonRelease event, serial 25, synthetic NO, window 0x2800001,
    root 0xd5, subw 0x2800002, time 18578294, (53,40), root:(180,231),
    state 0x100, button 1, same_screen YES

tnx for help
Comment 8 Ondrej Holy 2015-10-21 03:59:09 EDT
Could you provide more detailed steps to reproduce the bug (there is multiple ways how to mount the share)? Do you mount the share doubleclicking on the share icon in "Browse Network" panel? Did you see password prompt? You can also provide screencast easily using the screencast recording tool integrated in gnome shell:
https://wiki.gnome.org/Projects/GnomeShell/CheatSheet#Screencast_recording

I can reproduce "Cancelled" error only when I cancel the password prompt somehow, e.g. by cancel button on dialog, by Esc button on keyboard, or by multiple clicks on the share in "Browse Networks" panel... 

The gvfsd.log you attached here suggests that there were multiple clicks, or something similar.

The output from "xev -event button" looks correct (one press and one release event for one click), I hope you tried this multiple times, not only once as per Comment 7...

Isn't possible that you doubleclicked on the icon and have single click enabled for opening (Files -> Preferences -> Behavioral -> Single click to open items)?
Comment 9 antonio montagnani 2015-10-21 10:53:26 EDT
I am lost, for a while (a week or so) everything seemd to work, but today I have no network printer, no screen share, no file shares and I guess that everything is connected.

File shares: on PC1 I can see only PC1 public shares, on PC2 only PC2 public shares.

Screen share: when I try to connect in some case I don't see shared amchine, sometimes I get the warning that Avahi resolved reached timeout.

I lost my shared printer: trying to reinstall I should see the printer automatically discovered!!! but I have to input the ip number of PC,,,
Comment 10 antonio montagnani 2015-10-21 12:46:13 EDT
an update:

on PC1 I cannot see shared files on PC2 and I cannot see PC2 on VNC available computers' list.

on PC2 I see shared files on PC1 and I can see PC1 on VNC available computers' list

PC1 is wired while PC2 is wireless

Printer seems to be working again
Comment 11 antonio montagnani 2015-10-21 12:50:23 EDT
if I connect by issuing a dav//PC2.local I get 

Messaggio d'errore non gestito: Errore HTTP: Errore nel risolvere "Fujiantonio.local": Nessun indirizzo associato al nome host

that means 
unmanaged error message: HHTP error: error in resolve "Fujiantonio.local" : mo address associated to host name
Comment 12 Ondrej Holy 2015-10-23 06:09:22 EDT
I need answers for questions in Comment 8 to fix the original issue.

You provided lot of info, but it sounds like problems with your network and it is not related to this bug report. You should ask on such problems on some forum, or mailing list...

It isn't possible to connect directly using dav://PC2.local, because there is missing port in the uri. However this is another bug, because there isn't "Cancelled", but usually "Connection refused" error, see upstream bug report:
https://bugzilla.gnome.org/show_bug.cgi?id=730444

In your case there is "No address associated with hostname" actually, but this again indicates some problems with your network....
Comment 13 antonio montagnani 2015-10-23 07:42:11 EDT
tnx : some improvements were done last night.

I solved the problem with my network and now I can ping by name.
Now the situation is this:

from pcdesktop1 if I go to Nautilus/Network I see only shared folder on itself (doubleclicking).
From Fujiantonio I can see shared folders on each computer and I can mount them.

for more information:

[antonio@pcdesktop1 ~]$ dig pcdesktop1

; <<>> DiG 9.10.2-P4-RedHat-9.10.2-5.P4.fc22 <<>> pcdesktop1
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NXDOMAIN, id: 5517
;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 1

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 4096
;; QUESTION SECTION:
;pcdesktop1.            IN    A

;; AUTHORITY SECTION:
.            10800    IN    SOA    a.root-servers.net. nstld.verisign-grs.com. 2015102201 1800 900 604800 86400

;; Query time: 30 msec
;; SERVER: 192.168.1.1#53(192.168.1.1)
;; WHEN: ven ott 23 13:14:37 CEST 2015
;; MSG SIZE  rcvd: 114
---------------------------------------------------------------------------------------------------------------------------------------------------------
[antonio@pcdesktop1 ~]$ dig Fujiantonio

; <<>> DiG 9.10.2-P4-RedHat-9.10.2-5.P4.fc22 <<>> Fujiantonio
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NXDOMAIN, id: 48690
;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 1

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 4096
;; QUESTION SECTION:
;Fujiantonio.            IN    A

;; AUTHORITY SECTION:
.            10800    IN    SOA    a.root-servers.net. nstld.verisign-grs.com. 2015102201 1800 900 604800 86400

;; Query time: 29 msec
;; SERVER: 192.168.1.1#53(192.168.1.1)
;; WHEN: ven ott 23 13:14:51 CEST 2015
;; MSG SIZE  rcvd: 115
----------------------------------------------------------------------------------------------------------------------------------------------------------------------------

and from pcdesktop1:

[antonio@pcdesktop1 ~]$ avahi-browse -a
+ virbr0 IPv4 antonio's public files on pcdesktop1          WebDAV Condivisione File local
+  p19p1 IPv4 antonio's public files on pcdesktop1          WebDAV Condivisione File local
+ virbr0 IPv4 pcdesktop1                                    Sito Web             local
+  p19p1 IPv4 pcdesktop1                                    Sito Web             local
+ virbr0 IPv4 antonio's remote desktop on pcdesktop1        Controllo remoto VNC local
+  p19p1 IPv4 antonio's remote desktop on pcdesktop1        Controllo remoto VNC local
+ virbr0 IPv4 Samsung ML-1610 @ pcdesktop1                  Internet Printer     local
+  p19p1 IPv4 Samsung ML-1610 @ pcdesktop1                  Internet Printer     local
+ virbr0 IPv4 Samsung ML-1610 @ pcdesktop1                  _ipps._tcp           local
+  p19p1 IPv4 Samsung ML-1610 @ pcdesktop1                  _ipps._tcp           local
+ virbr0 IPv4 Samsung ML-1610 @ pcdesktop1                  Stampante UNIX       local
+  p19p1 IPv4 Samsung ML-1610 @ pcdesktop1                  Stampante UNIX       local
+ virbr0 IPv4 pcdesktop1                                    Remote Disk Management local
+  p19p1 IPv4 pcdesktop1                                    Remote Disk Management local

from Fujiantonio

[antonio@Fujiantonio ~]$ avahi-browse -a
+ virbr0 IPv4 antonio's remote desktop on Fujiantonio       Controllo remoto VNC local
+ wlp1s0 IPv4 antonio's remote desktop on Fujiantonio       Controllo remoto VNC local
+ wlp1s0 IPv4 antonio's remote desktop on pcdesktop1        Controllo remoto VNC local
+ virbr0 IPv4 antonio's public files on Fujiantonio         WebDAV Condivisione File local
+ wlp1s0 IPv4 antonio's public files on Fujiantonio         WebDAV Condivisione File local
+ wlp1s0 IPv4 antonio's public files on pcdesktop1          WebDAV Condivisione File local
+ virbr0 IPv4 Fujiantonio                                   Sito Web             local
+ wlp1s0 IPv4 Fujiantonio                                   Sito Web             local
+ wlp1s0 IPv4 pcdesktop1                                    Sito Web             local
+ virbr0 IPv4 CUPS-PDF @ Fujiantonio                        Internet Printer     local
+ wlp1s0 IPv4 Samsung ML-1610 @ pcdesktop1                  Internet Printer     local
+ wlp1s0 IPv4 CUPS-PDF @ Fujiantonio                        Internet Printer     local
+ virbr0 IPv4 CUPS-PDF @ Fujiantonio                        _ipps._tcp           local
+ wlp1s0 IPv4 Samsung ML-1610 @ pcdesktop1                  _ipps._tcp           local
+ wlp1s0 IPv4 CUPS-PDF @ Fujiantonio                        _ipps._tcp           local
+ virbr0 IPv4 CUPS-PDF @ Fujiantonio                        Stampante UNIX       local
+ wlp1s0 IPv4 Samsung ML-1610 @ pcdesktop1                  Stampante UNIX       local
+ wlp1s0 IPv4 CUPS-PDF @ Fujiantonio                        Stampante UNIX       local
+ virbr0 IPv4 Fujiantonio                                   Remote Disk Management local
+ wlp1s0 IPv4 pcdesktop1                                    Remote Disk Management local
+ wlp1s0 IPv4 Fujiantonio                                   Remote Disk Management local

I guess that is a problem of avahi... ;-) but no solution on my side...

I see that avahi doesn't broadcast shares...
An additional probelm seems that in vinagre if I try to connect by name I get a timeout in avahi solver. I don't know if correlated. Shall I close this bug and move to avahi??
Tnx for help
Comment 14 Ondrej Holy 2015-10-27 05:46:15 EDT
(In reply to antonio montagnani from comment #13)
> (snip)
>
> I see that avahi doesn't broadcast shares...
> An additional probelm seems that in vinagre if I try to connect by name I
> get a timeout in avahi solver. I don't know if correlated. Shall I close
> this bug and move to avahi??
> Tnx for help

Please close the bug if you can't reproduce the original issue. There is something wrong with your network configuration, I am not sure this is avahi issue, it is rather something more general like firewall etc. It would be better to discuss it on some mailing list, or forum...
Comment 15 antonio montagnani 2015-10-27 09:42:43 EDT
the bug can be reproduced : I think that there is nothing wrong with my network (that in my understanding is a pretty standard Fedora installation). But I resumed everything here...

https://bugzilla.redhat.com/show_bug.cgi?id=1274924
Comment 16 antonio montagnani 2015-11-04 12:21:40 EST
this bug has been superseded by bug https://bugzilla.redhat.com/show_bug.cgi?id=1274924

*** This bug has been marked as a duplicate of bug 1274924 ***

Note You need to log in before you can comment on or make changes to this bug.