Bug 1268609 - 'dnf upgrade' finds no updates but 'dnf upgrade *' does.
'dnf upgrade' finds no updates but 'dnf upgrade *' does.
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
23
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-03 11:42 EDT by Ian Morgan
Modified: 2015-10-14 14:17 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-13 10:02:56 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ian Morgan 2015-10-03 11:42:50 EDT
Description of problem:

'dnf upgrade' shows that there are no updates available when there really are. I can see that the downloaded metadata contains information about new package versions, but even a 'dnf info <package name>' only shows the old package version available.

But, if I 'dnf upgrade <fully-qualified-package-name-with-version>', then it _will_ find and install the new version. To force a proper upgrade, I have to 'dnf upgrade *'. This wildcard upgrade takes a long time to process (a couple of minutes), but then does eventually show all of the available package updates.


Version-Release number of selected component (if applicable):

$ dnf --version
1.1.2
  Installed: dnf-0:1.1.2-2.fc23.noarch at 2015-09-23 20:21
  Built    : Fedora Project at 2015-09-22 14:17

  Installed: rpm-0:4.13.0-0.rc1.3.fc23.x86_64 at 2015-09-23 19:50
  Built    : Fedora Project at 2015-09-07 16:01


How reproducible:

Always.


Steps to Reproduce:
1. Install F23 Beta
2. Ensure the fedora-updates-testing repo is enabled.
3. Run 'dnf upgrade'. Nothing is updated.

Actual results:

Cannot update any package unless explicitly named or matched with a pattern. Plain 'dnf upgrade' never finds any updates.

Expected results:

Expect available updates to be presented and updated.

Additional info:
Comment 1 Petr Pisar 2015-10-07 03:19:16 EDT
I have similar issue with dnf-1.1.2-2.fc24. I built updated perl locally with increased release number, put the binary packages into a local repository and tried to `dnf -v --enablerepo=perl --best --allowerasing upgrade'. It does not report anything for upgrade.

However, request for upgrading a specific package by a package name, e.g `dnf -v --enablerepo=perl --best --allowerasing upgrade perl' will offer the new perl package and its dependencies. It forgets for another other newer packages available in the local repository.

In contrast to the original reported, `dnf -v --enablerepo=perl --best --allowerasing info perl' reports both current perl from @System repository and the new perl from perl repository.

It looks like dnf does not consult any installed package for an upgrade. It consults only packages explicitly listed on the command line.
Comment 2 Jaroslav Mracek 2015-10-13 10:02:56 EDT
This is known issue for the release and it was replaced by newer version that solved the problem. We are sorry for difficulties. To update to new version of dnf, please use 'dnf upgrade dnf', than everything should work correctly.
Comment 3 Ian Morgan 2015-10-13 10:54:06 EDT
Jaroslav,

The latest available build appears to be dnf-1.1.2-4.fc23, which I installed on October 6th (a week ago).

See http://koji.fedoraproject.org/koji/packageinfo?packageID=14310

As of this morning, using dnf-1.1.2-4, I still could not update packages without using the wildcard workaround described earlier.

What "new version" of dnf corrects this issue, and where do we find it?
Comment 4 Jaroslav Mracek 2015-10-13 12:04:45 EDT
Dear Ian,

Please are you sure about installed version of dnf (rpm -q dnf)? With version dnf-1.1.2-4.fc23 we were unable reproduce your problem. Please try also 'dnf upgrade --refresh' it could also help.
Comment 5 Ian Morgan 2015-10-13 12:41:45 EDT
Jaroslav,

Yes, the installed DNF is really up-to-date:

$ rpm -q dnf
dnf-1.1.2-4.fc23.noarch

$ dnf --version
1.1.2
  Installed: dnf-0:1.1.2-4.fc23.noarch at 2015-10-06 16:07
  Built    : Fedora Project at 2015-09-30 13:56

  Installed: rpm-0:4.13.0-0.rc1.4.fc23.x86_64 at 2015-10-13 13:03
  Built    : Fedora Project at 2015-10-12 13:48


Since I had to do a forced upgrade with the * wildcard this morning, all packages are currently up-to-date, therefore 'dnf upgrade --refresh' did re-download all the metadata but did not find anything new.

I will monitor the metadata for new updates over the next day or two and try again when there are some.
Comment 6 Ian Morgan 2015-10-14 14:17:34 EDT
Well, for whatever reason, it worked today. A plain 'dnf upgrde --refresh' found and applied updates without using the wildcard trick.

I can now concur that this issue is resolved.

Note You need to log in before you can comment on or make changes to this bug.