Bug 1268687 - [Docs] [Director] Configuring after overcloud creation incorrect str_replace parameters in example
[Docs] [Director] Configuring after overcloud creation incorrect str_replace ...
Status: CLOSED CURRENTRELEASE
Product: Red Hat OpenStack
Classification: Red Hat
Component: documentation (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
medium Severity medium
: async
: 7.0 (Kilo)
Assigned To: Dan Macpherson
: Documentation
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-04 14:14 EDT by Ramon Acedo
Modified: 2015-12-15 23:53 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-15 23:53:19 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ramon Acedo 2015-10-04 14:14:28 EDT
In section 8.2 the example uses str_replace incorrectly and when applying the suggested modification it fails:

$ openstack overcloud deploy --templates -e ~/templates/post_config.yaml
Deploying templates in the directory /usr/share/openstack-tripleo-heat-templates
ERROR: openstack ERROR: Failed to validate: Failed to validate: u'"str_replace" syntax should be str_replace:\n              template: This is var1 template var2\n              params:\n                var1: a\n                var2: string'

The reason seems to be that it uses str_replace with "parameters" instead of "params" as documented in:

 http://docs.openstack.org/developer/heat/template_guide/hot_spec.html#str-replace 

str_replace:
  template: <template string>
  params: <parameter mappings>
Comment 2 Andrew Dahms 2015-10-07 20:45:49 EDT
Assigning to Dan for review.
Comment 5 Ramon Acedo 2015-10-15 03:51:03 EDT
Yes, that matches my working configuration and upstream documentation at http://docs.openstack.org/developer/heat/template_guide/hot_spec.html#str-replace

Note You need to log in before you can comment on or make changes to this bug.