Bug 126878 - RPM needs the ability to filter dependencies from the specfile
RPM needs the ability to filter dependencies from the specfile
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
Mike McLean
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-28 13:53 EDT by Chip Turner
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-28 16:47:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chip Turner 2004-06-28 13:53:49 EDT
Frequent need for dependency filtering has shown there is a legitimate need to filter 
dependencies in specfiles.  In particular, so long as RPM autogenerates dependencies, 
there needs to be a way to filter them, such as:

NoRequire: perl(Win32::wibble)

and

NoProvides: perl(OS2::wobble)

Other files that have autogenerated dependencies may benefit from this as well, as would 
pieces of software with optional components that do not inhibit main functionality but 
would require a hard dependency otherwise.
Comment 1 Jeff Johnson 2004-06-28 16:47:31 EDT
Heh.

Adding features to grammar-less spec files causes major
disruptions for all, not just Red Hat, rpm users. In addition,
new, and incompatible, syntax creates an instant need for
a version of rpm that understands that syntax.

While it is quite possible to introduce an incompatible feature
in a new version of rpm, at the moment there is no release
framework in place for rpm at all, nor are there any plans
for a new version of rpm.

Next the real need is to analyze (and fix) the automagic
perl dependency extraction tools which are creating the
(false imho) need for filtering in the first place. That
effort must be approached for all perl modules, not
by adding another band-aid to conceal the real problem.

Finally, it plain and simply is not that hard to write
a couple of line script to filter dependencies, that
mechanism has been working adequately since RHL 7.2, and
is known good.

WONTFIX if you ask me. Shop your answer elsewhere, please, if you
want, either internal to Red Hat, or on <rpm-devel@colug.net>,
perhaps you can convince someone other than me of your need. 
Comment 2 Enrico Scholz 2006-02-23 02:32:51 EST
> Finally, it plain and simply is not that hard to write
> a couple of line script to filter dependencies,

It is very hard with recent rpm versions. Using things like

| %global _use_internal_dependency_generator 0

and corresponding %__find_requires/%__find_provides (which would be needed for
dep-filters) is heavily discouraged by you (jbj) because the internal
dep-generator is more powerful and generates e.g. per-file dependencies.

Note You need to log in before you can comment on or make changes to this bug.