Bug 1268824 - Uncheck "Format Domain, i.e. Storage Content will be lost!" by default
Uncheck "Format Domain, i.e. Storage Content will be lost!" by default
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: Frontend.WebAdmin (Show other bugs)
3.6.0.1
All All
unspecified Severity high (vote)
: ovirt-3.6.1
: 3.6.1
Assigned To: Maor
Natalie Gavrielov
storage
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-05 07:51 EDT by Christopher Pereira
Modified: 2016-02-10 12:52 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-16 07:24:03 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
amureini: ovirt‑3.6.z?
rule-engine: ovirt‑4.0.0+
ylavi: planning_ack+
rule-engine: devel_ack+
acanan: testing_ack+


Attachments (Terms of Use)
snapshot after the fix (55.81 KB, image/png)
2015-12-16 04:56 EST, Natalie Gavrielov
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 47317 None DRAFT webadmin: uncheck format checkbox on remove SD. Never
oVirt gerrit 47420 master MERGED webadmin: Make the Format checkbox false by default. Never
oVirt gerrit 47477 ovirt-engine-3.6 MERGED webadmin: Make the Format checkbox false by default. Never

  None (edit)
Description Christopher Pereira 2015-10-05 07:51:19 EDT
When removing a Storage Domain, please uncheck the "Format Domain, i.e. Storage Content will be lost!" checkbox by default.

Data loss risk is to high for users who move Storage Domains between Data Centers.
Comment 1 Allon Mureinik 2015-10-14 03:57:11 EDT
Maor - didn't we do this already?
If not - please let's do it.
Comment 2 Maor 2015-10-14 04:39:58 EDT
(In reply to Allon Mureinik from comment #1)
> Maor - didn't we do this already?
> If not - please let's do it.

We did this to keep the default behavior (before the import storage domain feature) consistent.
The idea behind this was that most of the use cases of removing a Storage Domain will most likely be to format it.
Comment 3 Allon Mureinik 2015-10-14 04:53:29 EDT
Fair enough. I'm assuming the technical side is as trivial as changing a boolean, so this becomes a product decision.

Yaniv/Einav, your two cents?
Comment 4 Einav Cohen 2015-10-14 06:43:01 EDT
I personally agree with Maor, but Yaniv has the final call.
Comment 5 Maor 2015-10-14 06:50:50 EDT
(In reply to Allon Mureinik from comment #3)
> Fair enough. I'm assuming the technical side is as trivial as changing a
> boolean, so this becomes a product decision.

I've uploaded a draft patch that changes the default value, just in case.
At the worst case I will abandon it later

> 
> Yaniv/Einav, your two cents?
Comment 6 Yaniv Lavi 2015-10-14 08:45:17 EDT
No customer request to change this, so let's keep the default we have.
Comment 7 Allon Mureinik 2015-10-14 09:45:48 EDT
Agreed, the value of preserving the history behavior outweighs this request, closing.
Comment 8 Christopher Pereira 2015-10-14 10:02:22 EDT
(In reply to Yaniv Dary from comment #6)
> No customer request to change this, so let's keep the default we have.

Yaniv, please explain customer that if he removes a storage domain and accidentally presses "ok" without unchecking the checkbox, he will immediately lose all VM data. There is no alert prompt before everything is erased.

rm / -rf
Comment 9 Yaniv Lavi 2015-10-15 03:34:03 EDT
Since it is coming for a user of the system this changes the picture.
I would change the default if it bothers oVirt users.
Comment 10 Red Hat Bugzilla Rules Engine 2015-10-19 06:51:37 EDT
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.
Comment 11 Allon Mureinik 2015-10-20 00:18:17 EDT
This patch was merged to the ovirt-engine-3.6 branch after the 3.6.0 split. It will be part of oVirt 3.6.1.
Comment 12 Natalie Gavrielov 2015-12-16 04:54:30 EST
Verified, rhevm-3.6.1.3-0.1.el6.noarch (build 3.6.1-4)
Now, when deleting a storage domain - "Format Domain" is unchecked by default.
Comment 13 Natalie Gavrielov 2015-12-16 04:56 EST
Created attachment 1106344 [details]
snapshot after the fix
Comment 14 Sandro Bonazzola 2015-12-16 07:24:03 EST
According to verification status and target milestone this issue should be fixed in oVirt 3.6.1. Closing current release.

Note You need to log in before you can comment on or make changes to this bug.