Bug 1268856 - [abrt] dnf: package.py:108:repo:KeyError: '@commandline'
[abrt] dnf: package.py:108:repo:KeyError: '@commandline'
Status: CLOSED DUPLICATE of bug 1226766
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
23
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:19fa9d99dcbcad4b51834694329...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-05 09:07 EDT by Martín Cigorraga
Modified: 2015-10-13 10:10 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-13 10:10:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (1.22 KB, text/plain)
2015-10-05 09:07 EDT, Martín Cigorraga
no flags Details
File: environ (2.46 KB, text/plain)
2015-10-05 09:07 EDT, Martín Cigorraga
no flags Details

  None (edit)
Description Martín Cigorraga 2015-10-05 09:07:41 EDT
Version-Release number of selected component:
dnf-1.1.1-2.fc23

Additional info:
reporter:       libreport-2.6.2
cmdline:        /usr/bin/python3 -OO /bin/dnf install fedmsg-0.16.1-4.fc23.noarch.rpm fedmsg-announce-0.16.1-4.fc23.noarch.rpm fedmsg-base-0.16.1-4.fc23.noarch.rpm fedmsg-collectd-0.16.1-4.fc23.noarch.rpm fedmsg-gateway-0.16.1-4.fc23.noarch.rpm fedmsg-hub-0.16.1-4.fc23.noarch.rpm fedmsg-irc-0.16.1-4.fc23.noarch.rpm fedmsg-relay-0.16.1-4.fc23.noarch.rpm python-fedmsg-commands-0.16.1-4.fc23.noarch.rpm python-fedmsg-consumers-0.16.1-4.fc23.noarch.rpm python-fedmsg-core-0.16.1-4.fc23.noarch.rpm python3-fedmsg-core-0.16.1-4.fc23.noarch.rpm
executable:     /bin/dnf
kernel:         4.2.2-300.fc23.x86_64
runlevel:       N 5
type:           Python3
uid:            0

Truncated backtrace:
package.py:108:repo:KeyError: '@commandline'

Traceback (most recent call last):
  File "/bin/dnf", line 35, in <module>
    main.user_main(sys.argv[1:], exit_code=True)
  File "/usr/lib/python3.4/site-packages/dnf/cli/main.py", line 198, in user_main
    errcode = main(args)
  File "/usr/lib/python3.4/site-packages/dnf/cli/main.py", line 84, in main
    return _main(base, args)
  File "/usr/lib/python3.4/site-packages/dnf/cli/main.py", line 144, in _main
    ret = resolving(cli, base)
  File "/usr/lib/python3.4/site-packages/dnf/cli/main.py", line 183, in resolving
    base.plugins.run_transaction()
  File "/usr/lib/python3.4/site-packages/dnf/plugin.py", line 82, in fn
    dnf.util.mapall(operator.methodcaller(method), self.plugins)
  File "/usr/lib/python3.4/site-packages/dnf/util.py", line 157, in mapall
    return list(map(fn, *seq))
  File "/usr/lib/python3.4/site-packages/dnf-plugins/local.py", line 119, in transaction
    if pkg.repo.pkgdir == repodir:
  File "/usr/lib/python3.4/site-packages/dnf/package.py", line 108, in repo
    return self.base.repos[self.reponame]
KeyError: '@commandline'

Local variables in innermost frame:
self: <hawkey.Package object id 66368, fedmsg-announce-0.16.1-4.fc23.noarch, @commandline>
Comment 1 Martín Cigorraga 2015-10-05 09:07:46 EDT
Created attachment 1079938 [details]
File: backtrace
Comment 2 Martín Cigorraga 2015-10-05 09:07:47 EDT
Created attachment 1079939 [details]
File: environ
Comment 3 Honza Silhan 2015-10-13 10:10:38 EDT

*** This bug has been marked as a duplicate of bug 1226766 ***

Note You need to log in before you can comment on or make changes to this bug.