Bug 1268922 - Sites redirect to a '/app'
Sites redirect to a '/app'
Status: CLOSED NOTABUG
Product: OpenShift Online
Classification: Red Hat
Component: Networking (Show other bugs)
2.x
Unspecified Unspecified
unspecified Severity low
: ---
: ---
Assigned To: Miciah Dashiel Butler Masters
Meng Bo
:
Depends On:
Blocks: 1277547
  Show dependency treegraph
 
Reported: 2015-10-05 12:21 EDT by Ryan Howe
Modified: 2016-01-11 09:28 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-11 09:28:13 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ryan Howe 2015-10-05 12:21:15 EDT
Description of problem:

- Sites redirect to a '/app'

Version-Release number of selected component (if applicable):
Online 

How reproducible:
Unable to reproduce

Actual results:
- At times Alias will redirect to /app


Expected results:
- Nothing redirected to /app

Additional info:

Still trying to pin point/recreate issue
Comment 1 Andy Grimm 2016-01-05 16:48:21 EST
A bit of clarification here:

Redirection to /app is something that happens specifically in OpenShift Online when the front-end apache server thinks that the Host in the HTTP request does not match any VirtualHost definitions.  so, for example, if you hit:

http://ex-std-node500.prod.rhcloud.com/

it will redirect you to:

https://ex-std-node500.prod.rhcloud.com/app

As far as I know, this is a relic from the all-in-one dev environments, where accessing the host by its hostname takes you to the OpenShift console.

We can remove or change this redirect.  It should be raising a 5xx status instead.  The problem remains, though, that on a couple of nodes, we are seeing hits apparently 'fall through' the VirtualHost definitions to this redirect.  It's only happening for about one out of every 30,000 hits.  That's really what this bug is about.
Comment 2 Andy Grimm 2016-01-11 09:28:13 EST
After improving our logging, I do not believe there is a bug in Apache or OpenShift.  If anything, the bug is in varnish, and the varnish binaries are part of the downloadable cartridge.

Note You need to log in before you can comment on or make changes to this bug.