Bug 1268925 - iPXE boot from Satellite 6 boot image fails for KVM
iPXE boot from Satellite 6 boot image fails for KVM
Status: CLOSED NOTABUG
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Bootdisk Plugin (Show other bugs)
6.1.1
x86_64 Linux
low Severity low (vote)
: Unspecified
: --
Assigned To: Katello Bug Bin
http://projects.theforeman.org/issues...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-05 12:27 EDT by Chris Roberts
Modified: 2016-04-22 12:56 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-15 08:51:52 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Foreman Issue Tracker 12075 None None None 2016-04-22 12:56 EDT

  None (edit)
Description Chris Roberts 2015-10-05 12:27:38 EDT
Description of problem:

I've created a boot image for a VM installation, largely based on instructions from https://access.redhat.com/blogs/1169563/posts/1185403

When I try to boot the KVM image off the ISO image created by Satellite 6, I get an error, which is detailed here:

http://forums346.rssing.com/browser.php?indx=7254081&item=414

Is there an updated ROM image available for KVM on RHEL 6.6 that uses iPXE instead of gPXE?  I see some people have built an ipxe-roms-qemu package for Centos or Fedora, but is there an equivalent for RHEL?

Version-Release number of selected component (if applicable):

Installed Packages

candlepin-0.9.49.6-1.el6.noarch
candlepin-common-1.0.22-1.el6.noarch
candlepin-scl-1-5.el6_4.noarch
candlepin-scl-quartz-2.1.5-5.el6_4.noarch
candlepin-scl-rhino-1.7R3-1.el6_4.noarch
candlepin-scl-runtime-1-5.el6_4.noarch
candlepin-selinux-0.9.49.6-1.el6.noarch
candlepin-tomcat6-0.9.49.6-1.el6.noarch
elasticsearch-0.90.10-7.el6.noarch
foreman.example.com-qpid-broker-1.0-1.noarch
foreman.example.com-qpid-client-cert-1.0-1.noarch
foreman.example.com-qpid-router-client-1.0-1.noarch
foreman.example.com-qpid-router-server-1.0-1.noarch
katello-2.2.0.16-1.el6_6sat.noarch
katello-certs-tools-2.2.1-1.el6_6sat.noarch
katello-common-2.2.0.16-1.el6_6sat.noarch
katello-debug-2.2.0.16-1.el6_6sat.noarch
katello-default-ca-1.0-1.noarch
katello-installer-2.3.18-1.el6_6sat.noarch
katello-installer-base-2.3.18-1.el6_6sat.noarch
katello-server-ca-1.0-1.noarch
katello-service-2.2.0.16-1.el6_6sat.noarch
libqpid-dispatch-0.4-7.el6.x86_64
mod_wsgi-3.4-1.pulp.el6sat.x86_64
pulp-docker-plugins-0.2.5-1.el6_6sat.noarch
pulp-katello-0.5-1.el6_6sat.noarch
pulp-nodes-common-2.6.0.15-1.el6_6sat.noarch
pulp-nodes-parent-2.6.0.15-1.el6_6sat.noarch
pulp-puppet-plugins-2.6.0.15-1.el6_6sat.noarch
pulp-puppet-tools-2.6.0.15-1.el6_6sat.noarch
pulp-rpm-plugins-2.6.0.15-1.el6_6sat.noarch
pulp-selinux-2.6.0.15-1.el6_6sat.noarch
pulp-server-2.6.0.15-1.el6_6sat.noarch
python-gofer-qpid-2.6.2-2.el6_6sat.noarch
python-isodate-0.5.0-4.pulp.el6_6sat.noarch
python-kombu-3.0.24-10.pulp.el6_6sat.noarch
python-pulp-bindings-2.6.0.15-1.el6_6sat.noarch
python-pulp-common-2.6.0.15-1.el6_6sat.noarch
python-pulp-docker-common-0.2.5-1.el6_6sat.noarch
python-pulp-puppet-common-2.6.0.15-1.el6_6sat.noarch
python-pulp-rpm-common-2.6.0.15-1.el6_6sat.noarch
python-qpid-0.30-6.el6.noarch
python-qpid-qmf-0.30-5.el6.x86_64
qpid-cpp-client-0.30-9.el6.x86_64
qpid-cpp-client-devel-0.30-9.el6.x86_64
qpid-cpp-server-0.30-9.el6.x86_64
qpid-cpp-server-linearstore-0.30-9.el6.x86_64
qpid-dispatch-router-0.4-7.el6.x86_64
qpid-java-client-0.30-3.el6.noarch
qpid-java-common-0.30-3.el6.noarch
qpid-proton-c-0.9-4.el6.x86_64
qpid-qmf-0.30-5.el6.x86_64
qpid-tools-0.30-4.el6.noarch
ruby193-rubygem-katello-2.2.0.67-1.el6_6sat.noarch
ruby193-rubygem-qpid_messaging-0.30.0-1.el6_6sat.x86_64
rubygem-hammer_cli_katello-0.0.7.17-1.el6_6sat.noarch
rubygem-smart_proxy_pulp-1.0.1.2-1.el6_6sat.noarch
Comment 2 Bryan Kearney 2015-10-06 13:40:55 EDT
Created redmine issue http://projects.theforeman.org/issues/12075 from this bug
Comment 3 Lukas Zapletal 2015-10-07 04:03:50 EDT
For the record, this is usually a bug in the hypervisor itself, upgrade libvirt, or more specifically, upgrade QEMU PXE firmware which is known to be problematic with more recent versions of iPXE (we use 1.x version).

PXE-less discovery will solve this, coming out in Feature Errata next month.
Comment 4 Bryan Kearney 2015-10-15 08:51:52 EDT
Based on comment 3, I am closing this out as not a bug. Please see 6.1.4 which will include pxeless discovery.
Comment 5 Lukas Zapletal 2015-10-20 05:06:30 EDT
Additional note, RHEL 7 fully supports iPXE (it's part of the platform). We advice to migrate Satellite to RHEL7 to get better iPXE support.

Note You need to log in before you can comment on or make changes to this bug.