Bug 1268963 - Can't set action to be made when battery's level is critical
Can't set action to be made when battery's level is critical
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: control-center (Show other bugs)
22
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Control Center Maintainer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-05 14:18 EDT by Giulio 'juliuxpigface'
Modified: 2015-10-09 09:35 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-09 09:35:58 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Giulio 'juliuxpigface' 2015-10-05 14:18:57 EDT
Description of problem:
I can't set the action to be automatically made by Gnome when battery's level is critical. Nothing seems to happen when I click on the appropriate option.

Version-Release number of selected component (if applicable):
gnome-shell-3.16.3-1.fc22.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Boot a laptop which has got a battery inserted.
2. Log in to Gnome.
3. Open the power management GUI.
4. Go to the bottom of the menu and click on the option which allows users to customize the action to be made when battery's level is critical.

Actual results:
Nothing happens.

Expected results:
User should be able to switch from the default "hibernate" to "shutdown" or "suspend".

Additional info:
There seems to be a workaround, for example:

$ gsettings set org.gnome.settings-daemon.plugins.power critical-battery-action "shutdown"
Comment 1 Florian Müllner 2015-10-08 06:41:10 EDT
(In reply to Giulio 'juliuxpigface' from comment #0)
> Steps to Reproduce:
> 1. Boot a laptop which has got a battery inserted.
> 2. Log in to Gnome.
> 3. Open the power management GUI.

Assuming this refers to Settings' power panel, so reassigning there - could also be a gnome-settings-daemon issue, but not gnome-shell.
Comment 2 Bastien Nocera 2015-10-09 09:35:58 EDT
That's done in /etc/UPower/UPower.conf now, since upower 0.99.x:
http://www.hadess.net/2013/10/more-power-management-changes.html

This has been the case since GNOME 3.12, so brought with Fedora 21.

Note You need to log in before you can comment on or make changes to this bug.