Bug 1269003 - pycdio can't be imported
pycdio can't be imported
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: pycdio (Show other bugs)
23
All Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Jay Greguske
Fedora Extras Quality Assurance
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-05 18:10 EDT by Rob Tomsick
Modified: 2015-11-14 19:23 EST (History)
3 users (show)

See Also:
Fixed In Version: pycdio-0.20-1.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-14 19:23:52 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rob Tomsick 2015-10-05 18:10:34 EDT
Description of problem:
---
The pycdio package as shipped in Fedora 23 appears to be broken.  Attempts to import the module produce an error (see "Actual results" below.)


Version-Release number of selected component: 
---
Package pycdio-0.19-7.fc23.x86_64


How reproducible:
---
Always.


Steps to Reproduce:
---
1. Open a python prompt (run /usr/bin/python)
2. Attempt to import the pycdio module ("import pycdio").


Actual results:
---

Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
  File "/usr/lib64/python2.7/site-packages/pycdio.py", line 128, in <module>
    VERSION_NUM = _pycdio.VERSION_NUM
AttributeError: 'module' object has no attribute 'VERSION_NUM'


Expected results:
---
No output.


Additional info:
---
This problem can also be observed while using a software package which depends on pycdio.  I found this bug using morituri ( https://github.com/thomasvs/morituri ) and attempting to use the "offset" command (which requires pycdio.)
Comment 1 Adam Williamson 2015-11-03 14:22:36 EST
Confirming, I see this on Rawhide also.
Comment 2 Adam Williamson 2015-11-03 14:25:10 EST
Note, the _pycdio object has an attribue VERSION_NUM_swigconstant , so I'm guessing this may be some issue in swig?
Comment 3 Adam Williamson 2015-11-03 14:27:32 EST
I note here:

https://github.com/adamkovics/atmosphere/blob/master/README.md

"Dependencies

    SWIG version 3.0.2 (the most recent version 3.0.5 doesn't work)

Version 3.0.5 creates a _cdisort.so module with "_swigconstant" added inconsistently. Use earlier version instead."

so there's another project which found what looks like the same problem with swig 3.0.5. swig 3.0.5 landed in Fedora shortly before pycdio 0.19-7.fc23 got built, so that timing lines up. I'm gonna see if building with a newer swig solves this, and if not, re-assign to swig.
Comment 4 Fedora Update System 2015-11-03 15:22:57 EST
pycdio-0.20-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-b771bd72ae
Comment 5 Fedora Update System 2015-11-04 20:28:44 EST
pycdio-0.20-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update pycdio'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-b771bd72ae
Comment 6 Fedora Update System 2015-11-14 19:23:49 EST
pycdio-0.20-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.