Bug 1269038 - API documentation contains wrong information.
API documentation contains wrong information.
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Docs API Guide (Show other bugs)
6.1.0
Unspecified Unspecified
medium Severity medium (vote)
: GA
: 6.2
Assigned To: Peter Ondrejka
Russell Dickenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-06 02:01 EDT by jnikolak
Modified: 2016-06-16 00:16 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-16 00:16:40 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description jnikolak 2015-10-06 02:01:43 EDT
Document URL: 

https://access.redhat.com/documentation/en-US/Red_Hat_Satellite/6.1/html/API_Guide/chap-Red_Hat_Satellite-API_Guide-Authentication.html

Section Number and Name: 

Procedure 2.1. Attaining a certificate


Describe the issue: 

There is a type on this documentation.

#######
The default location of self-signed certificates is usually /etc/candlepin/certs/candlepin-ca.crt. 


ls -la /etc/candlepin/certs/candlepin-ca.crt
ls: cannot access /etc/candlepin/certs/candlepin-ca.crt: No such file or directory
#######

There is no candlepin cert in this location

I believe it should be.
/etc/pki/katello/certs/katello-default-ca.crt

So the grep command is pointing to the wrong location.


Then in section 3.
It asks to use curl command
   https://satellite.example.com/katello/api/organizations


Whats the difference between using 
 https://jnikolaksat6rhel6.gsslab.pek.redhat.com/api/v2/organizations
or 
 https://jnikolaksat6rhel6.gsslab.pek.redhat.com/katello/api/organizations
Comment 1 jnikolak 2015-10-06 02:29:46 EDT
I think we should include for the nssdb section, that the certutil command be run from the client.
Comment 2 Andrew Dahms 2016-03-03 17:23:52 EST
Assigning to David for review.
Comment 4 David O'Brien 2016-03-07 18:13:21 EST
Adding Andrew and Jon to need-info for visibility.

This looks like a small update but I'm in my last week before leave and need to get things reviewed/ack'd/etc.

thanks
Comment 5 David O'Brien 2016-03-07 18:52:11 EST
1275128 is now verified and release pending.
Comment 6 David O'Brien 2016-03-08 23:37:20 EST
(In reply to David O'Brien from comment #4)
> Adding Andrew and Jon to need-info for visibility.
> 
> This looks like a small update but I'm in my last week before leave and need
> to get things reviewed/ack'd/etc.
> 
> thanks

in my *2nd-last week* before leave. Sorry.

Still, need to get clarification on this soon.
Comment 9 Andrew Dahms 2016-04-12 09:22:05 EDT
Moving to my queue for now to be re-triaged as the schedule allows.
Comment 10 Andrew Dahms 2016-05-26 07:56:12 EDT
Assigning to Peter for review.

Peter - this is one of the bugs David made some progress on before he left, and I believe we have everything we need to move ahead with this.

Would you be able to take a look?
Comment 12 Andrew Dahms 2016-06-16 00:16:40 EDT
This content is now live on the Customer Portal.

Closing.

Note You need to log in before you can comment on or make changes to this bug.