Bug 1269096 - Unable to successfully add [v 3.6] host to [v 3.5] engine fails during host installation.
Unable to successfully add [v 3.6] host to [v 3.5] engine fails during host i...
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: vdsm (Show other bugs)
3.5.0
Unspecified Linux
unspecified Severity medium
: ovirt-3.6.1
: ---
Assigned To: Eliraz Levi
Meni Yakove
network
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-06 06:43 EDT by mlehrer
Modified: 2016-02-10 14:15 EST (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-22 07:26:45 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Network
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Log of host deploy failure (655.33 KB, text/plain)
2015-10-06 06:43 EDT, mlehrer
no flags Details

  None (edit)
Description mlehrer 2015-10-06 06:43:40 EDT
Created attachment 1080198 [details]
Log of host deploy failure

Description of problem:

Attempt to add 3.6 host to 3.5 engine fails during host setup with the following error 
 "failed to configure management on the host", also " the following networks are missing on the host" rhevm"

Version-Release number of selected component (if applicable):

vdsm-4.17.6-1.el7ev.noarch

How reproducible:
Set up 3.5 engine.
Attempt to add host configured with 3.6


Steps to Reproduce:
1.
2.
3.

Actual results:

Unable to deploy host.

Expected results:

To be able to successfully deploy host.

Additional info:
Comment 1 Yaniv Kaul 2015-10-08 04:36:46 EDT
Is it 3.5.0, 3.5.4, 3.5.5? or doesn't matter and the issue is in the VDSM 3.6 side (and therefore the 'version' field should be 3.6) ?
Comment 2 Dan Kenigsberg 2015-10-18 05:39:56 EDT
Please provide engine version, engine.log, and {super,}vdsm.log. The currently-attached ovirt-host-deploy.log shows no failure afaict.
Comment 3 Yaniv Lavi (Dary) 2015-10-21 05:34:37 EDT
Did you test this flow in 3.6? does it work?
Comment 4 Lukas Svaty 2015-10-21 06:04:19 EDT
reproducible, adding 3.6 host to rhevm-3.5.5-0.1.el6ev.noarch
Comment 5 Lukas Svaty 2015-10-21 06:06:57 EDT
by removing 'ovirtmgmnt' bridge and adding correct 'rhevm' bridge on host will enable 3.6 hosts inside 3.5.5 engine
Comment 6 Yaniv Kaul 2015-10-21 06:11:10 EDT
Lukas, can you please add logs, per comment 2 above?
Comment 8 Lukas Svaty 2015-10-21 07:57:04 EDT
The issue is in bridge through which vdsm connects to hosts. In older version of RHEV-M we used rhevm bridge as a default network connection. In oVirt and RHEV-M-3.6 we use ovirtmgmt bridge. As during host deployment vdsm is unable to attach rhevm bridge to the correct network interface (as it has already a ovirtmgmt bridge) it fails on setup.

Previously I saw some bugs in the past about resolution of default bridge naming, as it should have been moved to ovirtmgmt in oVirt as well as RHEV-M. Do you know what was the resolution in this issue? If we are using different network bridge for oVirt and RHEV-M or it was decided they will be the same?
Comment 9 Dan Kenigsberg 2015-10-21 10:46:19 EDT
What has created the ovirtmgmt bridge on your host?

We do not support adding a host with one management network name into a cluster with another name. Please confirm that prior to deployment, no bridge existed on the host.
Comment 10 mlehrer 2015-10-22 03:25:36 EDT
(In reply to Yaniv Kaul from comment #1)
> Is it 3.5.0, 3.5.4, 3.5.5? or doesn't matter and the issue is in the VDSM
> 3.6 side (and therefore the 'version' field should be 3.6) ?

The environment was used for a different scale bug, and is no longer available.
Comment 11 mlehrer 2015-10-22 03:26:17 EDT
(In reply to Yaniv Kaul from comment #1)
> Is it 3.5.0, 3.5.4, 3.5.5? or doesn't matter and the issue is in the VDSM
> 3.6 side (and therefore the 'version' field should be 3.6) ?

The environment was used for a different scale bug, and is no longer available.
Comment 12 Lukas Svaty 2015-10-22 04:54:43 EDT
ovirtmgmt bridge on host was created by 3.6 engine where host was previously added

Problem is we have different bridges for rhevm-3.5 (rhevm) and rhevm-3.6 (ovirtmgmt).

As mentioned in comment#5 these steps works, so the issue is only in the name of bridge:

1. Remove host from 3.6 engine
2. Remove ovirtmgmt bridge from host
3. Add host to 3.5 engine (which will create rhevm bridge)
Comment 13 Dan Kenigsberg 2015-10-22 07:26:45 EDT
(In reply to Lukas Svaty from comment #12)

> Problem is we have different bridges for rhevm-3.5 (rhevm) and rhevm-3.6
> (ovirtmgmt).

The default bridge name has intentionally changed in 3.6. Cf. bug 1204793.
Comment 14 Lukas Svaty 2015-10-22 07:39:14 EDT
I agree that this indeed is not a but, but by design behaviour, so we will be able to move hosts from ovirt to rhevm and so on.

Note You need to log in before you can comment on or make changes to this bug.