Bug 126910 - no way to change the default keyring
no way to change the default keyring
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: nautilus (Show other bugs)
2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Alexander Larsson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-28 18:53 EDT by Jacques Rodary
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-02 07:18:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jacques Rodary 2004-06-28 18:53:53 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; fr-FR; rv:1.6) Gecko/20040510

Description of problem:
after first opening of SMB share in nautilus, I can't find how to
change the so called "default keyring" (in french � trousseau de cl�s
par d�faut �.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.open "nautilus smb://ns/commun/ (my share)

2. enter key once

3.try to change key after a new login
    

Actual Results:  can't find how/where to change key

Additional info:
Comment 1 Alexander Larsson 2004-08-26 09:54:18 EDT
I'm not sure what you mean? Did the password on commun change? If so,
it should just ask you for the new password if the stored one didn't
work. What is it that you want to change?
Comment 2 Jacques Rodary 2004-08-26 14:03:03 EDT
The first time I tried to open my SMB share in nautilus, on the SMB
server, I gave a password, not a samba password, and could'nt open the
share after rebooting without giving this password again. It's OK now:
I removed ~/.gnome2/keyrings/default.keyring.
Nevertheless, couldn't gnome-keyring be disabled?
Comment 3 Alexander Larsson 2004-09-02 08:15:53 EDT
disable? Its an important, heavily requested feature?

You didn't even reply to my questions. 

This is the way its supposed to work:
a) if you choose to save the password, it'll be saved for later use if
the login succeeds
b) if you have a saved password, that will be tried first when connecting
c) if that doesn't work, you'll be asked for the password as usual.

(None of this requires removing default.keyring)

What part didn't work for you?
Comment 4 Jacques Rodary 2004-09-02 17:33:09 EDT
Sorry, I didn't reply because I didn't undestand your questions. I am
no good at samba. I only use it on a very small private, non routable 
(192.168.1.) network. I don't know what you mean by 'if you choose to
save the password': samba password or keyring password? Just remember
I only want to access the  share on the samba server; the windows part
is OK now (Sorry for my poor english).
Comment 5 Alexander Larsson 2004-09-06 09:23:28 EDT
Aha. So you created a keyring, made up a password for it and forgot
the keyring password?
Comment 6 Jacques Rodary 2004-09-07 07:06:37 EDT
No: I did remember the keyring password, but I would prefer not to be
asked for any password, as it used to be in FC1.
Comment 7 Alexander Larsson 2004-09-07 07:32:16 EDT
Why did you ask for it to be saved in the keyring then?
Comment 8 Jacques Rodary 2004-09-07 17:57:56 EDT
Because when I was asked for a samba password, which is empty, I first
thought that saving it in the default keyring would imply that I would
never be asked again.
Comment 9 Alexander Larsson 2004-09-08 04:03:06 EDT
Thats whats supposed to happen. Although you will be asked for the
password for the keyring (as the saved passwords are encrypted), but
the keyring can contain many passwords.

Note You need to log in before you can comment on or make changes to this bug.