Bug 1269139 - xmgrace is failed to open
xmgrace is failed to open
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: grace (Show other bugs)
23
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: José Matos
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-06 08:40 EDT by RudraB
Modified: 2015-11-26 15:59 EST (History)
3 users (show)

See Also:
Fixed In Version: grace-5.1.25-4.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-26 15:59:32 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
rebuilt rpm (1.07 MB, application/x-rpm)
2015-11-15 02:53 EST, Paul van Maaren
no flags Details

  None (edit)
Description RudraB 2015-10-06 08:40:37 EDT
Description of problem:
xmgrace is failed to open:

$xmgrace 
libXbae was built with LessTif, but is running with Motif!
Use a semistatic binary or compile Grace/libXbae yourself!

Version-Release number of selected component (if applicable):
grace-5.1.25-2.fc23.x86_64
motif-2.3.4-10.fc23.x86_64
lesstif-0.95.2-9.fc23.x86_64

How reproducible:
Every time

Steps to Reproduce:
1.
2.
3.

Actual results:
crashed with error stated above

Expected results:
Should run without any problem

Additional info:
Comment 1 Paul van Maaren 2015-11-13 10:24:50 EST
When I rebuild the rpm from grace-5.1.25-2.fc23.src.rpm using:

rpmbuild -bb grace.spec 

The resulting xmgrace works for me. The distributed xmgrace has two libXm's:

libXm.so.2 => /lib64/libXm.so.2
libXm.so.4 => /lib64/libXm.so.4

The one I build has only one:

libXm.so.4 => /lib64/libXm.so.4

Not sure why though. I have only motif-devel installed.
Comment 2 RudraB 2015-11-14 15:34:21 EST
Hi,
I don't have devel apps installed. Can you kindly share the x86 rpm?
Comment 3 Paul van Maaren 2015-11-15 02:53 EST
Created attachment 1094325 [details]
rebuilt rpm

I was asked to share the rpm
Comment 4 RudraB 2015-11-15 04:02:10 EST
(In reply to Paul van Maaren from comment #3)
> Created attachment 1094325 [details]
> rebuilt rpm
> 
> I was asked to share the rpm

Thanks a lot. Working fine.
Comment 5 RudraB 2015-11-15 04:02:22 EST
(In reply to Paul van Maaren from comment #3)
> Created attachment 1094325 [details]
> rebuilt rpm
> 
> I was asked to share the rpm

Thanks a lot. Working fine.
Comment 6 Fedora Update System 2015-11-15 05:10:55 EST
grace-5.1.25-4.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-3b69f69600
Comment 7 José Matos 2015-11-15 05:15:51 EST
I suspect that the last rebuild was done at the wrong time. :-(

Meanwhile this bug hit at the middle of semester and so it took me a while to answer.

I hope that with the change to open-motif several crashes and graphical glitches are gone.
Comment 8 Fedora Update System 2015-11-16 00:53:33 EST
grace-5.1.25-4.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update grace'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-3b69f69600
Comment 9 Paul van Maaren 2015-11-16 02:06:35 EST
I tried to add the following comment to https://bodhi.fedoraproject.org/updates/FEDORA-2015-3b69f69600 
but it did not appear, so I thought I add it here:

$ su -c 'dnf --enablerepo=updates-testing update grace'

did not work for me, but the following did:

$ wget https://kojipkgs.fedoraproject.org//packages/grace/5.1.25/4.fc23/x86_64/grace-5.1.25-4.fc23.x86_64.rpm 
$ sudo dnf update grace-5.1.25-2.fc23.x86_64 
$ xmgrace

So I think it is fixed.
Comment 10 Paul van Maaren 2015-11-16 02:08:46 EST
Made a cut'n paste error, the second command should have been:

$ sudo dnf update grace-5.1.25-4.fc23.x86_64.rpm 
$ rpm -qf /usr/bin/xmgrace 
grace-5.1.25-4.fc23.x86_64
Comment 11 Fedora Update System 2015-11-26 15:59:29 EST
grace-5.1.25-4.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.